Next Generation Emulation banner
1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi guys. First of all, I just want to say that you've done a really great job with ePSXe, and thanks for giving so many people the opportunity to emulate Playstation games.
Secondly, let me apologise in advance, because this same type of problem has been mentioned many times before (I was a good girl and used the search tool on this forum for like 2 days before finally deciding to post) but so far I haven't managed to find a solution for myself yet. I may have missed some threads though; there seem to be a lot of FF9 threads here so I'm really sorry if I overlooked one that may have my solution.

I'm playing FF9 from an ISO using ePSXe 1.5.2. I have tried various different plugins and the one that gives me the nicest graphics quality is Pete's DX6 D3D Driver 1.76. However, with this plugin the game becomes laggy (this includes video and sound) in battle mode/menu screens. I have played around with settings and managed to fix this problem by changing the off-screen drawing to 1, but then when I enter battle there is no battle menu.
I was just wondering if there is perhaps a way I can make the game stop lagging in these areas, but still be able to see everything I need to see.

Here's my plugin config at the moment (keep in mind I've been playing around with these a lot so they're probably mixed and matched):

Plugin: Pete's DX6 D3D Driver 1.1.76
Author: Pete Bernert
GFX card: NVIDIA RIVA TNT2 Model 64

Resolution/Color:
- 800x600 Fullscreen - [16 Bit]

Textures:
- Default
- Filtering: 0
- Hi-Res textures: 0
- VRam size: 0 MBytes

Framerate:
- FPS limit: on
- Frame skipping: off
- FPS limit: Auto

Compatibility:
- Offscreen drawing: 2
- Framebuffer texture: 2
- Framebuffer access: 0
- Alpha multipass: on
- Mask bit: on
- Advanced blending: hardware

Misc:
- Scanlines: off [0]
- Unfiltered FB: off
- Dithering: on
- Screen smoothing: off
- Full vram: off
- Game fixes: off [00000200]

And, if you need to know some of my computer specs - 128MB ram, AMD Athlon 1.3GHz Processor, Windows ME.
I realise the problem of my game lagging COULD be the fact that I don't have a very good computer/OS, and it's pretty old.

Any help is appreciated, thanks.
 

·
Registered
Joined
·
654 Posts
Did your searches turn up >>> THIS <<< thread?

Because there's at least a couple of configs in there, including mine (plug :) ), and a pointer to the Kane's Domain website where there's more.

Some parameters - especially offscreen drawing and framebuffer ones - can have counterintuitive effects. A higher number does not always mean better quality, and in many cases a very specific combination of settings is needed to get a game to work right.


Dan
 

·
From Love and Limerence
Joined
·
6,574 Posts
The operating system won't affect how well it runs. RAM isn't really too important as long as you have 256MB+ for Windows XP and 128MB+ for the other Windows. That CPU will be fine if you use hardware mode. Now for the graphics, probably not the best. All I can say offhand is to turn the resolution down to 640x480. Maybe try turning off advanced blending and turning down the framebuffer textures (that will lose you the battle swirl). Everything else seems as low as it'll get for the most part.

I'm not certain exactly if that processor can run in software mode or if it'll see slowdown.
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,982 Posts
eh, i'd say use OpenGL for your graphics card. what drivers are you using for that? im not sure what are the best, but i think like the 28.xx detonators are good for that.

and yeah, 640x480 should be a good res.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
hushypushy said:
eh, i'd say use OpenGL for your graphics card.
I have actually tried that plugin, but I hate the way the graphics look. I lose a lot of image quality with that plugin for some reason and I can't figure out how to change it.

I tried what Lord Zedeck said, decided to ditch the battle swirl and turn down the framebuffer textures. It seems to have done the trick, the game runs a LOT more smoothly now. I can't believe it was that easy to fix the problem! I tweaked it so many times and didn't have any success... I feel silly for posting the question now! ;)

Anyway, thanks a lot for your input. I was originally worried I might get yelled at for posting another FF9 problem but you guys have been really great. :)
 

·
From Love and Limerence
Joined
·
6,574 Posts
Well, glad to hear it worked. Most people don't think simply lowering the resolution alone will do it. They asume that since it runs too slow that the card just "doesn't have the power" to keep up no matter what. It's going to strecth to the monitor anyway (in fullscreen) but it has far less ground required to cover and draw on at lower resolutions. That game looks best at that resolution anyway in my opinion.

Also if you want to try, up the filtering to two, four, or six (try them all and see which you like). If you get no slowdowns it's worth it becuase then it makes the 2D backgrounds look less pixelated. Beware that each has it drawbacks too though.

hushypushy, I really can't see TOO much of a difference myself between the two really, but I do prefer OpenGL. The main menu doesn't fade from blue to black on Direct3D too well and other minor factors look odd too, but I don't think it's bad or anything.
 

·
Registered
Joined
·
45 Posts
Have you tried SSSPSX? I tried it on dbhankins suggestion for FF7 which it ran wonderfully. I gave FF9 a test, and it ran flawlessly too! Absolutely 0 slowdown between battles, had the full framebuffer effects and everything. I have a much, much better system than yours and I got slowdown using ePSXe both 1.6.0 and 1.5.2.

I would really suggest giving SSSPSX a try. It has a few rough edges but, at least with FF7 and FF9, it is easily ePSXe's superior when it comes to running the games.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top