Next Generation Emulation banner

1 - 15 of 15 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1 (Edited)
Well, after reading as many FAQs/similar threads as I could find, I've only found part of the answer, so maybe I can solicit a bit more help by posting.

I'm running XP, as the title suggests. The speed is horribly slow with Pete's OpenGL plugin, maybe half a second between frame shifts. Changing to software modem or even a different Pete plugin, like D3D, eliminates this problem, but I'd like to use the OGL one. I read a similar thread where this is caused by CDDA - turning this off did not help a bit. Playing with graphics settings I can't get this to change at all - the D3D plugin runs very fast even with high quality settings, so I'm guessing it's more basic than that.

I've tried both drives I have (36x plain ol', 32x burner) - the burner doesn't give the initial "buffer offest" error the normal one does, but other than that, and this is probably irrelevant, the result is the same.

Any suggestions?

Edited to say: Celeron 400, 128 MB RAM, Viper 550 (16MB AGP TNT), Soundblaster Live!
 

·
Banned
Joined
·
7,778 Posts
Well, you are running it from a CD. That usually hurts speed a bit. Try running it from an ISO.

As for the problems with the OpenGL plugin, it would help to know what hardware and drivers you are using. Some 3D cards run better than others, so this information would really help.

I personally don't see much difference in the D3D and OpenGL plugins. Why do you want to run the OpenGL one so bad?
 

·
Banned
Joined
·
7,778 Posts
Ah, I just read your edit. I used to use a TNT myself. That exact card in fact. I had no problems with the OpenGL plugin. (I do see why you want to use it now).

Try using these settings:

Plugin: Pete's OpenGL Driver 1.1.55

Resolution/Color:
- 640x480 Fullscreen - Desktop changing [16 Bit]
- Keep psx aspect ratio: off

Textures:
- R5G5B5A1
- Filtering: 0
- Caching: 2

Framerate:
- FPS limitation: on
- Frame skipping: off
- FPS limit: Auto

Compatibility:
- Offscreen drawing: 2
- Framebuffer texture: 1
- Alpha multipass: on
- Mask bit: on
- Advanced blending: off

Misc:
- Scanlines: off
- Line mode: off
- Unfiltered FB: on
- Dithering: off
- Full vram: off
- Game fixes: off [00000200]

Also, show me what settings you are using right now, and specifically what games you are trying.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4 (Edited)
The speed is just fine off of the CD (although I do want to see the difference with an ISO), it's just that silly plugin. I really have no reason to use the OpenGL over the D3D one except that I read that the OpenGL one is a bit better for TNT cards - that and it should just work. :p

The system info is at the bottom of my post (I added with an edit so you may have missed it). As for the driver version, it's the one that comes with XP. The newest one screws up Civ3, so I'm not going to update until they fix that bug.

Thanks for the response.

Oh, and a separate problem that's kind of irritating is a screen full of colored pixels at the start of some games (FMV sequences? Haven't tested enough yet). Is that a result of some setting, or should I go get some more info?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Tried the settings you recommended, didn't seem to help at all.

Specifically, I'm trying Chrono Chross, Final Fantasy Tactics, and Xenogears. All seem to display fine graphically (except for that colored pixel jumble across the screen I mentioned earlier), they're just slow slow slow.

I just updated to 1.55 of Pete's plugins - didn't notice the default installer only had 1.52. No difference though.
 

·
Banned
Joined
·
7,778 Posts
I used to have a bunch of green squares in the FMVs in Final Fantasy IX. I assumed that they were a result of a corrupted ISO. My copy was kind of scratched.

My TNT worked flawlessly with Pete's OpenGL. I used driver version 12.41. You can find a copy here:

http://guru3d.com/files/detonator/

I have not tried newer drivers than that as they are optimized for Geforce cards, rather than our old TNTs. XP might pose a problem with this though. I would suggest trying them, and seeing what happens.

I also had the updated BIOS for the card. I don't know if that would help anything or not.
 

·
Banned
Joined
·
7,778 Posts

·
Super Moderator
Joined
·
6,283 Posts
He gave us the name of his problem:WINDOWS DEFAULT DRIVERS!,why do you use them for a video card?
You should try the 12.90,they're really good with TNT cards,or try the old 6.37 too.
 

·
Premium Member
Joined
·
874 Posts
Seems like his actual ogl drivers are not hardware accelerated... easy to check:

go to the ogl plugin config window, push "copy settings to clipboard" and
paste it into some text editor... the beginning of the infos should look like that:

Plugin: Pete's OpenGL Driver 1.1.56
Author: Pete Bernert
Card vendor: NVIDIA Corporation
GFX card: GeForce3/AGP/3DNOW!

if your card vendor/gfx card infos are showing something like "Microsoft", "GDI"
or "Generic OGL", you haven't installed your nvidia drivers properly, or you
used some tweak tool and disabled hw/accel. opengl by accident.
 

·
Super Moderator
Joined
·
6,283 Posts
1.1.56 huh?:)
We'll see what this one looks like.
 

·
Registered
Joined
·
21 Posts
The default drivers installed with XP for nvidia cards have a faulty OpenGL support, if you want to use OpenGL in games you have to switch to the latest Nvidia reference drivers...
 

·
Registered
Joined
·
6 Posts
Discussion Starter #13
This is the copy from the plugin screen:

Plugin: Pete's OpenGL Driver 1.1.55
Author: Pete Bernert
Card vendor: NVIDIA Corporation
GFX card: RIVA TNT/AGP

I caved and updated to the latest NVidia reference drivers (23.11) at everyone's suggestion - fixed the speed problem. Terribly sorry to waste your time with what turned out to be a simple problem. :emb:

The other problem still remains though - no FMV works, I just get a screen full of random colored pixels, even in software mode. This also happens in screens that aren't FMV per se but must do something similar (like the title screen intro in XG - it fades from the screen full of pixels into the title screen). Has this happened to anyone before?

Thanks for the help everyone, I really appreciate it.
 

·
Registered
Joined
·
275 Posts
Try turning on/off the frame buffer updates at the bottom. My old setup (which is still in my sig) would not play mdecs if that option was turned off.. so try checking it and see what happens. That was using D3D though, but its always worth a shot.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #15
Ok, my face is red for the second time today. I missed the MDEC option in the plugin...I checked it and everything runs fine. I'll play with the settings more to see if I can get things optimized, but my two major problems are now solved. I really appreciate everyone's help.
 
1 - 15 of 15 Posts
Top