Next Generation Emulation banner
1 - 1 of 1 Posts

·
TEKKEN LORD
Joined
·
1,287 Posts
the game is older than vista . it just might not be compatible .

anyway ; explain more about this error you are getting , and try to set the setup EXE to xp in compatibility tab
 
1 - 1 of 1 Posts
Top