Next Generation Emulation banner

Xenogears pitch problems.

1292 Views 9 Replies 4 Participants Last post by  Kane
I downloaded ePSXe 1.6.0 to play Xenogears on the computer.

I have the following plugins for it.
- gpuPete3D3
- gpuPeteDX6D3D
- gpuPeteOpenGL
- spuNull2Mixer
- spuPeopsDSound
- spuPeteMidas

Now the video is fine and I think the correct FPS for Xenogears is 50, but the sound is just totally messed up.

Null2 and DSound were skipping, but the sound was mostly correct. Midas has no skipping, but the sound is off. The exact problem seems to be pitch, because the ladies in the beginning movie sounded like men and the captain sounded like a super base. And this is with the settings for the Midas plug-in given on the ePSXe website.

Can anyone reccommend a different sound plug-in for Xenogears or tell me the correct configuration so that I can hear this right?
1 - 2 of 10 Posts
Well knowing what your CPU speed is, and what graphics and sound card you have would be helpful, but generaly the most reliable plugins for that game are Pete's OpenGL 1.75, and Eternal SPU 1.41. The sound skipping can be alliviated by increasing hte buffer size in Eternal or PEOPs Dsound (I use 22). The problem with increasing the buffer is it increases lag
Use a program like CDRWin or ISOBuster
1 - 2 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.