Next Generation Emulation banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
I've been trying to fix Microsoft's awful support of the Xbox Series controller when connected through bluetooth with x360ce (All games version), and so far I haven't had any success. The problems I've been facing are really obscure and I haven't found any documentation for this online. The device is recognized by the program and works in the menu, I can control it and all. I have installed the ViGEm Bus and HID Guardian, I have enabled the mapped device, and when I go to game controllers in control panel, and check the output on "Controller (XBOX 360 For Windows)" it shows no movement. I'm not sure if it's supposed to do that, but when I enter into a game, I hear a device connecting sound in windows (sometimes) and it doesn't work, so I doubt it. When I go back to check the program, my mapping is gone, It just deletes every button mapping when I open a game, not like I'm losing anything important with it, but this one leaves me stumped as to why it would do that. Also HID Guardian doesn't work at all and refuses to block the controller even if I tick the "hide" box manually, when I check "show hidden devices" it tells me there isn't any, I even tried adding it in the registry editor and it still doesn't block it. This program is supposed to create a virtual controller, and make it do the things my controller does with the mapped buttons, but it refuses to do that for some reason. I've given up trying to fix this on my own, I have no idea what the problem even is, let alone how to fix it, the only guess I have is the program is designed to convert Dinput to Xinput so converting Xinput into a different type of Xinput causes some problems, but it does show the mappings working in the GUI so I would find it strange if that were the case.
 

·
Registered
Joined
·
1 Posts
I'm with the same problem, trying to avoid the windows mess of controllers number with 4 Xbox series controllers, it works on X360CE GUI but on Windows not response at all. Did anyone find a solution?
 
1 - 2 of 2 Posts
Top