Next Generation Emulation banner
1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi All,

I am trying to use x360ce to use my Speedlink Black Widow in Train Sim World 2 (TSW2).
In the x360ce gui the throttle is identified without any problems (IAxis 3).
Moving the throttle makes the right counter goes from 0 to 255, so this seems to work OK.
When starting TSW2 and moving the throttle forward a little bit, this will make the throttle go to the maximum setting and will not move again. It is like it is constantly receiving the instruction to increase throttle more.
Only in the full idle position (zero) the Max Throtle message disappears, so it seams no instruction is given then.

Has anyone of you been able to use this version of x360ce with TSW2 without issues?
Does anyone know how to solve my problem. It is probably something small, but I cannot figure it out. Your help is appreciated.

Kind regards,

Daniel
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #2 ·
When a TeamViewer session is needed, in case a developer does not have this game, I can do this.

Alternatively TSW2 is on sale for 6 euro on Steam until Jan ~5 2022.
 

·
WORLD of JOYSTICKS
Joined
·
61 Posts
Hi All,

I am trying to use x360ce to use my Speedlink Black Widow in Train Sim World 2 (TSW2).
In the x360ce gui the throttle is identified without any problems (IAxis 3).
Moving the throttle makes the right counter goes from 0 to 255, so this seems to work OK.
When starting TSW2 and moving the throttle forward a little bit, this will make the throttle go to the maximum setting and will not move again. It is like it is constantly receiving the instruction to increase throttle more.
Only in the full idle position (zero) the Max Throtle message disappears, so it seams no instruction is given then.

Has anyone of you been able to use this version of x360ce with TSW2 without issues?
Does anyone know how to solve my problem. It is probably something small, but I cannot figure it out. Your help is appreciated.

Kind regards,

Daniel
Try World of Joysticks, it does everything.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Tried that before, but could not get it to work correctly.
I have now installed per readme again (not running the hidehidedriver as not sure when needed).
I have assigned just the right trigger, which is the most important for me as it is what is used to drive the train.

When in game mode, the game becomes very sluggish, FPS drop probably, and when I move the gamepad (SL-6640-SBK) lever forward, nothing happens and when I move it backwards just a bit, the lever in the game travels to the most forward position and stays there, whatever I do with the gamepad lever.

Pls can you help me configure it correctly?

This is the mapping part from xml file:

<Mapping>
<Item0>
<Src>Axis Z</Src>
<Dest>Trigger Right Inverted</Dest>
<Comment></Comment>
<OverlayLine></OverlayLine>
<OverlayRect></OverlayRect>
</Item0>
</Mapping>
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Hi all,

I never touched a xbox controller and just found out that the triggers are actually spring loaded, so are not used at all as a throttle axis.

What I want to do is to use my throttle lever on my flightstick to be able to move the throttle lever in the trains and really hope that DTG will make this possible for us soon.

Regards,

Daniel
 
1 - 5 of 5 Posts
Top