Next Generation Emulation banner
1 - 16 of 16 Posts

·
Sir
Joined
·
51 Posts
Discussion Starter · #1 ·



My God of War is buggy. There's always this weird fog all around when I play the game... I'm using r825 here. :(

Dragon Ball Z Sparking Meteor (Tenkaichi 3) also has the same "fog" transparency fog in the scenarios... It's really annoying :(

Graphical glitches in other games as well such as Final Fantasy X International (look at that hair...). Maybe it's all due to my lack of SSE4 instructions? (Q6600)

Using GSdx DX10 826... with SSSE3.
 

·
Banned
Joined
·
35,081 Posts
Toggle Alpha correction on/off and update to 890 or higher.
 

·
Sir
Joined
·
51 Posts
Discussion Starter · #4 ·
I fixed God of War fog using GSDX 1076m but Tenkaichi 3 only works without the damn white fog in software mode... I heard there's a GSDX version that fixes it too, but I don't know which one. :(

Also, in DX9, I cannot see the water texture in God of War 1... Is there any workaround for it? I really dont like Vista or Windows 7... :(
 

·
From Love and Limerence
Joined
·
6,584 Posts
I've heard the PAL version of Dragonball Z Budokai Tenkaichi 3 has issues with flickering and an overall dark appearance to everything, so I don't know if that's what you mean by fog, but I'm using GSdx 0.1.15 (it identifies itself as GSdx 1479). It's the one that came with the July 8th public beta (I think the latest "public" beta was July 9th). Besides the lack of Black outlines on characters (which I really want to know if it can be fixed) and some few polygons missing on characters or flashing/popping polygons/textures during the beginning of a fight when scenes of the level are being shown, it otherwise displays correctly (I'd say ~98%+ correctly). It looks the same to me in DirectX 9 and DirectX 10, so that can't be it. I've only tried the SSE4.1 plug-in though.

Could you post a screenshot of the Dragonball Z Budokai Tenkaichi 3 fog and the way your plug-in is configured?

Also, the problems with Tidus' hair have to do with the VU recompilers in PCSX2, if I remember right. You can technically get around it by disabling the two main VU recompilers, but then expect a serious speed hit (I'm talking you'll get low single digit frame rates here).
 

·
Sir
Joined
·
51 Posts
Discussion Starter · #6 ·
Here



I didnt play with any settings. Everything default, native resolution checked, 8 bit textures unchecked. Nothing else.

Software mode plays without that damn fog...

And it's just impossible to play with VU recompilers disabled... :p I guess we'll have to leave Tidus hair like that :)
 

·
From Love and Limerence
Joined
·
6,584 Posts
Something odd is going on, because the top half, the "fog", is how the whole screen should look, not the other way around, so I'm willing to bet it's the same for God of War. In other words, you're not having incorrect "fog" show up, but rather the bottom half of the screen isn't rendering as it should, like the middle and top.

I would say try downloading the latest GSdx (unless you already have). If I have 1479 (not sure if that's it's revision number, but it says it's 1479 in the plug-in name, since I don't know how to figure out which revision it is), then you must be a good many revisions behind.
 

·
Registered
Joined
·
11 Posts
the bottom half of the screen isn't rendering as it should, like the middle and top.
Mmmm. I've got somehow similar problems with almost every game I've tried emulating so far: Okami, MGS3, KH2.
But I thought it was because of the graphic card, since my x1950 IS pretty old :)

Can't confirm same glitches in FFX or DBZ, though. I don't own these games.
 

·
From Love and Limerence
Joined
·
6,584 Posts
You know what though? I'm not so sure it is supposed to look like the top as I first thought. I initially thought it was supposed to look like the top, since the bottom part of your screenshot appeared too blurry and washed together from what I remembered of playing it, but as I just got done playing it now, I remembered to take a closer look, and my ground in that level actually looks closer to the bottom in yours, so I think you may be right in that it's supposed to look like the bottom and there's some "fog" messing up the rest.

Here's what mine looks like (800x600 with an internal resolution of 1600x1200 in DirectX 9 mode).



Clearly, it looks closer to how yours looks on the bottom, so I can wager it is the top that's messed up. Maybe yours only looked washed out on the bottom and fooled me since it's in native mode. Going on memory, at the time, the top looked more "accurate" to how it should be. After playing it again, I found out the opposite. My memory for such things isn't always the best.

Either way, at this point, all I can do is ask if you have an ATi card as well, and ask if it's using the latest drivers for it. There seems to be no large number of other ATi users having this problem though.
 

·
Banned
Joined
·
35,081 Posts
Its possibly an Alpha format issue ;) the more alpha channels available the less "fog" would pose a problem, its almost like the alpha is not being applied properly.

and yes, the bottom "Third" of the picture is how the screen should look.
 

·
Banned
Joined
·
35,081 Posts
Not ATI specific, but Texture format specific, even within the nvidia range some cards support more formats than others.

Then, it could also be driver specific, setting specifc etc...

Maybe some of the users are enabling the driver level AA settings? ATI does have some AA issues in games where Nvidia doesn't.
 

·
No sir, I don't like it.
Joined
·
7,022 Posts
^
True dat.

I've got GoW, so I'll see if I can reproduce the fog issue on ATI hardware with 0.9.6 and the latest SVN.
 

·
Sir
Joined
·
51 Posts
Discussion Starter · #15 ·
Oh, I have a computer with a nVidia GeForce 8800GT here as well. The fog is exactly the same (in both dbz and gow). :(

Here's also something I noticed about gow level 1 "water inside the boat" texture: if I play with DX9 hardware mode, it's not there. But with DX10 hardware mode, it's there.

But... in DX9 software mode, the water is there. Weird... I always thought DX9 was to blame for this. :eyemove:
 

·
Banned
Joined
·
35,081 Posts
:p guess Dx10 ain't so accurate after all.
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top