Next Generation Emulation banner

vib-ribbon (PAL) [help!]

6710 Views 29 Replies 6 Participants Last post by  DJMagdalen
Hi --

I've just recently managed to pick up a copy of vib-ribbon (PAL), what I consider one of the greatest games ever made. :)

Unfortunately, I can't get ePSXe to run it completely.

What happens:

I boot up, the game runs fine -- even through the introductory screens and the title page. You get a choice of language (ENGLISH) and then a menu.

If you choose GAME or INSTRUCTIONS. The LOADING page comes up (complete with spinning stars). Then -- after a small wait -- the stars stop spinning and the game just hangs.

I'm fairly certain it's not a graphics problem. The emulator/plugin has no trouble with the simple,vector graphics and I'm fairly certain that the opening menus, etc are all "in game".

I know vib-ribbon reads audio tracks from CDs to make the boards that make up the game, and I'm fairly certain this is where it's going wrong. In the case of INSTRUCTIONS, the game hung, but the music played in the background anyway.

Is it the CD plugin? The audio plugin? Or the emulator itself?

PLEASE if anyone could give me advice, I'd *greatly* appreciate it!

-- d
1 - 14 of 30 Posts
Thanks for the reply...

Forgive me denseness, but do I just have a really old version or may I ask what on earth are you running? My version (1.4.0) looks *nothing* like yours. :)

That being said, I went under audio and fiddled with:

Enable XA sound (Select to enable XA sound in MDEC)
Enable XA read (Select to enable XA sound in game)

Both were OFF, I tried one on each and both and I still lock up. :(

It's always at the same point -- when it's "LOADING." Strange thing is -- if you pick "HOW TO PLAY" you can *hear* the sound in the background, but the screen locks up. I tried ESCaping and then continuing (the sound keeps playing regardless!) and the screen is just dead -- just all red.

I've also tried fiddling with the CDROM settings (keeping the speed low, not reading ahead) to no avail.

Any ideas?

Thanks again!

-- d
See less See more
Well, about the snapshot, I mean my ePSXe looks *completely* different from yours. You have those tabs at the top, etc. I'm picking stuff off menus.

As for the bottom stuff, I can't find them in my version. :/ Are they in video? Sound? CD-ROM?

I presume sound.

My sound has the plugin (I'm using Pete's DSound 1.11)

Under that config...

XA is enabled, XA pitch is enabled. And I fiddled with the MISC settings (slow timer updates and SPU IRQ queue). None of them do anything.

As I said, I'm running 1.4.0. Is there a newer version?

-- d
See less See more
Ah! Thanks!

I'll download it immediately and fiddle with the settings...

It's interesting. If you start the HOW TO PLAY and then QUIT ePSXe ... the sound keeps playing! It's very obviously a CD-track and it just keeps going until you re-run the program...

Also, it's obvious that the *program* knows that the tracks are audtio tracks. When I run the CD, I get this:

* Running ePSXe emulator version 1.4.0.
* Memory handlers init.
* ePSXe: PSX BIOS loaded [bios\SCPH1001.BIN].
* Init Core W9x cdrom ... [E] ok
* First/Last track: 1 8
* Track 1: (DATA) - Start 0: (00,02,00) - Length 01:40
* Track 2: (AUDIO) - Start 1: (01,42,00) - Length 02:39
* Track 3: (AUDIO) - Start 2: (04,21,00) - Length 02:34
* Track 4: (AUDIO) - Start 3: (06,55,00) - Length 02:32
* Track 5: (AUDIO) - Start 4: (09,27,00) - Length 02:35
* Track 6: (AUDIO) - Start 5: (12,02,00) - Length 02:47
* Track 7: (AUDIO) - Start 6: (14,49,00) - Length 02:33
* Track 8: (AUDIO) - Start 7: (17,22,00) - Length 03:00
* Testing readmode (3/3)
* Doing init gpu...
* Gpu open...
* Direct input init ok.
* Doing spu init...
* Spu open...
* Force PAL cdrom detected.

Well, I'll download the program and try again. If you think of anything else, please let me know! And thanks again! :)

-- d
See less See more

Well, no luck. I set up my config screen to precisely match yours, then even fiddled with stuff further and no luck.

Anyone have any ideas? I'm desperate to play this, especially since the darn game keeps tempting me with the opening screens running just fine... :)

-- d
Further experiments...

First, thanks for the responses. I think I'm narrowing down exactly what's happening, but then again, it's *still* not working, so what do I know? :)

Here's what I've found:

The 'CD audio' in the game is, in fact, NOT XA. If I shut off XA read on the MISC screen and XA sound in my sound plugin config, the sound still plays.

The apparent important option is CDDA (which I presume is CDDAta?). If this is shut off, the sound does *not* play during the HOW TO PLAY section. However, the game *still* locks up. Is it a CD setting then? I've fiddled with the timing and the state to no avail.

I also tried it with AdriPSX and the exact same thing happens, but then again, AdriPSX uses the same plugins. :)

I've also tried it with both European (7502?) and American (1001) bioses but no luck...

Has anyone ever gotten this game working with any emulator?


-- d
See less See more
I don't have access to my machine at the moment, but i"ll try that first thing I get. This'll probably be the last word on the issue for a while, as I just read the boards are going down...

Thanks everyone for your help. If it doesn't work, I'll be back here as soon as the boards are up again (whenever that is...) begging for an answer. :)

-- d
Well, it doesn't *need* a music-CD, per say -- you can use the tracks that are on the original CD, although the best part of Vib-Ribbon is the ability to use any other CD for the game...

I'll definitely give it a try, though. I'll pretty much try anything at this point. :)

Thanks again!

-- d
Well, no luck with the ISO...

In fact, it seems to work *worse*. When I choose 'How to play' the game locks up -- but no audio! Since that's a CD track, did I mess up the ISO somehow (I used isobuster)? The file's rather small (approx 200MB) but then again, the game has really simple graphics and only a few songs on it (7 tracks + 1 data track).

Then again, I can't get at the CDDA option under epsxexcutor because I can't figure out how to make it run ISOs. Whenever I run a config, it immediately looks at the drive. Is it possible to set up a config for an ISO?

...OK ... update/correction/I'm an idiot. :) I don't know what I'm doing wrong, but I can't get ISObuster to make an ISO of the disc such that it gets all the tracks...

This is what I do. I right-click CD and pick either Extract Image->Extract RAW or Extract From/To -> Start Extraction.

In either case, if I open the file in buster (should have thought of that) it's on the FIRST track...

Now for something *really* weird though... if I pick CD/properties and then Advanced, I get:

ImageFile: No
Tracks: 1
Sessions: 8

??? Excuse me? There are clearly 8 tracks on the disc. Why isn't it getting them all? Can ISObuster not handle mixed-medium discs?

I'm definitely starting to think it's just something in the game itself that the emulator is unable to handle. :( update. The 'HOW TO PLAY' music is *definitely* an audio track. I fiddled with IsoBuster and right-clicked and chose 'play audio' on the various other tracks. The How to Play music instructions are Track 8.

So the emulator/game/whatever is capable of playing audio tracks fine. It's just the game dies when it does. :( Does anyone know what this means?

-- d
See less See more
Well, I tried it with right clicking on session1/raw... luck.

This is how the original CD looks in ISObuster:

|---Session 1
|---Track 1
|--- ISO
| |---GAME
| |---KIOSK
| |---TITLE
|--- Track 2
|--- Track 3
|--- Track 4
|--- Track 5
|--- Track 6
|--- Track 7
|--- Track 8

(2-8 are listed as music tracks)

Then, if I open my iso file after trying the above, I get...

|---Session 1
|---Track 1
|--- ISO

Notice that none of the secondary audio tracks (2-8) come over.

Is there a way to add files to an image afterwards? As I've said, I've tried both right-clicking and getting both the CD as raw and Session 1. It ends up the same way...

...also, I thought I'd be all clever and try and figure out what was going on by adding "-debug" to the runtime. It runs (I don't get an error) but my keyboard won't work when I try to choose something from the menu. Does anyone know if the control-scheme is different/screwed up in debug mode?


-- d
See less See more
bump. :)

Anyone? Bueller? Bueller?

-- d
Oooh. That sounds bad. :(

Just out of curiosity, what about vib-ribbon makes it incompatable? Is it compatable with any emulator out there? Will it ever be compatable with ePSXe?


-- d
An update.

I can't find *any* emulator, to my knowledge, that will work with vib-ribbon correctly. Most do precisely what ePSXe does -- when you attempt to run the game, it gets to the LOADING screen and then locks.

VGS works *slightly* better. It manages to show the 'instruction' animation correctly while playing the music track (although it's out of sync). However, it still locks up when you try to play the game.

I'm a coder myself and I'm curious if anyone knows precisely *why* the game is doing this and if there's an open-source emulator that I could try tinkering with to try to get the game to work... :)

In any case, thanks everyone (particularly Beta...) for your help!

-- d
See less See more let me see if I get this straight...

The basic problem is *how* all of the emulators are playing CD tracks. Normally when a playstation game asks for a CD-track, it's loaded as you described above, but on the emulators, they just start playing the track directly...thus in the case of Vib-Ribbon the program doesn't get the information it needs and hangs.

If this is true, does this mean I need to fiddle with an emulator directly (and are there any open-source emulators out there) or just with a CD-plugin?


-- d
1 - 14 of 30 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.