Next Generation Emulation banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I think I've found a bug in the latest version of VisualBoyAdvance. The application doesn't terminate properly when I choose "exit" or click the X. The window goes away and all seems well, but, the task manager continues to hold the VisualBoyAdvance process unless I end-task it.

It's not so much a problem as it is annoying to have to terminte it manually every time I want to start it up again.

Perhaps it's termination protocol was somehow compromised on one of the updates or perhaps it's because XP has "issues".
 

·
Premium Member
Joined
·
483 Posts
I am not able to recreate this problem. Is there a special case where this happens like paused game, no game, etc...? It seems to work fine on my computer.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
No exceptions in particular. It doesn't matter if I load a game or not, when I close the program it's task does not terminate.

Perhaps my operating environment is to blame for this occurrence. I belive I've had this problem since upgrading to version 1.5, I still have this problem with the latest version.

Is there some sort of information I could send you perhaps? Some logging I could do maybe?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
I just tried the beta and it does the same thing.

Now.. Here's something odd.
When I run the executable in a new directory (without the ini) it closes just fine and creates a new ini, running it after with that ini is fine as well.
When I use the ini I have all my previous settings in I get that termination problem.

I suppose I can just delete my ini and start fresh configuring everything again.
I wonder what option I have that is causing this...
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Ok, get this.
I looked further into the issue, and somehow, placing visualboy advance in the folder I usually keep it puts it into "run in windows 95 compatable" mode.

I'm not sure why this is if I've been updating that file, but I unchecked the box and I no longer have the problem.
 

·
Premium Member
Joined
·
483 Posts
ok, that's better. I wonder what the hell Windows XP is doing when in that mode that causes that. I may be curious enough to try it... Not that it really matters.
 

·
Guardian
Joined
·
162 Posts
I can back this person up, however if I'm reading right.. CTRL+X shuts down the emulator no matter what configuration you use.
 
1 - 8 of 8 Posts
Top