Next Generation Emulation banner

1 - 20 of 69 Posts

·
Super Moderator
Joined
·
13,069 Posts
Discussion Starter #1 (Edited)
New build in the wild.

Release thread on the VBA-M forum:
http://vba-m.com/forum/vba-m-svn-854-mfc-info-and-download-t-337.html

Edit (23/2/2009): updated link


VBA-M [svn 854 MFC] info and download

General Info
:
VBA-M is a [Super] Game Boy [Color / Advance] emulator for Windows, Linux & Mac. Here you can get information about the latest development build of the Windows version and download it while you're at it.

Changes in this release:
bgk: Initial version of the GTK GUI (forwardported from VBA's CVS)
xkiv: SDL: new option to slow down autofire (needed for it to work with some games)
bgk: Fixed MFC
ZachThibeau: Compiled release. used yasm instead of nasm. (nasm giving errors in release build but not in debug build), fixed url in about box to point to http://vba-m.mudlord.com

Download:
VisualBoyAdvance-M SVN854 (click to download)
MD5: 6b37c1eb0a8cbafbd4a1fed2726b97dd
 

·
Banned
Joined
·
23,263 Posts
I'm gunna kick Zach in the nads for failing to link the openal sdk.
 

·
Banned
Joined
·
23,263 Posts
...thats not going to happen, besides its only a minor issue and it works otherwise.
 

·
Registered
Joined
·
2,441 Posts
thanx, but where do i get the linux stuff. plus the vba-m site has all this errors.

Warning [2] preg_replace() [function.preg-replace]: Compilation failed: lookbehind assertion is not fixed length at offset 8 - Line: 406 - File: inc/class_parser.php PHP 5.1.6 (Linux)
and how comes this build's size is so small compared to other builds.
 

·
Super Moderator
Joined
·
13,069 Posts
Discussion Starter #6 (Edited)
It's not tied to mudlord's webspace (its now reserved for his personal works and developments).

New url:
http://www.vba-m.com

Note: the ngemu subdomain doesnt redirect (yet?) to the correct location, but the new address is vba-m.com


how comes this build's size is so small compared to other builds.
Packed, I believe. The binaries were actually bigger than they should have (packing doesnt affect performance much if at all).

For linux, straight compiles from svn could do (svn compiles are windows-only).
 

·
Banned
Joined
·
23,263 Posts
It was redirecting,

Seems like someone took it on themselves to restore the broken site and change the dns.
 

·
Registered
Joined
·
5 Posts
I'm getting an error with this version on startup:

"Cannot SetCooperativeLevel 80070057"

Didn't get it in 781.

By the way - why is my D3D Multithreading option grayed out? :-(
 

·
Banned
Joined
·
23,263 Posts
you NEED, to update DirectX.

There is no, if's, buts, or maybes.
 

·
-o-
Joined
·
261 Posts
I'm getting an error with this version on startup:

"Cannot SetCooperativeLevel 80070057"

Didn't get it in 781.
Code:
Open DirectSound.cpp
//		systemMessage( IDS_CANNOT_SETCOOPERATIVELEVEL, _T("Cannot SetCooperativeLevel %08x"), hr ); // Line 107
//		systemMessage( IDS_CANNOT_SETFORMAT_PRIMARY, _T("CreateSoundBuffer(primary) failed %08x"), hr ); // Line 144
Because directsound error. Try this one.
 

·
Banned
Joined
·
23,263 Posts
No, we are not patching the emulator to work around system config issues.
 

·
Registered
Joined
·
5 Posts
you NEED, to update DirectX.

There is no, if's, buts, or maybes.
Uhm - like I said - I HAVE the latest DirectX version - just to confirm that I even downloaded the DirectX web installer, which of course finished without installing anything because, I repeat again, I do have the latest DirectX version...

Now - I also doubt this is a system issue (I'm on Vista and please spare me the talk of how this system supposedly sucks) since previous versions of VBA-M didn't have any problems. With exactly the same configuration.

The "workaround" above only removes the error messages, as I understand? I have no sound in the emulator anymore.

Would downloading a .dll from a previous version of DirectX solve the issue? (I noticed you use DirectSound 8)
 

·
Banned
Joined
·
23,263 Posts
thats just a backup of all current releases,

Dax

VBA-M SourceForge

We are working on getting the site backup, our host denies any problem what so ever, yet the site refuses to connect to the domain.
 

·
Banned
Joined
·
23,263 Posts
The protection is now removed actually, i just removed it.

I also reverted the Quickopen menu which was ****ing up the other open "gbtype" menu's.

the Setcooperative level is occuring because of changes made in 823 by bgk (without contacting the win32 devs first i might add....) basically the app isn't picking up the device modes available so its defaulting to Dsound software (which isn't a bad thing on NT6).

We'll get it sorted out soon, im going over the code now,
 
1 - 20 of 69 Posts
Top