Next Generation Emulation banner

1 - 11 of 11 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I'm using several different versions of VisualBoyAdvance (each one configured identically) on 2 computers:

(1) A desktop with a 2.0 gHz processor, a GeForce4 64MB video card, and 256 MB RAM.
(2) A laptop with a 2.8 gHz processor, an ATI Mobility Radeon 9800 128 MB video card, and 512 MB RAM.

But while VBA works perfectly on my desktop (even with frame skip set to 0), VBA on my laptop suffers constant speed hiccups (even if I increase the frame skip to 2). By "hiccups", I mean when the game's speed percentage suddenly dips below 100% for a brief period of time. Outside of this slowdown issue, the games work perfectly, but the speed hiccups occur so frequently that they disrupt the pace of the games to the point where they're almost unplayable.

I've tried this on both computers with versions 1.7 beta 3, 1.7.2, and CE, and the desktop only needed to be set to a frame skip of 2 on version 1.7.2 to play correctly; the laptop suffers frequent speed hiccups on all of these versions unless the frame skip is at 2, and even then the speed sometimes stutters.

Does anyone have a clue as to what's going on here? These are the settings for VBA 1.7 beta 3:

Emu version : 1.7-beta3
Emu Type : Normal Version
Using BIOS : 0
Skip BIOS : 0
Disable SFX : 0
Skip intro : 0
Throttle : 0
Rewind : 0
Auto frame : 0
Video option : 1
Render type : 1
Color depth : 32
Red shift : 00000013
Green shift : 0000000b
Blue shift : 00000003
Layer setting: FF00
Save type : 0 (0)
Flash size : 00010000 (00010000)
RTC : 0 (0)
AGBPrint : 0
Speed toggle : 0
Synchronize : 1
Sound OFF : 0
Channels : 030f
Old Sync : 0
Priority : 0
Filters : 0 (0)
Cheats : 0
GB Cheats : 0
GB Emu Type : 1

For comparison's sake, here are the settings for VBA 1.7.2:

Emu version : 1.7.2
Emu Type : Normal Version
Using BIOS : 0
Skip BIOS : 0
Disable SFX : 0
Skip intro : 0
Throttle : 0
Rewind : 0
Auto frame : 0
Video option : 1
Render type : 1
Color depth : 16
Red shift : 00000000
Green shift : 00000000
Blue shift : 00000000
Layer setting: FF00
Save type : 0 (0)
Flash size : 00010000 (00010000)
RTC : 0 (0)
AGBPrint : 0
Speed toggle : 0
Synchronize : 1
Sound OFF : 0
Channels : 030f
Old Sync : 0
Priority : 0
Filters : 0 (0)
Cheats : 0
GB Cheats : 0
GB Emu Type : 0
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Sonic 4ever said:
How much does it drop below 100% on your laptop? :)
On frame skip 2 the speed hiccups generally send VBA down to about 80-85% (which is enough to cause some really annoying stuttering), but sometimes it's been as bad as 50%.

If I set it to frame skip 0 and get a speed hiccup the slowdown ranges between irritating (80-85%) and atrocious (20-40%).
 

·
Premium Member
Joined
·
483 Posts
Try setting the sound synchronization to Old sync (Options->Sound->Use old synchronization). If that doesn't fix it, try a different render method.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5 (Edited)
Forgotten said:
Try setting the sound synchronization to Old sync (Options->Sound->Use old synchronization). If that doesn't fix it, try a different render method.
Tried it already. DirectDraw, Direct3D, GDI, and OpenGL all have slowdown issues (some worse than others). Old Sync didn't help either; even disabling the sound didn't stop the speed hiccups.

Here's a list of what I've tried so far (and I just know I'm going to forget something):
  • Setting 'render method' to DirectDraw, Direct3D, GDI, and OpenGL
  • Setting sound to 'Use Old Synchronization'
  • Turning off sound
  • Setting video size to 1X
  • Setting video size to full screen
  • Setting frame skip to 2
  • Setting priority to 'highest'
  • Turning off all filters
  • Turning off interframe blending
  • Turning off synchronization
  • Using different versions of VBA (I've tried 4 so far)
  • Defragmenting the hard drive
  • Updating the video card drivers (that didn't work because the ATI RADEON 9800 Catalyst drivers available on the site apparently are not compatible with my ATI Mobility RADEON 9800 video card)
  • Using AVG to scan for viruses
  • Using Ad-Aware to remove all spyware and adware
  • Using Advanced System Optimizer to defrag and optimize the registry and memory
I'm starting to get the feeling that my laptop just doesn't like VBA.
 

·
Premium Member
Joined
·
483 Posts
It is usually either a video card driver or sound driver problem. You can also try the SDL version (it is a command-line program) with a frontend. It may not have the same problem as it works slightly different on the synchronization than the regular VBA version.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7 (Edited)
I took a closer look at your last post, Forgotten, and decided that since the audio drivers had nothing to do with it (VBA lags even when sound is disabled) and my laptop's specs tower over my desktop's, the slowdown is the result of either a video driver problem or a memory error (could be possible since my laptop has frozen on a few occasions in the past, which could have damaged something).

So I just finished reinstalling my video drivers (turns out that the drivers weren't on ati.com but on dell.com), reinstalling my audio drivers (just to be on the safe side), and downloading the SDL version of VBA onto my computer. Additionally, I used CHKDSK to scan my computer for memory errors (it found one).

Unfortunately, VBA's speed hiccups are just as bad as ever on all versions (and they're terrible on the SDL).

It's become apparent that, unless CHKDSK missed a memory problem while scanning my system, my video card just isn't compatible with VBA.

So until I find another possible cause of the slowdown (and/or another possible solution), it looks like I'm going to have to stick to the desktop for VBA...for now, at least.

------------------------------------------------------------------------------------------​

EDIT: Uhh, nevermind. I found the source of the problem. Turns out my laptop has been slowing down due to overheat.

Why has the laptop been overheating? Simple: because I'm an idiot and forgot that you're not supposed to use your laptop ON THE BED (which I started doing a few days before I put VBA on my laptop).

Why is it that I always look for the simplest solution last?
 

·
Registered
Joined
·
9,504 Posts
Psykotik IV said:
EDIT: Uhh, nevermind. I found the source of the problem. Turns out my laptop has been slowing down due to overheat.

Why has the laptop been overheating? Simple: because I'm an idiot and forgot that you're not supposed to use your laptop ON THE BED (which I started doing a few days before I put VBA on my laptop).

Why is it that I always look for the simplest solution last?
that's right...your suppose to put it on your lap and have your sperm count shrink :evil:

BTW....I never heard of this 1.7 beta 3 before. Is it newer than 1.7.2?
 

·
Registered
Joined
·
76 Posts
Oh well , we all make mistakes :) The important thing is that we learn from them.

To Psykotik IV :

If you want to use your laptop on your bed what you can do is get rubber feat, stick them on a piece of perspex then rest your laptop on the rubber feat.

That should take care of heat problems. :thumb:
 
1 - 11 of 11 Posts
Top