Next Generation Emulation banner

1 - 12 of 12 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
So, I've been manually adding all of my backup games to Steam - all's well, all emulators work, etc. HOWEVER, for some reason I'm stumped on getting ePSXe to work.
What I'm looking to do is have the emulator start the rom by clicking a game directly in Steam (I hope that makes sense). For most games I've used something like this (using an example of one that works for me):

"X:\1. Emulation\Nintendo 64\Project64.exe" "X:\1. Emulation\Nintendo 64\Roms\Donkey Kong 64.z64"

I'm using something similar for ePSXe, but while the emulator launches, the file won't. Oddly, when I try to launch the file directly from the emulator itself, it works like a charm. This may be a question over on Steam, but I figured someone here would have experience with this!!! Thank you in advance!

"X:\1. Emulation\Playstation 1\ePSXe.exe" "X:\1. Emulation\Playstation 1\isos\Arc the Lad 2.iso"
 

·
Not a Registered User
Joined
·
1,303 Posts
You're lacking a command there "-nogui" and "-loadbin <file location>"
Like this.
D:\PS1\ePSXe.exe -loadbin "D:\PS1\isos\Spyro the Dragon \Spyro the Dragon .PBP" -nogui
This way you can create shortcuts that directly start a game, it should also work with steam, thou the "-nogui" will disable ePSXe menu and pressing ESC will close ePSXe completely.

Also your PS1 games shouldn't be in a ISO format, that's a bad format for PS1 games as it discards valuable data, like subchannel and CD audio.
BIN/CUE is proffered but CCD/IMG/SUB, MDF/MDS work as well, I use PBP it's a BIN/CUE format compressed.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
Fox... please give me your address so I can send you some flowers or something. It freaking worked!
One question - what are you doing about games with multiple disks? Are you adding them to steam separately or combining them in some way? Just curious!
 

·
Not a Registered User
Joined
·
1,303 Posts
Fox... please give me your address so I can send you some flowers or something. It freaking worked!
One question - what are you doing about games with multiple disks? Are you adding them to steam separately or combining them in some way? Just curious!
No problem friend, glad to be of help, as for your question sadly you have to make a separate shortcut or use default ePSXe to switch discs, save and continue using the shortcut.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
ONE final question... some of my files are in CCD/IMG format. Do I need to convert those in some way or do you think they'll run the same way? Not at home so I can't test it yet, just thinking about it.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
Okay Fox... Final FINAL question (I think). I can get the image file to run, no problem, but when trying to run it directly through Steam, no dice. I click the link and... nothing happens. I tried the command "loadimg" like I would have tried with "loadbin" but that didn't seem to work. I'm sure I'm missing something very, very simple.
 

·
Not a Registered User
Joined
·
1,303 Posts
Okay Fox... Final FINAL question (I think). I can get the image file to run, no problem, but when trying to run it directly through Steam, no dice. I click the link and... nothing happens. I tried the command "loadimg" like I would have tried with "loadbin" but that didn't seem to work. I'm sure I'm missing something very, very simple.
Well if nothing happens that means you made a typo somewhere in the command line, i tried it myself in steam and it does work.
Edit. "loadbin" is a general command for all types of disc images, there is no "loadimg" or "loadmdf" "loadiso", it just "loadbin" for all types.
Here's how it works for me.
201392


Thou in launch options you could just type.
-loadbin "D:\PS1\isos\Spyro the Dragon \Spyro the Dragon .PBP" -nogui
For example,it works either way.
201393
 

·
Registered
Joined
·
7 Posts
Discussion Starter #10
"X:\1. Emulation\Playstation 1\ePSXe.exe" -loadbin -nogui "X:\1. Emulation\Playstation 1\Roms\Xenogears\Xenogears D1\Xenogears.img"

So above is what I have right now. I'm getting the emulator to pop up now but for some reason it isn't going directly into the rom, which I would have expected given the "loadbin" command.

Keep in mind I am probably the last person who should be trying this, considering how non-tech-savvy I am, but I feel like I'm so close!
 

·
Not a Registered User
Joined
·
1,303 Posts
"X:\1. Emulation\Playstation 1\ePSXe.exe" -loadbin -nogui "X:\1. Emulation\Playstation 1\Roms\Xenogears\Xenogears D1\Xenogears.img"

So above is what I have right now. I'm getting the emulator to pop up now but for some reason it isn't going directly into the rom, which I would have expected given the "loadbin" command.

Keep in mind I am probably the last person who should be trying this, considering how non-tech-savvy I am, but I feel like I'm so close!
" -loadbin" has to be followed by the rom file path then " -nogui" has to be at the end, like this.
"X:\1. Emulation\Playstation 1\ePSXe.exe" -loadbin "X:\1. Emulation\Playstation 1\Roms\Xenogears\Xenogears D1\Xenogears.img" -nogui
 
1 - 12 of 12 Posts
Top