Next Generation Emulation banner

1 - 14 of 14 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1 (Edited)
Sigh. It's so idiotic that you can't use a different controller plug-in for ePSXe. I've tried everything. I have XBCD drivers, I have the custom updatedxbcd3602 config file, I tried using Slide- instead of the normal axis...EVERYTHING. In fact, it made things worse by reversing my start/select and shoulder buttons (which still happens sometimes). The analogs have never worked properly. I even tried ePSXe 1.7.0 earlier and still NOTHING.

I tried pSX, and it works perfectly for my controller, but it has the same idiotic problem ePSXe has - you can't change a certain plug-in, in this case, the video plug-in. I can't go back to those crappy default graphics after using Pete's OpenGL. So it's either I get great graphics and gimped controls, or perfect controls and ugly graphics.


Why can't there be a PS1 emulator that lets you configure BOTH video and controller plug-ins, that isn't an unstable pos (I'm looking at you, psxeven)?

Oh, and a side question because I don't wanna make two topics: How come when I run the BIOS, ePSXe cuts off the cool Sony Entertainment/Playstation logo so quickly? And how come that logo never shows up when I run games? pSX--using the same BIOS file--runs the entire logo sequence perfectly.
 

·
クロスエクス
Joined
·
4,662 Posts
For the first question.... define "analog not working perfectly" and what version of ePSXe you're using?

I have a Microsoft Xbox 360 controller and it's working perfectly with ePSXe.

As for the last part, there's a command line if you want to see such logo all the time. Just read the documentation.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
I can map the left analog stick on the 360 controller(J1_LY, J1_LX), but it in-game, it does nothing; it doesn't work at all. The right analog stick can't be fully mapped (it only maps the J1_LRY axis) either. So I end up having to map the PSX d-pad to the left analog stick so it "feels" like analog control.

I've read dozens of topics/thread across different forums about this problem, and I haven't come one step closer to solving it. And I don't see anything in the documentation about having longer logo sequences, only disabling them completely.
 

·
God of Douchebagness™
Joined
·
9,826 Posts
have you been pressing F5 upon startup of a game?
 

·
クロスエクス
Joined
·
4,662 Posts
Make sure you're actually in ANALOG and not DIGITAL when testing/playing.

Some games start at Digital and change to Analog in the startup screen... so if you use Savestates it might remain as Digital.

I have never had your issue though, I can map it perfectly.

Also, I suggest that if you're using mutiple XBCD profiles, assing the triggers the last button numbers (example, buttons 11/12). This way, if you switch from buttons/axis profiles, it won't mess up the button number distribution.
 

·
God of Douchebagness™
Joined
·
9,826 Posts
No, I haven't...
then do that and set it to digital/analog in the pad config. the F5 key serves the same function as the analog on/off button found on a real psx controller.
 

·
Site Owner
Joined
·
14,909 Posts
My Xbox360 is working perfectly. just make sure f5 is on, for analog switch

8edit jonc beat me too it
 

·
Banned
Joined
·
23,263 Posts
9/10 users of xbcd based on the 0.2.6 driver have no issues with epsxe's analogues....
 

·
Registered
Joined
·
5 Posts
Discussion Starter #10
then do that and set it to digital/analog in the pad config. the F5 key serves the same function as the analog on/off button found on a real psx controller.
*smacks forehead*

Can't believe that was it all along...F5! Analogs working perfectly now. Ok, but I still don't know how to get the cool Sony/PS Logo opening sequence to go all the way when I run the BIOS. or to get it to show up when I run games...
 

·
No sir, I don't like it.
Joined
·
5,507 Posts
Ok, but I still don't know how to get the cool Sony/PS Logo opening sequence to go all the way when I run the BIOS. or to get it to show up when I run games...
I usually just switch to the software plugin. It's not a big deal since you can't "play" the BIOS. The feature is just there for memory card management.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #14
Alright, BIOS and controller working perfectly. Thanks a bunch. Just feels....right, having that logo every time I start a game. :D
 
1 - 14 of 14 Posts
Top