Next Generation Emulation banner
Not open for further replies.
1 - 1 of 1 Posts

· Premium Member
bsnes, ePSXe
23,380 Posts
Hey, welcome to the PSX emulation Troubleshooting FAQ. Check out this thread to get you started. If you're still having problems, read on.

If you read around the PSX section enough, you'll see the same problems being posted over and over and, predictably, the same answers also being posted over and over. Kane, myself, and others have long had the idea of a general PSX emulation FAQ in mind for a long time but no one really cared enough to start it up. As of late, dbhankins finally motivated me to get going and make something. So here goes. This page will always be changing; as new problems come about, so do new answers.

I suggest just reading this whole thread. I tried to organize it in order of relevancy, so that you can start at the top and read down the thread and troubleshoot as you go. You can always control+F this business if you want to find something fast.

Before the beginning...
Just a quick note. If you're looking for support on a downloaded game, just leave immediately and/or buy the game you're looking for. Besides being illegal which is against the [rules]rules[/rules], the more important concern is that the ISO you downloaded is either corrupt or was improperly ripped, and since you don't have the original there's no way to verify. It's frustrating to spend a lot of time troubleshooting various plugins and settings and then find out that corrupted data could be the problem--it's happened many times SO DON'T PRETEND IT DOESN'T. Just kidding about the caps. But seriously, you won't get any support for downloaded games. If you own the game, just make your own ISO using a free program, you don't have to download one.

So if you own a legit version of the game, jump in...

BASIC PSX EMULATION TROUBLESHOOTING (with less random capitalized words than a CKemu thread, I promise)

First, before you read on, use the board's Search function to see if anyone else had the same problem as you. then read these:

  • Try restarting your computer and killing unnecessary processes
  • Update your drivers for your graphics card, sound card, etc.
  • Try a different emulator (different version of ePSXe, or PSXeven, SSSPSX, PCSX, pSX, Xebra). Keep in mind that memory cards from all of these emulators can be shared with each other. Some emulators will accept the formats with no problem (PSXeven is excellent in this regard), but if you're having problems with memory card compatibility, use PSXMemTool to change the format. Keep in mind that save states are not transferrable between emulators.
  • Try using a software GPU plugin (like P.E.Op.S or Kazzuya's, etc)
  • If you're using Pete's plugins, they have a "Nice" preset. 99% of the time this will be the correct GPU configuration.
  • If you're using save states, don't. Load off of your memory card save. This is extremely important when troubleshooting because the save state feature is something that was not part of what the real PSX console was capable of doing and the most effective way to troubleshoot problems is to eliminate as many unique factors as possible and attempt to isolate the problem under conditions that can be generally considered standard.
  • If you're using PEC or any type of cheats, turn them off.
  • If you're playing off CD, make an ISO image or switch CDR plugins. If you're using an ISO, try the original CD (not a copy or a bootleg!)
  • If you have an nVidia SLI setup, you may need to create a profile for ePSXe's executable and to set the SLI performance mode to "Single GPU rendering".
If you've done all of those things, and you still have problems, proceed.


*Insert game* works perfectly on ePSXe 1.6.0 (or 1.5.2 or some other emulator) but it doesn't work on 1.7.0!
  • You can make a thread about it or post in the bug report thread (, doing so will let the developes know whats up so they can improve the emulator when they have the chance.
  • In the meantime however, save yourself from the frustration of all this and just play your game with another emulator or version that does work for it. Older versions are not necessarily inferior to 1.7.0 so don't toss out the idea of using them just because they are not the latest version.

When I try run ePSXe I get these weird messages and ePSXe doesn't start at all.

What's this BIOS thing everyone is talking about? Where do I get it?
  • A BIOS is essential to PSX emulation. check out this thread for a little bit of help (;))
  • Check out the ePSXe help file. In the Contents, go to Technical Stuff-->Dumping the PSX BIOS.
  • Shendo has written a great tutorial (with pics!)
  • As always, Google is your friend.
All I get is a black screen.

  • ePSXe 1.7.0: Xeven's CDR plugin does not work in ePSXe 1.7.0. Sapu's plugin has an updated version that is compatible. Otherwise, you must use the (new and improved) internal CDR Plugin with subchannel reads enabled.
  • First, make sure you've got everything together. You need a BIOS, plugins (graphics, sound, and CD and pad if you need them), and of course the game you want to play.
  • Look at the console (the "DOS window"). Are there any errors? What are the errors? Based on that, make adjustments to the plugins you use (i.e. if it has a CD reading error, try a different plugin, different drive, or make an ISO).
  • If you have a copy protected PAL game, you might need to use a PPF patch. Check NGEmu's PPF page for our database of PPF patches. Alternatively, create an ISO image with subchannel data.
  • Does anything show up when you run the BIOS? (File-->Run BIOS in ePSXe). If so, then you know it's a problem with the game or its compatibility, and not with the emulator's general configuration.
  • Does the game work on a real PSX? If not, then that's your problem; your game just doesn't work.
  • Try turning off DEP (Data Execution Prevention) - Disabling Data Execution Prevention (DEP)

The game is running way too fast (1.6.0 and earlier)
  • turn on frame limiting, and set the limit to Auto. You can also manually set it to 60 (NTSC) or 50 (PAL). thanks to Shendo for making the pic.
  • MDECs and XA music play at unlimited speed but everything else responds to the frame limit? This is a recent problem, and it's caused by dual core CPUs. you need to set it so that your epsxe.exe runs on a single core. for more information, check this thread. thanks to dbhankins for this fix. Also, if you are using a dual core AMD processor, install the dual core optimizer, as well as the processor driver, from here.
  • If using version 1.7.0, try pressing F4 at the start-up of a game to toggle the internal FPS limiter on/off. Do not use both the internal and plugin limiters at the same time, having both of them running can result in speed fluctuations.

The frame rate is jittery (it feels like the game is jumping) (1.7.0)
  • 1.7.0 has internal frame limiting, which can be turned on and off via the F4 key. This will cause problems with your GPU or SPU's frame limiting, so make sure your plugins' frame limiting is OFF so you can use ePSXe's, or make sure ePSXe's is OFF if you want to use your GPU/SPU's limiter.

The game is running way too slow. I have an ATi/AMD graphics card.
  • Recent drivers do not report the amount of VRAM correctly which causes Pete's plugins to have an overall slowdown. To fix this, simply set the memory amount manually within the settings dialogue.
The game crashes with an opcode error

  • Your CD may be corrupted due to dirt or physical damage. Clean it and/or polish it and then make an ISO out of it. If you are already playing from an image, try re-ripping.
  • Try using a different graphics plugin
  • Use a different emulator
  • Don't use save states (load off memory card)

What is this wnaspi32.dll it says I'm missing?
  • Wnaspi32.dll is a part of the ASPI layer used by many programs to access optical drives.
  • If you're getting the error that it's missing, you just need to download Forceaspi. Hit up Google, it's everywhere, or you can use this link that Squall-Leonhart recommended.
  • Easy solution: Just switch to IOCTL read mode in whatever CD plugin you're using.

It says I'm missing WGL extensions?
  • Your graphics card probably won't work with OGL2. Try using Pete's OpenGL (not OGL2) or Peops software GPU.
  • If you're certain your card can run OGL (GeForce FX or higher, Radeon 95xx or higher) then you update your drivers.

The game plays fine, but there's no sound! (or, there's sound, but no music)
  • Make sure your speakers are on and that your computer's sound works in the first place. you'd be surprised at how many times people have their volume muted or something.
  • (ePSXe 1.6.0 and earlier only) Make sure the top 3 boxes are checked under Config-->Sound
  • Some games have CDDA audio. Scroll down a little bit and read about how to get that working.
  • (ePSXe 1.6.0 and earlier only) If you're playing off an ISO, you can't use ePSXe's built in "run ISO" command; it doesn't support CDDA audio. You'll have to load the image using Mooby's CDR plugin OR mount the image to a virtual drive (in both these cases, you need to use File-->Run CD). Furthermore, if it's a bin/cue image, you cant simply run it with the bin. You'll need the cue file as well to tell the emulator where the audio tracks are.

So what are these command line switches i keep hearing so much about?
  • they are "switches" you can use to do different things, for example load with no GUI (-nogui), or load with the BIOS (-slowboot)
  • for a list of command line switches, try this thread, and especially this post.
  • once you've decided which one(s) you want to use, here is how you use them.

I configured my controller, but none of the buttons work! (or, all of the buttons work, except analog)
  • Press F5 in game until the controller works. that is the same as pressing the "analog" button on the PSX controller. You will most likely lose input response if you have analog toggled on while trying to play a game that does not support it or vice versa.
The game freezes in a specific spot
  • Typical causes can be a damaged disc, bad/corrupted image, save state use, or incompatibility problems.
  • Try cleaning your disc, re-ripping your image, load from a real memory card save, or try playing the game another version of ePSXe.
I get this error: "missing render extension" or "no pixel format"
  • This is caused by graphics cards that don't support the OGL2 plugin's new features (render to texture, pixel shaders). In this case, use the regular OpenGL plugin, or depending on how bad your graphics card is, use Peops Software GPU.
  • You can work around this by setting Render Mode to 1. Keep in mind that with your slower card you won't be able to run all (or any) of OGL2's fancy features like high internal resolution, screen filters, shaders, etc. Try turning down the resolution if you're having slowdown issues.
The music in Ridge Racer, Wipeout, Devil Dice, [insert game here] doesnt work at all (ePSXe 1.6.0 and earlier)

These games (among others) use CDDA audio. There are a few things you can do to get the music working:

  • Play off the CD. the analog cable from your CD drive to the soundcard must be connected
  • Play off an ISO, and you must make a full ISO (no warez'd games, they always chop out CDDA audio) and have a bin/cue type format (or similar format that has a image file and a cuesheet)
You cannot use the "Run ISO" command in 1.6.0 and earlier and get CDDA audio. if you insist on using an ISO, follow the above steps for an ISO and load the bin/cue with Mooby's CDR plugin or upgrade to 1.7.0 and follow the directions below.

The CDDA music doesn't work! (ePSXe 1.7.0)
  • The only plugins known to support CDDA are the internal ones included with ePSXe. Most other plugins use CDA instead which requires the old 4/2 pin (analog) connector from your CD drive to sound card.
  • The ISO support in ePSXe has also been improved but it's not 100% yet. If CDDA does not work via ISO, try mounting the image in Alcohol or Daemon Tools and read it via the internal plugin.
ePSXe crashes on exit

  • This is if you have Office 2007/2010 installed. You need to modify the installation and remove Microsoft Sharepoint Workspace, reboot, then RENAME this file:
C:\Program Files (X86)\Microsoft Office\Office14\GROOVEEX.dll

Reboot again, this will allow you to finally delete the file that is causing the crash on exit.

Fast-forward doesn't work in OGL2

  • You need to add an nVidia profile to force v-sync OFF for epsxe.exe, AND you need to press F4 when playing to disable internal frame limiting.

How do I change discs?
  • When the game asks you to change discs, press Escape to exit to the GUI. Then, go to File-->Change Disc.

*Insert game name* just doesn't work!
  • Use the board's search function and type in the name of your game. Most likely, someone has already posted for help about your specific game. If you're having a certain problem that you don't think is specifically game related, you can also type in those search keywords (like, "freeze" or "black screen" or something like that).

What's the best config to use with *insert game*??
  • Most of the time, you can just press the "Nice" preset in Pete's plugins and it will pretty much do the work for you. for some games there is a special config. In that case, check this thread.
  • If the Nice preset isnt working, and you dont have a game that's been previously covered, feel free to make a thread. if you've come up with a great config and you'd like to share screenshots, post them here.

I saved my file in the emulator..but when i replay the game later, my saves aren't there!
  • Open the emulator and go to Tools > Enable Logs (if you haven't already) which will enable the logger window (the "DOS window" behind the gameplay screen). Now restart ePSXe and start the game again. If you see "MEMCARD HAS NOT WRITTEN TO DISK" then restart the emulator, go to Config > Memory Cards and confirm each card's location and file name. You can type whatever you want; the default is simply memcards\epsxe000.mcr -- simply confirm this window and restart ePSXe to play again.

ePSXe holds the memory cards in memory while playing, and when the emulator closes it writes it to the actual memory card file. So, here's what you can do:
  • After you save your game, make sure to exit the emulator properly--this means pressing escape to exit to the GUI, then closing the GUI via file>exit. Do not just close the "DOS window".
  • If you use save states, use them after you save to the memory card. If you do save state then memory card save, it will mess up your memory card saves when you reload the save state. in other words, the correct procedure would be to first save to the memory card, and then save the state.

Why is ePSXe/music still running in the background even after I close it?
  • The same reason why memory card and save state data can be missing after shutting it down, it was not done correctly. Do not close the window by clicking the "X" in the upper right hand corner or anything like that, instead press the escape key and then do file>exit from the GUI when wanting to quit.
You say to change the graphics settings "in game", but how do I do that?
  • When the game is running, press Delete and it brings down the FPS display.
  • If you need help, press Insert--it explains what each category is.
  • You can press pgup/pgdown to navigate across the different variables, and use Home/End to change the variables up or down.
  • If you need more help, read the readme that comes with Pete's plugins, there is a more detailed explanation about what the funky icons on the left mean, and what each value does.

How do I use Gameshark codes?
  • You'll need PEC. You can get it here
  • Go to the actual PEC program, and pick your cheats. then go to File-->Send to Plugin
  • In your emulator, chose PEC as your graphics plugin, then have that select your real graphics plugin
  • For step by step info on how to enter codes, check out this post.
  • If you need codes, check out this thread.

Is there any way to get the Playstation logo to show up before a game starts like on a real Playstation?
  • Yep. Just use the -slowboot switch in the command line. (ePSXe only)

How do I get Xebra working?
  • Have a look at this post. Thanks to SimoneT.
  • If you have any questions about Xebra, DO NOT POST IN THAT THREAD. Make your own thread.

I got Delta, and it comes with all these games, but I can't play any of them...
  • Actually, Delta doesn't come with any games. It just comes with configuration files for those games. You didn't expect hundreds of games in just a few megabytes, did you? ;)

In Final Fantasy 7, there are a lot of green lines everywhere...
  • first, make sure your graphics card has AF turned completely off. if you're using OGL2, AA should be off as well.
  • turn off hi-res textures
  • change texture filtering, or just turn it off. setting it to 4 or 0 works for most people. you can change the settings in game to see what you like better.

In FF7/FF8/FF9/any RPG, I can't see anything during battle! There are no menus, text, etc...
  • Turn frame skipping off.
  • Turn up offscreen drawing to at least 2 for FF8/9 and 3 for FF7, if you're using Pete's OGL or D3D, and higher than 0 for OGL2.
  • For any other game, just turn it up one setting higher than you have it now.
  • Use a software plugin.

Final Fantasy 8 - I'm stuck out on the balcony and I can't get in the door!
  • As they say, an ounce of prevention is worth a pound of cure. If you have Rinoa in your party (in other words, you didn't send her to the missile base), you will get stuck on the outside. To fix this, you simply need to send her to the missile base in the first place so she isn't in your party. Thanks to R.evolution for pointing this out.
  • This is somewhat of a mysterious problem. So far the only common link is Rinoa, but many people have claimed they didn't get a freeze with Rinoa in their party. If anyone can shed some light on this, please PM me.
  • ePSXe 1.7.0: This has been fixed.
Final Fantasy 9 freezes at the FMV at Dali!!
  • you didn't search, did you? :mad: well in any case, use ePSXe 1.5.2, PSXeven, SSSPSX, etc, anything EXCEPT ePSXe 1.6.0.
  • ePSXe 1.7.0: This has been fixed.
Final Fantasy 9 stops working at Cleyra!
  • This is yet another problem that can be caused by save state use, so load from a real memory card save and it should proceed as normal.
Xenogears freezes on disc one at Fei's memory scene no matter what I do.

  • If you're using ePSXe, press F7 once before the scene, and once after.
  • You can also switch to another emulator to bypass this problem (and you don't have to use the F7 trick)
  • ePSXe 1.7.0: This has been fixed, and the F7 hack has been removed.

In Xenogears, at the first fight with Deus on disc 2, it keeps crashing.

Metal Gear Solid plays like crap!
  • ah, MGS, it's tricky. check out this thread.
  • ePSXe 1.7.0: try using internal SPU plugin.

I'm using an XBox 360 controller on my PC, and it works fine in everything--except ePSXe.

What are pixel shaders? How do I use them?
I've heard so much about this Lewpy's Plugin, but I can't use it because I don't have a Voodoo card! Can i use a Glide Wrapper?
  • You can, but results aren't guaranteed. Check Lewpy's (semi) official answer here.

Why is the emulator using 100% of my CPU?
  • This is normal for many emulators, as well as almost all PC games. Having it at 100% won't diminish the performance of the emulator, however, if other things are running in the background, those will probably slow down. If your game is running bad, check the basics: close unnecessary programs, play off of a ISO if you're playing off of a CD, try another emulator, check/alter your plugin settings, or upgrade your PC.
  • Dual core processors react differently than single core processors in regards to CPU usage. In most cases, it will be at or below 50%. ePSXe and PSXeven like to evenly split between the two in Task Manager during MDECs and be fairly lopsided otherwise, with load dropping off significantly in some cases (like FF7/9 battles). pSX only shows as using one core, sometimes in its entirety but mostly not. This is normal and should not diminish performance.

I keep trying to configure ePSXecutor for my controller but it always reverts back to the default configuration.
  • Unfortunately, this feature doesn't actually work. Read here for more.

I can turn the analog mode on and off with F5, but what's the difference between the red and green icons?
The game stops responding and/or cannot complete a disc change when prompted. (1.7.0)

  • This is a bug in 1.7.0 that can be triggered when attempting to do a disc swap from one disc image (CDs work fine) to another. It is not game-specific nor is it related to plugin configurations, it can happen with any plugin setup and in any game that requires you to change between several discs at some point. No direct fixes for the bug itself have been released but there are a few work-arounds
  • You can do the disc change on a previous version of ePSXe and once it has been done you can then save your game and continue back on 1.7.0.
  • Save at the prompt and then restart ePSXe and load the next disc, from there just load the memory card save that was made at the swap point.
  • As I mentioned before, playing directly from the game disc will work fine.
  • Some users have also reported that mounting the disc image onto a virtual drive can work as well.
*This issue seems to have been fixed with ePSXe Shark.*

If you've read all that and done the appropriate "basic" troubleshooting steps, then feel free to make a post. Please try to be as coherent as possible; use proper grammar, spelling, and punctuation. I know this is the internet but please speak so you can be understood. Explain your problem clearly. It would help if you said what steps you tried, what plugins you're using, whether you're using CD or ISO, and what your computer's specs are. You might also want to state "I read the troubleshooting FAQ and tried all the steps" first so you don't get redirected back here ;) Remember, it always helps to be polite. If you follow these simple guidelines, people will be more inclined to help you.

If you have any suggestions, PM me. Don't PM me to ask for help with your emulation; that's what this forum is for. I will not play PM tennis to help you solve your problem. If you're lucky, I'll respond telling you to visit the forums and post for help, but most likely I won't even respond at all.

*note by jonc2006*- hushy is not really active in the forums anymore so PMing him is even more pointless than ever. contrary to his above statement on receiving PMs though, depending on my mood i will sometimes consider assisting with troubleshooting through the PM system (offerings of alcoholic beverages or tips leading me to some fool for stabbing may improve your chances). however i do prefer that most people use the forums for help since there are some topics (PEC and netplay-related questions specifically) that i am not as well versed in and my suggestions in such cases would be limited quite a bit.

In closing, good luck and happy emulating!
  • Like
Reactions: wong234
1 - 1 of 1 Posts
Not open for further replies.