Next Generation Emulation banner

1 - 8 of 8 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I'm using the latest version of Xebra. In my video settings I've got Cycle(2) set to 1, and the other two set to 0. My problem is, I'm experiencing intermittent screen tearing. Sometimes the video is perfectly smooth, but occasionally it starts to tear or jitter. I notice the most in 2D games like Castlevania and Lunar Silver Star.

This happens no matter what resolution I set it on, even 640x480, and 16/32 bpp doesn't affect it. I also get the same problem in Arbex. I do not experience this issue in other emulators like pSX.

Usually when I experience this issue in an emulator, setting the resolution to be identical to my desktop resolution fixes it, but not in this case.

I tried forcing Vsync and triple buffering in the NVidia control panel, but that had no effect.

Is there some special setting that I'm overlooking that can help with this?

Athlon X2 6000+
GeForce GTS250 1.0gb
 

·
Look out behind you
Joined
·
7 Posts
Sorry for reviving an old thread but I'm having a hard time trying to enable a proper Vsync on Xebra.

The refresh rate of my monitor is 60Hz and I run Xebra without Aero to minimize the input lag. When I run Xebra with Aero or Vsync enabled in the driver settings, theres no tearing at all. I just wanna know if theres a proper way to enable a proper Vsync through the emulator.

I use the latest version of Xebra (130815) with the following video output settings (the rest are default):
- Stretch with Opengl (on)
- Stretch (on)
- Nearest (on)
- Progressive (on)
- cycle 1, 2 and 3 are set to 0

My PC config:
Windows 7 ultimate x64
Phenom x4 955 BE @3.7Ghz
AMD HD6870
4GB of RAM
 

·
Registered
Joined
·
17 Posts
I don't know if you'll read it since it's been so long. Anyway, tearing appears when the number of frames sent to the monitor does not match its refresh rate. Vsync is irrelevant if the amount of frames is correct anyway, the only thing vsync would do in your case is turn tearing into missing/doubled frames for extra flavour or add glitchy audio (as I believe is the case with Aero on, you might be lucky enough to not notice it though). Unless Dr. Hell adds a nice compensation thingamajig I'm afraid there's not much to do other than trying a different monitor.
 
1 - 8 of 8 Posts
Top