Next Generation Emulation banner

Tekken 3 - ending crash (or freeze?)

32145 Views 28 Replies 15 Participants Last post by  ClockworkBastar
So, I beat arcade mode with a random character, and when their ending cinematic is over, the ePSXe screen goes black and apparently the game freezes. I waited 5-6 mins, it can't possibly take that long, or can it? What is the cause of this?

Thanks in advance people. :thumb:
1 - 6 of 29 Posts
I was having the exact same issue the OP was describing. After reading dozens of threads for this game describing this issue, I'm very surprised no one posted a proper detailed explanation of what is wrong and how to fix it.

Using ePSXe, Tekken 3 freezes/crashes after completing arcade mode but before the credits movie is supposed to start. The announcer saying "King of Iron Fist Tournament, Enter the Tekken" is the last thing that happens and the screen remains black. I use the NTSC release of Tekken 3 which has 3 .bins (Track 1, 2, and 3) and one .cue.

I'm almost 100% certain the issue is the fact that the game is multi-track and ePSXe (at least every version after 1.4) does not have proper multi-track support. This is not an issue for the vast majority of games but in the case of Tekken 3 it is. And sure enough after mounting the .cue using PowerISO, "Track 2" is the ending credits song. To fix the issue you need to create an image that merges all of the tracks into one .bin.

I first tried this with PowerISO since this was the tool I had installed on my computer but there was a problem. After creating an image with the source being the .cue mounted on a virtual drive, I launched the new .bin that was created. I was able to make it to the credits and the game did not crash but the song for the credits was corrupted. It sounded like data and horrible scratching noises. Obviously "Track 2" and "Track 3" were not converted correctly.

I then used ImgBurn v2.5.0.0, with the original .cue mounted using Daemon Tools Lite v4.35.6 (since a virtual drive created by PowerISO is not recognized by ImgBurn for some reason), to create the image. I tested the image created by ImgBurn and it works as it should. The game does not crash and the credits song plays and sounds correct.

A big thanks to this post as it was the reason I tried ImgBurn and Daemon Tools Lite:

Only use ImgBurn v2.5.0.0 or below because I tried using v2.5.8.0 and the process of creating the image was stuck at 0% due to an infinite loop at "File Splitting: Auto". More information about the problem can be found here:

Make sure you use Eternal SPU or you will likely not hear the credits song. I found that P.E.Op.S. DSound SPU v1.9 and P.E.Op.S. Sound SPU v1.10b do not play the credits song.

Just to add more information about my experiences, I tried SSSPSX v0.0.34 and the emulator seems to have at least partial multi-track support because the game does not crash and the credits play. But the credits song does not play, regardless of the SPU used.

Last but not least, PCSX-R has native multi-track support. So Tekken 3 can be played using PCSX-R without having to convert the multi-track .bins into a single .bin. I tested PCSX-R myself and indeed the credits and credits song play with no issues.
First of all congrats on a 7yr necro you sick bastard, secondly use newest ePSXe (currently 2.0.5) with the built in plugins only, other plugins such us Eternal are outdated and are not completely computable with newest ePSXe, thirdly ePSXe completely supports multi track CDs, the problem is the OP and you were/are using a broken CD image, so make a new cop from a real disc as it does matter as a lot of downloaded copy that are on the net were made by 5ys old.
How do i know your copy is most likely broken? the multiple BIN format, a proper CD image best used for PS1 games is a single BIN file containing the entire CD in a binary format and a CUE sheet with the tracks information.
Granted ePSXe supports multiple BIN format but it's completely pointless and often broken.
Both of you are using a broken game that crashes whenever it tries to load the FMV.
See less See more
what exactly is wrong with reviving an old thread with more information that some people may find useful?

How do i know my copy is not broken? i used it in PCSX-R and it worked perfectly. i said that in my last post so i'm not sure why you couldn't put two and two together.

so yes i'm 99% sure ePSXe does not have proper multi-track support. there is nothing wrong with my image. that or PCSX-R is amazing for making broken stuff work :p
You could always make your own thread, as for your case i could be wrong, it just could be that you're using outdated stuff like Eternal or Dsound.
Finally ePSXe fully supports multi bin format, how do i know that?
Text Software Font Technology Screenshot

Because i tested both copy i made myself, and a copy from a certain paradise.
See less See more
i posted on this thread because when i google search "tekken 3 epsxe crash" this is the first thread that shows up. posting here might result in more people seeing the information.

i didn't say ePSXe doesn't support multi-bin format. i said ePSXe does not have proper multi-track support.

using the same multi-bin image:
ePSXe - crash before credits start
SSSPSX - no crash, credits start but no credits song
PCSX-R - no crash, credits start and the credits song plays

looks to me its more of a compatibility issue dependent on the emulator being used.

you're saying you created your own multi-bin of tekken 3 and it worked in ePSXe (three bins and a cue)?
Yes and yes, and for the final nail multi track Has it cant crash games.
Multiple tracks for psone games were used for two things.
1. Anti piracy checks, mostly for PAL games.
2. Audio tracks aka game music, this is why you can put sone psone games into a CD player and listen to it.
If the tracks were broken like using ISO with a single one of two things would haopen.
1. The game would not start, Black screen.
2. Music would not Play during gamę Play.
So the multi bin support is not an issue, the op propably was using a broken image and you yourself are using outdated stuff like eternal and dsound, the issue lies elswere especially if it works on other emulators.
i have no idea what your first sentence means.

and you're wrong. i'm using the same plugins for every emulator (Pete's GPU and SPU), the only difference is the emulator. ePSXe is the only emulator i used that causes my multi-bin tekken 3 to crash. i'll say it for the third time, SSSPSX and PCSX-R do not crash. you can't be so sure its not a problem with ePSXe's multi-track support.
SSSPSX aka your grandma is dead as dicks, and so is PCSX-R, ePSXe 1.9.0 and upwards may not work properly with the old plugins like eternal and dsound.
And for the enth time it's not a multi track issue as that was tested and it works properly, the problem lies with your setup.
Hey FoxSevent, i necropost too because fuck you, i want to thank applepiejr as his solution is the only one i found that works, epsxe does indeed crash a legit copy of the tekken, i used ImgBurn v2.5.0.0 to merge all the tracks into one .bin and it now plays properly.
Well f you to buddy, I have clearly shown in now the deleted video that ePSXe has no issues with multi bin/multi tracks games, I have tested many multi tracks games all with no issues, therefore the issue lies somewhere else like a improper disc image downloaded from your moms porn site.

Heck if this truly was a multi track issue don't you think it would be fixed by now seeing as this thread is over a decade old?
No the Tekken credits crash is a case of a bad image going around online since 2007 because almost no one rips their own games back then and today, the fact that someone ripped the game into multiple bins is a proof that whoever made that image didn't know how to rip PS1 games.
UPD Consider this post incomplete. One last test should be done*

Cool! Thanks.
I did have twice a bad dump. First of all it was in *.ccd format, and Duckstation just used *.img file with no sub-sectors

Then I've redumped the image from CCD (tested it in music player for tracks to present, the second one did not played.
Dumped to a single CUE+BIN, loaded in Duckstation, yep, second WAS bad.
REDOWNLOADED Image that looked like CUE+BIN1, BIN2, BIN3
(I only have a JP licensed disc and I really dunno where is it)
And now - everything is GREEN!

——> But the game still freezes all the same way. <——

*UPD a minute later I thought that I've loaded a savestate to check, if the problem was fixed... But maybe I should run a clean boot with all the correct information in emulator loaded...
Sorry, I can check it only 12 hours later from now.
Save states can carry bugs, so if you loaded a state made on a bad dump that bug will still be present on a correct dump, it's always best to start fresh or load a sav file from memory card.
Here I recorded a test run and no freezing whatsoever.
  • Like
Reactions: 2
1 - 6 of 29 Posts