Next Generation Emulation banner

1 - 9 of 9 Posts

·
RPG n00b guru
Joined
·
86 Posts
Discussion Starter #1
Right, so I'm playing this game for the umpteenth time. The opening FMV is bugging me with the choppiness, and certain spells (such as Black Sword Rune's 4th level spell) are also choppy.

Here are my specs:

Plugin: Pete's OpenGL Driver 1.1.75
Author: Pete Bernert
Card vendor: ATI Technologies Inc.
GFX card: RADEON 9800 SE x86/SSE2

Resolution/Color:
- 640x480 Fullscreen - NO desktop changing [32 Bit]
- Keep psx aspect ratio: off

Textures:
- R8G8B8A8
- Filtering: 6
- Hi-Res textures: 0
- VRam size: 64 MBytes

Framerate:
- FPS limitation: on
- Frame skipping: off
- FPS limit: Auto

Compatibility:
- Offscreen drawing: 3
- Framebuffer texture: 0
- Framebuffer access: 4
- Alpha multipass: on
- Mask bit: on
- Advanced blending: on

Misc:
- Scanlines: off
- Line mode: off
- Unfiltered FB: off
- 15 bit FB: off
- Dithering: off
- Screen smoothing: off
- Screen cushion: off
- Game fixes: on [00010000]
 

·
Registered
Joined
·
8 Posts
I very recently started playing Suikoden II again as well, so your timing couldnt have been better, and though i cant guarantee this will work, i had the same problem and it was only a matter of finding the precise FPS to run the game at for all the choppiness to go away. In my case 56 FPS.

Try that or + - a few frames and see if you can make it work right. I wouldnt bet on it though :)
 

·
Premium Member
Joined
·
3,093 Posts
IIRC Suikoden is a 2D game, so why don't you try using PEOPs plugin? Or at least pete's OGL2, your card is more than able to handle it and it works far better than ogl1 woth 2D graphics. Also, as you say it happens with intro fmv's and some spells (wich i think might be prerecorded and streamed from the cd too), you could try playing from an ISO if you aren't yet.
 

·
RPG n00b guru
Joined
·
86 Posts
Discussion Starter #4 (Edited)
Ah, I've tried using PEOPs in the past, and it causes much the same problem as far as slowdown is concerned. As far as I can see, Suikoden II does rather well with a 3d plugin, as some of the FMVs are 3d themselves.

With most of my rare games, I like to keep them in ISO form to preserve the CD itself. So that answers that question.

I'm going to try OGL2 and give some plugin specifications that worked well for me.

EDIT:

Plugin: Pete's OpenGL2 Driver 2.6
Author: Pete Bernert
Card vendor: ATI Technologies Inc.
GFX card: RADEON 9800 SE x86/SSE2

Resolution/Color:
- 640x480 Window mode
- Internal X resolution: 1
- Internal Y resolution: 1
- Keep psx aspect ratio: off
- No render-to-texture: off

- Filtering: 4
- Hi-Res textures: 0
- TexWin pixel shader: off
- VRam size: 128 MBytes

Framerate:
- FPS limitation: on
- Frame skipping: off
- FPS limit: 60

Compatibility:
- Offscreen drawing: 1
- Framebuffer effects: 3
- Framebuffer uploads: 0

Misc:
- Scanlines: off
- Mdec filter: off
- Screen filtering: off
- Shader effects: 0/1
- Flicker-fix border size: 0
- GF4/XP crash fix: off
- Game fixes: off [00000000]


Choppiness in the FMV, truly a shame, but I did find that the FMVs run at 90 FPS. Perhaps there's the key to figuring this out...
 

·
Premium Member
Joined
·
6,341 Posts
I've found that setting the Async mode in Eternal to Smooth causes occasional framerate drops on my PC and my mom's PC but setting it to Simple doesn't. If you're using those settings and plugin, try switching the Async mode. Have you tried turning on PC FPS Calculation in the game fixes section?
 

·
RPG n00b guru
Joined
·
86 Posts
Discussion Starter #6
Interesting, the PC FPS calculation makes it a tad too fast. I'm betting it only wants 45 FPS in that mode for the movies. But perhaps I really do not know.

I think there may be something within the game's programming itself that causes the PSX hadware to change FPS or something...

Any other ideas?
 

·
Premium Member
Joined
·
3,093 Posts
Yes, PC fps calculation doesn't take into acount the interlacing produced in TV's, so you should input half of the expected framerate. Then, a pal game would need 25 fps, and an ntsc 30. The weird thing is that fmv's seem to be playing at 90... No analog TV standard that i know of runs at that framerate. Why don't you try with framerate autodetection? Both with pc fps calculation on and off. Also, try disabling sound to see if it affects. You could even try disabling fps limiter, and changing eternal's async mode to wait, so that the spu plugin will limit the framerate.
 

·
RPG n00b guru
Joined
·
86 Posts
Discussion Starter #8 (Edited)
Wait mode keeps the speed at a good 60 FPS or so even with Frame Limiting off, this brings me to the conclusion that the problem may have to do with the Eternal Plugin itself.

Furthermore, I'm surprised people don't really have this problem elsewhere. I wonder if it's what I burned that's causing the videos to need a faster framerate...

EDIT: However, if I hit the 'Default' button on Eternal SPU, and take the frame limiting off, the video and music play at the correct speed. Which fluctuates between 80-100 FPS. Rather interesting...
 

·
Is this thing on?
Joined
·
2,121 Posts
Using Thread mode MAYBE is one of the most common cures to problem games.

EDIT: Your computer can MAX OUT every option in the OGL2 plugin configuration except for X-resolutions.
 
1 - 9 of 9 Posts
Top