Next Generation Emulation banner

1 - 3 of 3 Posts

·
Registered
Joined
·
92 Posts
Discussion Starter #1
Switched to Git huh?

Nice :D

Now, when VJ was on svn, I could open the directory within I/Explorer and see the version number at the top of the page (currently showing 422) but with GiT I cannot open the address to view the files.

Not really a problem as GiT d/loads everything perfecty.

but, being new to GiT, just double clicking GiT and entering the GiT clone command along with the address I am not sure that when it shows nothing changed that there really hasn't been any changes or that GiT has a problem my end.

Is there a way to see if there have been changes with the repository without running the GiT clone command ?

I have however managed to get msys to put a version number onto the virtualjaguar.exe now using GiT, whereas under SVN I couldn't get the damned thing to work. So, thanks for that :D

Nice work as ever Shamus, now keep it up :D

Ricardo.
 

·
Registered
Joined
·
344 Posts
Yeah, I'm still debating whether or not to use gitweb to serve that info to web browsers. :)

You can use git pull (instead of clone) and git log -n 1 to see the latest commit. :thumb:
 

·
Registered
Joined
·
92 Posts
Discussion Starter #3 (Edited)
ah, nice one Shamus, thanks :D

gave them commands a try, all I get is:

Fatal: Not a git repository (or any of the parent directories): .git

Wonder if it's to do with needing gitweb setup to allow the information.

Never mind though, for now I will just run a git clone evey now and then, that seems to work just fine.

Don't blame you for not allowing gitweb to serve the version info to a web browser, probably opens up access to parts that hackers would love to reach......b******s that they are....


Keep up the good work Shamus :D :D
 
1 - 3 of 3 Posts
Top