Next Generation Emulation banner
1 - 9 of 9 Posts

·
Registered
Joined
·
603 Posts
Discussion Starter · #1 · (Edited)
Yet another game giving me problems. Though I checked some other topics already regarding this, but the topics that contained this problem didn't have any real working solution posted.

I just started SO2, it works fine, sound is fine, etc etc. But then when I enter the first fight in Arlia, it gives me a black screen with Japanese text, and the entire emulator then freezes.

Here are the settings I use:
Code:
Plugin: Pete's OpenGL2 Driver 2.9
Author: Pete Bernert
Card vendor: ATI Technologies Inc.
GFX card: Radeon X1650 Series 

Resolution/Color:
- 800x600 Window mode
- Internal X resolution: 2
- Internal Y resolution: 2
- Keep psx aspect ratio: off
- No render-to-texture: off

- Filtering: 0
- Hi-Res textures: 0
- TexWin pixel shader: on 
- VRam size: 512 MBytes

Framerate:
- FPS limitation: on 
- Frame skipping: off
- FPS limit: Auto

Compatibility:
- Offscreen drawing: 1
- Framebuffer effects: 2
- Framebuffer uploads: 2

Misc:
- Scanlines: off
- Mdec filter: on 
- Screen filtering: on 
- Shader effects: 5/3
- Flicker-fix border size: 0
- GF4/XP crash fix: off
- Game fixes: off [00000002]
For the sound I use Eternal SPU 1.5b2 with the Star Ocean 2 fix enabled. (Tested it without the fix as well, but no good results).

Edit:
Tried Pete's OpenGL 1.77 plugin as well, but no success there either. The only change is that the Japanese Text isn't there, but it still freezes.

Edit 2:
Nevermind. The Japanese text does appear, just at the top this time.
 

·
Registered
Joined
·
603 Posts
Discussion Starter · #4 ·
Solved this.

Somehow it was due to 1.7.0

I entered the same area in 1.6.0 with the EXACT same settings, and while the screen did go black for a moment, it quickly went away and started the battle as normal. Everything else after that point went smooth as well.

Looks like it was a bug with 1.7.0 and maybe a particular setting that it didn't like for SO2.
 

·
Registered
Joined
·
603 Posts
Discussion Starter · #7 ·
Well the black screen issue somehow went away on its own in 1.7.0 as well after passing it in 1.6.0. But now I ran into another problem.

I'm in Eluria Town now, and the scene changes to a Space Ship, where some conversations take place, after that it's supposed to switch back to the main party, the screen goes black, and then........ Opcode 3B UNK (PC 00000114) (3045281,0) error.

I tried it in ePSXe 1.6.0 too, but it crashes there as well.

I'm already running it through CD with subchannel reading on.

The sad part is that I have a Save State right before the crash, and there's no actual savepoint in that area, so I can't load from a Memory Card either. So either I'm screwed and have to start over, or someone might know what the cause is. D:

Edit:
Nevermind. Got around it.

Used a cheat to "save anywhere" and then loaded from memory card. Solved the problem.

No more save states with this game. Going to use the Memory Card from now on.
 

·
God of Douchebagness™
Joined
·
9,826 Posts
you should is make a real memory card at every chance or point the game normally lets you, if you do this you can still use save states but you dont have to worry about loosing progress if something was to go wrong as often.

if you want to take it a step further, you could make a copy of whatever memory card is being used and keep that somewhere else as a backup in the event a save state actually screws up your memory card data as well.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top