Next Generation Emulation banner

1 - 13 of 13 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1 (Edited)
I am almost at the end the game and I have been playing normally so far, but now my game freezes 2-3 seconds after I open the menu. I think this can be avoided by reloading, but my last hard save is many hours old and I just want to know if there's any way to fix this without playing half the game all over again.
EDIT: I forgot to say I'm using v1.6.0 because the newer one wouldn't load my ISO.
I don't think this will make difference since, like I said, I played through the game almost completely without any problems, but here are my settings:
Code:
Plugin: Pete's OpenGL2 Driver 2.9
Author: Pete Bernert
Card vendor: NVIDIA Corporation
GFX card: GeForce 6200/AGP/SSE2

Resolution/Color:
- 800x600 Window mode
- Internal X resolution: 1
- Internal Y resolution: 1
- Keep psx aspect ratio: off
- No render-to-texture: off

- Filtering: 4
- Hi-Res textures: 0
- TexWin pixel shader: off
- VRam size: 0 MBytes

Framerate:
- FPS limitation: on 
- Frame skipping: on 
- FPS limit: 130.0

Compatibility:
- Offscreen drawing: 0
- Framebuffer effects: 1
- Framebuffer uploads: 0

Misc:
- Scanlines: off
- Mdec filter: off
- Screen filtering: off
- Shader effects: 0/1
- Flicker-fix border size: 0
- GF4/XP crash fix: off
- Game fixes: off [00000000]
 

·
God of Douchebagness™
Joined
·
9,826 Posts
so you are using save states? i hate to say it but that could indeed be the problem, they are rather unstable and can lead to a wide range of issues if one becomes corrupt (freezing being one of them), and once it does its pretty much FUBAR.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3 (Edited)
Well, yes I am using save states. I usually try to be careful and keep one "safe" save state in case something like this happens, but this isn't the case.
In any case, I think I figured out the source of the problem: memory cards. I can't say I'm sure, but after deleting and re-downloading/installing the emulator, the game no longer freezes on the menu. Now it freezes if I try to save within the game (NOT save states). This is a much smaller issue since I no longer need to save, but if there's a known cause/fix for this, I'd like to hear it.
EDIT: This is rather weird but the problem is back. I don't know what changed between 1 minute ago and now but I can't go to the menu anymore. I did not advance through the game so it must be something with the settings. I think it has something to do with memory cards. Any ideas?
EDIT 2: Problem gone again. What I did was pointing my new install of ePSXe to the old memcards folder, then I deleted both of the memcard files. So, basically I have no memory cards now. I would try to actually fix this but since I really don't understand why it got messed up nor why it works now, I rather leave it as it is. Unless someone knows how to fix it.
P.S: Sorry for all the edits and self answers.
 

·
Banned
Joined
·
23,263 Posts
Framerate:
- FPS limitation: on
- Frame skipping: OFF (skipping can cause games to freeze)
- FPS limit: 130.0

Compatibility:
- Offscreen drawing: 1
- Framebuffer effects: 2
- Framebuffer uploads: 2

Fixing memory card issues related to save states is mentioned in the First Stop sticky.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #5 (Edited)
I seriously do not understand the instructions given in that thread. If I go to memory card dialogue and type a name, then press open, nothing happens. No new files are created. Also, I don't understand what this means:
So once the state is loaded, hit escape, then select the other 2 files you created, Resume emulation then save to them
What do you mean with "select the other 2 files"?
I tried following the steps but I end up with no files at all in the memcard folder or with the game freezing again.
 

·
Banned
Joined
·
23,263 Posts
Nice Catch, I'll update that now.

Instructions fixed.

Btw, Triace games may freeze or have issues if a memory card is set with certain saves on it.

Valkyrie Profile, for instance freezes when trying to access a memory card with more then 2 FF7 saves on it.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #7
I'm still doing something wrong. I now have 4 memory card files which I just created following the instructions. I follow the steps, but when I try to save the game freezes. The game finds and reads the memory cards and they show no saved games. When I try to save (after selecting a slot and choosing "Ok") the game freezes. This didn't happen before as I actually had saved games.
 

·
God of Douchebagness™
Joined
·
9,826 Posts
you are using epsxe 1.6.0 right? try pressing F4 when it freezes.
 

·
Banned
Joined
·
23,263 Posts
unfortunate, that i don't have this game to test.

In this instance, i would make a mental note of where you are, and then download a memory card file form gamefaqs, from a save point relatively close to where you are.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #11
Sadly, there are no saves in gamefaqs that are close to my own. Anyway it doesn't really matter because I am abandoning this game since I met with another nasty problem: my screen goes black when I do a certain action (play "The evil melody" in case you are familiar with the game). To be honest I had it with this game, even though I like it I don't want to waste more time trying to fix the many problems it gives.
Thanks for all the help.
 

·
God of Douchebagness™
Joined
·
9,826 Posts
try it on psx and see if it plays better, that emulator is sometimes easier to work with anyway since it doesnt use a plugin system.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #13
Well the game runs on that emulator too, but I can't save my game on ePSXe and it's save states seem to be different than the ones from PSX. In any case, I dumped the game already but thanks anyway.
 
1 - 13 of 13 Posts
Top