Next Generation Emulation banner

1 - 18 of 18 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
hello...

im playing silent hill for a while
and im using savestates to play it...
first i used the internal spu plugin
but i wanted to try the prodigy plugin
i used it
saved
but i liked the internal plugin and changed again
but now i have no sound
could anybody help???
what can i do???
 

·
Registered
Joined
·
1,238 Posts
simple: almost all the spu are supporting save states now.
The only one (and newest that does not support it tough is this one: Prodigy spu)
Although that one is a continuation of the discontinued null2 spu, I suggest u to give it a try if it worked for the prodigy one...
(although i recommend u to grab the 1.35 version, even if it makes some flickering in mdecs...)
I ll post it here

Bye

Sawasdee
 

·
Registered
Joined
·
1,238 Posts
well i ve also included the latest spu's that are supporting the save states feature

here it is (just unzip it in the plugins directories)

errr if someone could post the peteDsound too, that would be great.....even for me.
I ve just noticed i lost it:confused:
 

·
Super Moderator
Joined
·
6,283 Posts
OK,since the only version supporting savestates of null's SPU is buggy,I think you should either use the internal plugin,Iori's,or Pete's.
Here's Pete's latest.
 

·
Super Moderator
Joined
·
6,283 Posts
Woops seems I misunderstood your problem.
Well to get sound back,just make a normal save on a memory card.
Restart the game and you'll get sound back.
You'll be able to use savestates but only use them with a plugin that supports them or the same problem will occure.
Here is attached Iori's latest SPU so you can try all available SPU to found the one you prefer.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #7
thank you...

but my problem is
that i cant use the memory cards
i dont know why
it says the memory card is not formatted
when i want to format it, the game crashes
if i want to start a game with a formatted memorycard and i load the savestate its again unformatted..
is there no other way to get my sound back?
 

·
Registered
Joined
·
1,238 Posts
Well, it seems that if u want to play w/ sound again and ur save state, u must reach a certain point in the game where the music changes (that s what i ve done w/ the 1.34 null2 spu anf FF9)

For the memory card problem; grab epsxe cuttor 11.0.4 at www.psxemu.com ; then go in the mem cards configuration...then create some memory cards..
U should see something lke this: (no formatted memory cards)
 

·
Registered
Joined
·
1,238 Posts
( ??????? strange picture above.. but that s not a problem...)
Well, then select a memory card and format it...
then put one in the slot 1 and the other in the slot 2 like this...
U should be able to save..

Bye
 

·
Super Moderator
Joined
·
6,283 Posts
What do you mean by "strange picture"? It looks fine to me.
 

·
Registered
Joined
·
1,238 Posts
Now it seems too....

The uper down of my first picture seemed very dtrange yesterday....
White and black lines...
Now it s just ok...
Well
 

·
Registered
Joined
·
34 Posts
Discussion Starter #12
no, i cant save...
when i try to format it within silent hill
the game crashes
when i start it with a formatted memory card
and i load a savestate
the memory card isnt formatted any more
i think the savestates save the memory cards as well...
 

·
Super Moderator
Joined
·
6,283 Posts
No,the savestate doesn't save the emory card since version 1.4.0(actual version:D ).
You should try to press F4 before saving,I'm sure it will work.
 

·
Registered
Joined
·
1,238 Posts
Listen:


The save states have NO relations w/ the memory cards....
Do u understand?
Try to do like i said above...

Bye
 

·
Registered
Joined
·
34 Posts
Discussion Starter #15
ok...
i tried everythink you have said
i pressed f4 before accessing the memory card
but please explain
why the memory cards are allways "not formatted" when i load the savestate?
i tested it
i used the memory card
saved another game on it
played silent hill
loaded a savestate
and again the memory card is unformatted
and when i look at the card
the previous save game is gone
can you explain that?
i use the actual epsxe...
 

·
Registered
Joined
·
1,238 Posts
oh man!

I thought this problem has been solved w/ the latest release of epsxe!
Damn!

So listen:

When u load a save state, it llload all ur settings U had at that moment (in the game).
So 2 solutions:

1)
Play the game again from the beginning w/o save stating.
Ur memory card should work fine.
2)
Play only w/ save states.
I guess it s the best solution.I ve beaten ff9 like that!

So use a pspu which support the sound resuming features (actually all, except the prodigy one)

Sawasdee
 

·
Registered
Joined
·
34 Posts
Discussion Starter #17
ok...
now it works
thank you very much
but its funny...
i have to start espxe without the epsxecutor
start the game
load a savestate
go to a save point
press f4
format card
wait
wait
wait
wait
and after a while
ca 2 minutes
it saves the game
then i restarted epsxe
i choose "continue"
it reads the memory card
i see my save game
but
the screen changes and theres a message that no memory card is inserted...
i closed epsxe
tried it a few times
and everytime the same
but
in the end
when i saw the "memory card not inserted" screen
i waited
about 2 minutes again
and suddenly the memory card is found
strange isnt it???
now it works and i use savestates
there i dont have to wait for so long
but now i have the problem that sometimes the game stops for about 20 seconds and then it works again with about 59,9 fps...
 

·
Registered
Joined
·
1,238 Posts
Sorry to have been so long to answer.

Well, u ve said it, that s strange.
For the in game freeze (the 20 seconds, try all the cdr plugin u can find or better play w/ an iso. It should be faster)

Sawasdee
 
1 - 18 of 18 Posts
Top