Next Generation Emulation banner

1 - 20 of 47 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
my pc--
cpu--i5 8600k--not overclocked--hyper 212 cooled
motherboard--z370 gaming plus
ram--16gb ballistix sport lt 8gb x2 dual channel--not overclocked
video card--gtx 1080 founders edition--drivers are 399.24 as the 400 series cause me serious frame drops in my other games
hardrive--samsung 850 250gb ssd

windows 10 1809 build 17763.292

espxe 2.0.5
no plugins all core
bios scph1001
setup according to basic setup guide but i noticed some weird frame issues also...ill explain below
gamepad dualshock setup--default keyboard mappings
using xpadder for macros and other button combinations--various fighting games--ect

backstory--my daughter is into vampires ect and i wanted to introduce to her a few games that i played oh so long ago...ie castlevania symphony of the night and blood omen legacy of kain.
ive used espxe back before version 2.* but something has changed and is causing me tons of sound grief.

so using the basic setup guide and pete's opengl2 2.0.0 and these settings i get the sound crackling.
t1.jpg
the fps fluctuate wildly...57 60 58 70 60 57 58 60...like so...sound crackles.
but if i press "F4" and set the "frame limit" to "OFF"...sound smooths out and fps lock to 60 fps.
but if i uncheck "use fps limit" in plugin settings and restart the game...my fps go to the moon like 400 or so.
are not "F4" and "use fps limit" the same function?? lost.
can i always start a game with the "F4" setting off...so i dont have to keep toggling this all the time?

gpu core 2.0.0 works a treat only if i set the custom fps to 60...setting it to 0 or any other number other than 60...makes the sound crackle.
any reason why it has to be this way here? i need to learn.

any help would be much appreciated. i would like to get both cores sound issues figured out.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #3
crackle is still there but not as bad...fps still fluctuating, a little stuttering..."F4" fixes sound and the fps display flucutates but i dont notice any tearing or stuttering.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #5
hey no worries...thank you for trying.
ive gotten mednafen, xebra, and retroarch to work absolutely great...but there's this special place in my heart for epsxe...i really want it to work.
 

·
Registered
Joined
·
311 Posts
I use ePSXe updated, 2.0.5, on an extremely modest laptop and I have no problem with "Castlevania - Symphony of the Night", even in live stream! You're not the first to complain about sound or sync problems using ePSXe on extremely powerful Windows 10 machines. I do not want to insinuate anything, but I would like to find out the reasons.

Some updates to users regarding the behavior of the latest version compared to the old version of the same emulator:

(a) the emulator is more stable using the native plugins, do not add any plugin;

(b) there is some synergistic relationship between native plugins;

(c) the Pete's OpenGL video plugin has fps fluctuation without any damage to gameplay, and this has to do with the inner workings of the SPU plugin;

(d) even 10-year-old computers can run Pete with all the options at most, the plugin is not heavy by today's standards, and its problems are usually due to its emulation quality failure than to a lack of hardware power;

(e) usually in relation to 3D games with Pete there are only two options to consider: Threading Mode [use "0: 1-Thread" or "3: 2-Threads (more effects)"] and Off-Screen drawing [test the three options according to the game and with the presented glitches].

(f) the Pete plugin produces great graphical improvements when using 3D games in relation to ePSXe GPU Core, but it does not have the same degree of accuracy, fidelity. The Pete plugin does not produce a series of screens (missing screens) besides introducing noises in image;

(g) if in 3D games the Pete plugin can be recommended, when we are talking about 2D games only the ePSXe GPU Core makes sense to use. Try the ePSXe GPU Core in 3D games too, at least 2x high internal resolution your machine should be capable to play most 3D games, and although the number of shaders is small relative to the set of shaders for the Petes, the reliability of the plugin is a relevant factor of consideration. It is extremely solid in native emulation at 1x internal resolution.

(h) although the name "GTE Hacks" is attractive, I do not recommend using any of them as they both produce a series of unexpected distortions.

Recommendations:
(1) Emulator - Config - BIOS - DISABLE HLE Bios;
(2) Emulator - Options - CPU Overclocking - x1;
(3) Emulator - Options - CPU Mode - Dynarec (Fast);
(4) Emulator - Options - GTE Hacks - Both Disable!;
(5) if you have made a disk image, check its hash with those listed on the redump site.

Redump PS1: http://redump.org/discs/system/psx [only cue and hashes]

Having said all that... you will have more success for 3D games, better quality emulation with graphical enhancements using RetroArch Beetle PSX HW using the OpenGL or Vulkan driver.

ePSXe is much simpler to configure, much more user friendly, however, lacking in features for users with a lot of "raw power". Make no mistake, I'm ePSXe enthusiast but I can not deny the facts. Beetle is the current emulator for state of the art of present hardware.

* If you'd prefer to continue using ePSXe, please let me know the full game name and the minimally consistent location where the problem occurs. Castlevania Symphony of the Night I already completed in live stream, using ePSXe GPU Core and OBS-Studio, in a first-generation i3... I had no problems.

** I've already monitored CPU usage using "0: Normal Latency" and "5: Low Latency" and noticed no variation. If there was, it is very low, even for my processor. At the same time I've never noticed any variation in gameplay. I would like to know a scenario where this change is advantageous.

cheers
 

·
Registered
Joined
·
26 Posts
Discussion Starter #7
i will look into it...sleep beckons...thank you for your time. at best i can get it working...at worst ill shelve it and move on to the others and just remember the good old times/days. thanks again /salute
 

·
Registered
Joined
·
17 Posts
My previous answer wasn't complete, I forgot one thing that helped me solve the crackling sound.

Change "Auto-detect FPS/Frame skipping limit" to "FPS limit", you can let the 200 value and don't check "Use FPS limit".

The reason the crackle is happening is because the frame rate is controlled by the ePSXe audio plugin. So, if you use "Auto-detect FPS" then both plugins are trying to control the FPS and then the crackling sound happens.
 

·
Registered
Joined
·
2,149 Posts
ideally you use the internal plugins (the core ogl2 is pete's only hacked to include extra features) and the internal SPU... yes the SPU controls sync.. but , personally I get no crackle using all internal stuff... sync is locked at 50/60fps and sound is perfect
 

·
Registered
Joined
·
26 Posts
Discussion Starter #10
My previous answer wasn't complete, I forgot one thing that helped me solve the crackling sound.

Change "Auto-detect FPS/Frame skipping limit" to "FPS limit", you can let the 200 value and don't check "Use FPS limit".

The reason the crackle is happening is because the frame rate is controlled by the ePSXe audio plugin. So, if you use "Auto-detect FPS" then both plugins are trying to control the FPS and then the crackling sound happens.
can i get a screenshot of your settings...im not understanding you?
 

·
Registered
Joined
·
26 Posts
Discussion Starter #11
ideally you use the internal plugins (the core ogl2 is pete's only hacked to include extra features) and the internal SPU... yes the SPU controls sync.. but , personally I get no crackle using all internal stuff... sync is locked at 50/60fps and sound is perfect
can i also get a screenshot of your settings?
 

·
Registered
Joined
·
2,149 Posts
my settings are simple... internal SPU and for Internal ogl2 gpu, I have the output set to 1920x1080, I have use window size in full screen and have that set to 1500x1080 (so i get decent 4x3).... x and y are set to maximum, single thread is set (2 causes issues)... auto detect FPS is set... frambuffer stuff is set to standard (all 3 options) and I use a shader
for the internal software GPU (core 2.0.0) I use 4x for most games for resolution, 4x3 aspect, standard brightness and ogl2 blit, auto detect fps is set as well...., audio is always perfect
 

·
Registered
Joined
·
311 Posts
I don't believe that the option "Use FPS limit" work at all when using native SPU + native Pete GL2 Core.

It works when using all others video plugins, with all other sound plugins, but not when using GL2 Core + SPU Core.

On my machine for sure there is no effect, and this is an example of what I meant by the "synergy" between native plugins. The same option for the other plugin [ePSXe GPU Core] works as expected.

cheers!
 

·
Not a Registered User
Joined
·
1,303 Posts
I don't believe that the option "Use FPS limit" work at all when using native SPU + native Pete GL2 Core.

It works when using all others video plugins, with all other sound plugins, but not when using GL2 Core + SPU Core.

On my machine for sure there is no effect, and this is an example of what I meant by the "synergy" between native plugins. The same option for the other plugin [ePSXe GPU Core] works as expected.

cheers!
Thats cause ePSXe 2.0.0 uses the SPU plugin for synchronisation and fps limitation not the gpu plugin. that function will not work with ePSXe 2.0 and newer if SPUcore is used.
Also if you're using other plugins than the default plugins use ePSXe 1.9.25 or older as ePSXe 2.0 and newer isn't fully compatible with other plugins as they weren't updated in over a decade.
ePSXe 2.0 and newer should only be used with it's default plugins.
"Use FPS Limit" is best left unticked when using SPUcore with OGL2 plugin, the fact that leaving this option unticked and OP getting 400fps means he's not using SPUcore.
 

·
Registered
Joined
·
2,149 Posts
also note that with epsxe 2.0.0 and up, the old shortcut keys in pete's do not control frame limit any longer... it is now F4, it turns Frame limit off and on (it shows on screen as well)
 

·
Registered
Joined
·
26 Posts
Discussion Starter #18
ive tried your guys setups and nojoy...sound still has static.
the only way i get good sound in the gpu core is to "set custom fps" to 60 and check "use fps limit"
its workable for 2d games at least.
now the pete's open gl2 core, no matter what combination of settings i choose, yours or mine...
the only way to get the sound to stop crackling/static is press "F4" and turn off framelimit.
a bit of a hassle but still workable.
is there any reason as to what could affect sound ie hardware, windows, drivers?
i appreciate all the help im getting.
im going to say with both workarounds, i can at least use epsxe to play on.
just wish i could figure out why it works for you guys and not for me without tweaks. hmmm.
 

·
Registered
Joined
·
311 Posts
Do you consider this simple setting graphically unattractive?

2019-02-15 04-06-09.png



There are two improvements: (a) increase of internal resolution [2x for 3D games] and (b) use of shader [in this case, technique for decreasing aliasing].

The increase of the internal resolution is executed by the CPU when using this plugin, therefore, it greatly affects the performance. However, shader usage is performed by the GPU and thus does not influence the emulation cost at all and therefore does not affect performance. On your computer, your GPU is not afraid of anything, it is extremely powerful, and for your CPU at least 2x the vast majority of games should be able to run smoothly, and at least a few in 4x.

There are alternative shaders for the Core GPU, "thin thing"! ["coisa fina" in portuguese means "good luxury"]

Choose the "99: Custom" option and then click the "..." button and choose a folder with one of the shaders from the link below:

https://www.ngemu.com/threads/epsxe-gpu-core-2-0-custom-shaders.191049/

ps: I'm also interested in knowing if VSync's GPU driver is disrupting the emulator's performance! :D

cheers!
 
1 - 20 of 47 Posts
Top