Next Generation Emulation banner
1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Since my PSX died I have been unable to play all my old PSX games, and I am trying to get my hands on a cable for my PS2 to hook it up to a tv (Tried many shops and nowhere near me sells one!!! GRRRRRRR).. anyway.. I figured I could play my PSX games on my PC using an emulator. I have got "Pcsx2.0.9.6" for runnign my PS2 games and I use "ePSXe 1.7.0" for PSX games. Up until recently I have had no problems running PSX games until I tried Soul Reaver.

I insert the disk into my dvd drive and select that drive and launch the game. I get a black screen with the picture of the controller in the top right hand corner and it just sits like that. I tried running from both the CD and creating an image of the disk and running from ISO.. I also tried mounting the image in daemon tools and running from that... all gave the same results... nothing. The light on my DVD drive doesnt even light up showing the emulator is not even trying to access the dvd drive.. yet when I try to run other games it works no problems.

Can anyone offer any advice?

My hardware specs:
Toshiba Satellite A100-926
Intel Core 2 Duo T7200 @2GHZ
3GB DDR Ram
512mb X1600 ATI Mobility Radeon

ePSXe settings:
ePSXe 1.7.0
Pete's OpenGL2 Driver 2.9
ePSXe SPU core 1.7.0
ePSXe CDR WNT/W2K core 1.7.0
 

·
Banned
Joined
·
23,263 Posts
this specific game makes use of libcrypt and will not boot without subchannel enabled (and a drive that can read it)
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Thanx for the reply :)

Yeh I saw on a site someone mention it had some sort of protection in it of sorts... libcrypt?

How do I enable subchannel?

A drive that can read it? Well.. if I copy the disk to ISO and then mount that then that should work, if my DVD drive doesn't support subchannel...

I can explore the disk in windows explorer easy enough and see all the files, I have been visiting the lost worlds website to try to find ways of extracting video and sound clips etc from the game, can't find a way to extract the video yet :( anyway... offtopic... haha
 

·
Banned
Joined
·
23,263 Posts
unfortunately not (atleast with ISO) Since ISO is a content image and not a disk image it misses the protection completely.

You will want to try CCD, MDF or NRG images (CloneCD, Alcohol, Nero) and then mount the image using that.

Then you just enable subchannel reads in the CD plugin screen.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
CCD, MDF or NRG? I don't use Nero but I do have Alcohol and CloneCD so will give them a go when I get home tonight. Thanx a lot, hope this works!! I have been trying to get all 5 of the games in the series to run so I can play right through them one after the other and Soul Reaver was the only one that was giving me problems, as I have Blood Omen 1+2 and Soul Reaver 2 on PC and Defiance on both PC and PS2 so they all run fine.. only issue was Soul Reaver.

I do have Blood Omen 1 on PSX and got it running... a few gfx errors, the side bar would become distorted at times... but I have Blood Omen 1 on PC running without any issues anyway so can play it on that :)

Shame they cancelled the series and won't release the final game in the series.. its like watching a 3 hour movie and the last 10mins of the film being shopped off!! Highly frustrating.. *shrugs*
 

·
God of Douchebagness™
Joined
·
9,826 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #7 ·
Well I created the image using Alcohol 120%, I mounted the image and then ran the CD drive and the game works!! Few issues with it tho.. the opening video was pretty jerky but I changed a few settings and its a bit smoother now... but straight after you are thrown into the abyss and the quid god is talking to you I can't hear what is said. Background music is there and sound effects like when I jump or attack etc.. but when it comes to the cutscenes I can't hear the dialog... but hey! At least the game is running!! I can make do with that until I find a cable for my PS2 :) cheers :)
 

·
Banned
Joined
·
23,263 Posts
it might help to use Eternal SPU.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #9 ·
I have tried:

P.E.Op.S. DSound Audio Driver 1.8 (Seems to work well for most games I throw at it)
ePSXe SPU Core 1.7.0
Eternal SPU Plugin 1.41
Eternal SPU Plugin Lite 1.41

same problem... :-/ perhaps I just have to keep tweaking the settings *shrugs*
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top