Next Generation Emulation banner

1 - 20 of 23 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter · #1 ·
Hi

Just got myself 2 Smart Joy USB adapters for ps2 joypads, and they work great in all my emus except, ironically, ePSXe... :eyemove:

I can configure the butons, but as soon as I go ingame, the joypad cease to work (even when i toggle f5), however this problem only occurs in 1.6.0, not in 1.5.2, and I use the exact same settings in the two. :hdbash:

Any help is much appreciated, since some of the games I wanna play only boots in 1.6.0.

Thanks :)
 

·
Is this thing on?
Joined
·
2,121 Posts
CONFIG--->GAMEPAD--->PAD 1/2

Ensure that both pads are properly configured in ePSXe 1.6.0.
On the top right-hand corner, there should be a drop-box.
Change it to Analog/Digital.
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #4 ·
but oddly enough the f5 swith dosnt show anything in the logwindow as it usually does, but as I said, its the same in 1.5.2 and works fine...
 

·
Registered
Joined
·
183 Posts
is f5 mapped to a gamepad key in the PAD plugin perhaps? Do other quick hacks/switches work AND show up in the log menu? Is there a keystroke logger or keyboard wrapper installed that changes the function of certain keys on your keyboard?

If it is DirectX (I kinda doubt it, but i wont throw the idea out the window), all you can do is reinstall the latest version of DirectX and always tell it to replace files when it asks.
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,978 Posts
have you tried PSXeven or SSSPSX with a pad plugin? see if those games that only boot in 1.6.0 work in those emulators.
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #8 ·
nah I prefer epsxe so that no solution to me, I want both my pads to work in epsxe.

Unfortunately BlueKirby0 I have tried everything you say, exept other quick hacks/switches, which I am not sure what is?
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,978 Posts
man, are you too lazy to download and configure another emulator or what? i should really watch what i give as advice to you, you might prefer your current settings. did you even consider the possibility that using another emulator might fix your problem? well since you obviously prefer ePSXe keep on using it.

oh and by the way, don't triple post.
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #10 ·
Why is it that people tend to get angry when they dont have a solution to a problem, lame.

And I am not too lazy to use another emulator, epsxe happens to be the best though, and works better on my system, thats all. and I thought maybe it was possible to have it work with two smartjoys.

I appreciate you and others' help, but please dont get angry when I kindly ask for another solution, this msgboard is for helping others right? And if I wanted to play my games in other emulators, then maybe that would have been what I asked for help with. I want it to work in epsxe though, and I am sure its possible, so anyone know how, or maybe had the same experience?

If this happens to be a bug in 1.6.0 I might just end up helping the emulator get better, how about that hushypushy? =) jk
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,978 Posts
1. i tried helping you. i offered a solution and didnt take it. i cant even make an analogy out of it because it's as basic as it gets. imagine you're having troubles with, say, your girlfriend, and you go to a friend and say 'what do i do?' and your friend gives you advice and you tell him to blow it up their ass.
2. how can you say ePSXe is "the best" when you simply "prefer" it--it's obvious that you havent put the time in to test it out with your current problem. maybe if you had said, "i tried it with PSXeven and SSSPSX and i got the same error" then you'd be less full of crap.
I appreciate you and others' help, but please dont get angry when I kindly ask for another solution, this msgboard is for helping others right?
3. please refer back to number 1. how would your friend feel if you go told him to blow it up his ass? think about how i felt. dude, i dont want to sound cocky, but i deal with PSX problems every day. if you look at many of my posts, i basically say the same thing to everyone. you have to go through basic troubleshooting steps when you start out. and you telling me to shove it (basically) is rude and tells me you dont even care. you want to fix the problem at YOUR convenience as opposed to how i help you. would it make a difference if bluekirby0 urged you to use a different emulator?
4. if it happens to be a bug in 1.6.0, you'll never know will you because you refuse to try another emulator to prove that this happens only in 1.6.0. ePSXe is not dead, but it's moving slow. and i doubt they will add a bug fix for a problem that no one else has ever had, not to mention one that they probably cant replicate unless you send them 2 of your USB adapters.
And if I wanted to play my games in other emulators, then maybe that would have been what I asked for help with.
5. let's say you used AdriPSX. that is a really old emulator. back in the day it was fantastic but it has been passed up by other emulators. it doesnt support real memory card saves nor does it support disc change. imagine you are playing, say, chrono cross and i urge you to switch because of those two reasons. (once you get to the end of disc 1 you're screwed...and you cant convert out your mem card either). would you still not switch saying, 'this is what i play my games in leave me alone'. you are basically doing that now, just in a less extreme example. using another emulator might solve your problem. it might not. the reason i suggested it is because with other emulators you can use PAD plugins. due to the fact this is a controller problem i figured that would be somewhat important.

hey, listen. i dont have to help you. and if you dont want me to help you, tell me. I'll stop, i promise.
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #12 ·
Let me repeat myself first, I tried other emulators, and the pads work in them, but the games I wanna play dosnt, at least not as smoothly as in epsxe. The pads also work in epsxe 1.5.2, so isnt that proof enough that this is 99% sure 1.6.0 related, maybe I am wrong.

But one fact is still true though, nomatter what you think, you still didnt give me 1 single possible solution to my problem in epsxe, just throw dirt in my face and tell me to use other emulators. Want me to reply to all the posts in here: "Try another emulator" - which could probably be answered to any question in here as a easy way out.

If there is no solution fine, then I know at least that, but I am far from convinced yet.

And this will be my last post explaining my very simple question. Hopefully someone have an answer.

And hushypushy, please dont attack me again, I wont read it, so no need to waste your energy. My only interest is getting these 2 pads to work, thanks to anyone who can give me a solution or a good idea that I can try.
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,978 Posts
isnt telling you to use another emulator a solution in itself? man, stop rubbing your pootie over ePSXe and stop being so self righteous. a lot of people have been helped by switching emulators, so dont think my advice is so bogus.

oh, and thanks for basically correcting yourself and THEN saying im full of crap. you said you "prefer" ePSXe when you didnt even mention that you tried other emulators etc etc. maybe since the gamepads work in other emulators, and your games dont, you should be asking how to get the games working in the other emulator? just something to think about.

Want me to reply to all the posts in here: "Try another emulator" - which could probably be answered to any question in here as a easy way out.
heh, just read the posts around here. i (or someone else) basically say that to every thread. did you ever stop for a second to realize why the moderators and frequent users of this forum never ask for help? we've realized the basic troubleshooting steps that you use. we then pass that knowledge on to anyone who comes. you gotta start at the bottom, eh? trying a different emulator is the first step.

but seriously. read that second paragraph again. since the pads work in other emulators, what's wrong with the games? i have a feeling it'd be easier to troubleshoot the games rather than the controllers. unfortunately ePSXe doesnt support pad plugins. maybe next release....

incidentally, what are the problem games?
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #14 ·
So the conclusion is: There is no way to make two SmartJoys (newest models, advertized on ePSXe frontpage) work in ePSXe?
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,978 Posts
not really sure, since you're the only one testing it. if we had a group of 10 testers trying their best to get it to work and it didnt, then you could say it doesnt work. but for now, since it's just you, it's really a "we dont know".
 

·
Registered
Joined
·
17 Posts
I don`t think smartjoy plus adaptors work under Epsxe, at least, i`ve never been able to get the analog working on them. I think I got it all working once but only for V1.60 which is not very stable. Ironic isn`t it since they are advertised on the Epsxe homepage. It has been a long time since a Epsxe update maybe it is time to try a new emulator.
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #17 ·
Hi Guys, I did some intensive testing last night, here are the results:

1 SmartjoyPlus Adapter With PS2 DualShock Controller: works in both 1.6.0 and 1.5.2 (analog/digital F5)

2 SmartjoyPlus Adapters With PS2 DualShock Controllers: None of them works in 1.6.0 (digital/analog F5), but same settings in 1.5.2 and they both work fine. HOWEVER, if you change the setting in 1.6.0 to digital only (input) the controllers work! And you can just switch between analog/digital on the controller itself, and both analog AND digital will work. The input setting has to be digital only though.

*RSK is headed back to Gunners Heaven, FF9, SOTN and Gradius Gaiden :)
 

·
Registered
Joined
·
17 Posts
Smartjoy plus works or not? I don`t understand you? In number one you say it does then in number two you say not??

How did you get it working? Epsxe won`t even recognise the analog when setting up the pad on mine. (1.5.2)
 

·
Registered
Joined
·
654 Posts
I don't usually like to offer solutions that involve spending additional money, but in this case I think the solution is worth it.

Radio Shack sells a USB adapter for DualShock (and DualShock 2) controllers that works quite well with ePSXe. The analog sticks work fine, and so does rumble (through DX, not Burutter). It's what I use, and I'm very happy with it.

Cost: $13US


Dan
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,978 Posts
heh, i was going to suggest that, but after RSK got mad when i told him to try a different (free) emulator, asking to buy another controller was out of the question :rolleyes:
 
1 - 20 of 23 Posts
Top