Next Generation Emulation banner
1 - 20 of 23 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hello,

I am currently experiencing very odd problems framerate wise with several games. These include, but are not limited to:

Rage Racer
Wipeout 2097
Ridge Racer Type 4

What happens, is that, the game can run smooth for a certain part of a track, and be completely awfull at another part, and it will statically have the said slowdown at these spots.

In Rage Racer , for example, after I start a grandprix, the framerate drops from 30 to 20 just after the finish line - however, if i switch to outdoor view, it goes back up to 30!

Now even funnier is, that with the latest OpenGL Plugin from pete, and switching sound plugin from the SPUCore (that came with epsxe) to another one, my framerate stays at 30, and the game does not stutter at all.

Very odd indeed - but as soon as I switch back to the SPUCore plugin, the stutter or framerate decrease comes back :(

So my question is, is there a fix for this?

P.S: My system specs are as follows:

Intel Core2Duo E6600 @ 3.06Ghz per core
4GB Ram DDR2-800 @ 900Mhz
nVIDIA GeForce 260 GTX
epsxe version 1.7.0

Any help would be greatly appreciated.... because with games like Wipeout 3 this issue does not happen... (so it doesn't seem to be CDDA related)
 

·
Banned
Joined
·
35,081 Posts
Don't use the spucore then :\ simple as that. some games just don't run well with it.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
Well, if i was to not use the SPUCore Plugin, I would be losing CDDA playback in many games, which is honestly, not an option to me, as music is essential to games.

However, I just tested further, and basically right now, when I use Petes OpenGL Driver 1.78/Petes D3D Driver 1.77 with SPUCore it will _always_ have this issue, no matter what settings I have setup.

If I however, change the audio plugin, to something like P.E.Op.S. DSound Audio Driver 1.9, and have in Petes OpenGL Driver 1.78/Petes D3D Driver 1.77 enabled the fix to use PC FPS calculation, the framerate is fixed... but that comes attached with a drawback: I miss CDDA playback.

If I don't enable the fix to use PC FPS calculation, the framerate issue remains, no matter which sound plugin I use.

The problem here is, I do wish to have CDDA playback, and a proper framerate.

Am I the only one experiencing this, or is this generally normal for ePSXe? (I used it years ago, when CDDA wasn't even supported, so I don't know the current state of the emulator)

Is there any hope left for CDDA and Framerate to be well within ePSXe ?

Any help, would be greatly appreciated. Thanks!
 

·
Banned
Joined
·
35,081 Posts
Well, if i was to not use the SPUCore Plugin, I would be losing CDDA playback in many games, which is honestly, not an option to me, as music is essential to games.

However, I just tested further, and basically right now, when I use Petes OpenGL Driver 1.78/Petes D3D Driver 1.77 with SPUCore it will _always_ have this issue, no matter what settings I have setup.

If I however, change the audio plugin, to something like P.E.Op.S. DSound Audio Driver 1.9, and have in Petes OpenGL Driver 1.78/Petes D3D Driver 1.77 enabled the fix to use PC FPS calculation, the framerate is fixed... but that comes attached with a drawback: I miss CDDA playback.

If I don't enable the fix to use PC FPS calculation, the framerate issue remains, no matter which sound plugin I use.

The problem here is, I do wish to have CDDA playback, and a proper framerate.

Am I the only one experiencing this, or is this generally normal for ePSXe? (I used it years ago, when CDDA wasn't even supported, so I don't know the current state of the emulator)

Is there any hope left for CDDA and Framerate to be well within ePSXe ?

Any help, would be greatly appreciated. Thanks!
many? you mean few. CDDA isn't used on many games at all.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #6 ·
Im sorry, but I don't feel like getting sucked into a "THERES MANY CDDA GAMES vs THERES ONLY A HANDFULL!"

I'd much rather prefer to stay on topic and see if anyone has a SPU plugin, capable of playing back CDDA tracks without changing the framerate :) Or if any other solution exists for the mentioned games.
 

·
Banned
Joined
·
35,081 Posts
Easy fix, rip the disk to images, emulate CDDA via CDA and it will work with any plugin.
 

·
Banned
Joined
·
35,081 Posts
no, the problem lies in the fact that most of the sound plugins only do CDA (analogue), while the psx uses CDDA (digital transfers across the bus interface), you can emulate CDA on certain image drives and force the disk to run the cdaudio in other plugins.
 

·
Banned
Joined
·
35,081 Posts
In Daemon tools (free), enable the analogue audio option, the CDAudio should then work on all plugins.

anyway, im still not 100% convinced that problem is the spu, rather it could be having the epsxe framelimiter and peops frame limiter enabled at the same time.
 

·
Registered
Joined
·
261 Posts
Well, if i was to not use the SPUCore Plugin, I would be losing CDDA playback in many games, which is honestly, not an option to me, as music is essential to games.

However, I just tested further, and basically right now, when I use Petes OpenGL Driver 1.78/Petes D3D Driver 1.77 with SPUCore it will _always_ have this issue, no matter what settings I have setup.

If I however, change the audio plugin, to something like P.E.Op.S. DSound Audio Driver 1.9, and have in Petes OpenGL Driver 1.78/Petes D3D Driver 1.77 enabled the fix to use PC FPS calculation, the framerate is fixed... but that comes attached with a drawback: I miss CDDA playback.

If I don't enable the fix to use PC FPS calculation, the framerate issue remains, no matter which sound plugin I use.

The problem here is, I do wish to have CDDA playback, and a proper framerate.

Am I the only one experiencing this, or is this generally normal for ePSXe? (I used it years ago, when CDDA wasn't even supported, so I don't know the current state of the emulator)

Is there any hope left for CDDA and Framerate to be well within ePSXe ?

Any help, would be greatly appreciated. Thanks!
CraIZE I just wanted to let you know I am having the same issue as you. I am a huge Rage Racer and Ridge Racer Type 4 fan, and the fps slowdown during certain parts of the track is driving me up the wall. My PC specs are similar to yours with the exception of my ATI 4870 GPU so I there should be no reason this is happening.

It's a shame all the devs are focusing on PS2 emulation when epsxe still can't run some of these old PS1 classics properly :(
 

·
Banned
Joined
·
35,081 Posts
use CDR Sapu 1.3 and eternal spu 1.4
enable pcfps calculation in the 1.7x plugins game fixes and set it to automatically detect the fps.
 

·
Registered
Joined
·
261 Posts
use CDR Sapu 1.3 and eternal spu 1.4
enable pcfps calculation in the 1.7x plugins game fixes and set it to automatically detect the fps.
Thanks Squall. It helped a wee bit but not that much.

But I just wanted to say Squall, that I've noticed you've been here on the forums for a long time answering people's questions and helping them with their advice, and for that I just want to say thanks man :) Your input is highly invaluable to these forums and is much appreciated.
 

·
Banned
Joined
·
35,081 Posts
I'm not sure CraiZE

maybe try Alcohol 120 instead? Thats what i used to mount the disk and i got both the music and practically smooth gameplay.

be sure that the versions are
epsxe 1.7
cdr sapu 1.3
eternal spu 1.4/1.5
 

·
Discontinued
Joined
·
1,192 Posts
Run -> Enable Logs. Close program. Reopen.
That black box will tell you if CDDA tracks were found when 'Run CDROM' or 'Run ISO'

Generic:
If iso, check for a 2352 number (not 2048). You must have a cue sheet for this though

If bin/cue, make sure your 'cue' sheet has audio tracks (open with notepad)

If ccd/sub, make sure your CloneCD trial isn't expired (it won't copy the subchannel / audio data when that happens).
 

·
Banned
Joined
·
35,081 Posts
his CCD is fine, i have CRC'd his against mine and both are perfect.

run ISO and the internal cdr plugins only work with the internal audio, but the emulator F4 fps lock requires the internal spu plugin, which is why its better to use eternal spu and sapu,

both of which work fine on alcohol with music working fine o_O

CraiZE jump onto the epsxe chan, i have something for you.
 

·
Registered
Joined
·
7 Posts
Didn't have time to read all of the posts but I believe squall is right although there is another simple solution which i'm not sure has been discussed which is simply to use any spu you want with Moody's Cdr plugin. It worked for me with wipeout 3, wipeout xl and wipeout 2097. Peace
 
1 - 20 of 23 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top