Next Generation Emulation banner
1 - 20 of 21 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Im playing FF9 on epsxe 1.70 on my notebook with geforce 9600m gt, Intel Core 2 Duo P8400 2.26 GHz, 4GB DDR3 and I still get some noticeable slowdowns. Most of them are in the battle while some one is casting spell, frame rate fall from 60fps too about 35fps. It is very noticeable. Sometimes frame rate fall to 30 even in the menu, its very irritating to be looking through menu while the cursor is responding very slowly. It only last for few sec.

right now my settings are like this:
Plugin: Pete's OpenGL2 Driver 2.9
Author: Pete Bernert
Card vendor: NVIDIA Corporation
GFX card: GeForce 9600M GT/PCI/SSE2

Resolution/Color:
- 640x480 Fullscreen - NO desktop changing
- Internal X resolution: 1
- Internal Y resolution: 1
- Keep psx aspect ratio: off
- No render-to-texture: on

- Filtering: 5
- Hi-Res textures: 2
- TexWin pixel shader: on
- VRam size: 512 MBytes

Framerate:
- FPS limitation: on
- Frame skipping: off
- FPS limit: Auto

Compatibility:
- Offscreen drawing: 1
- Framebuffer effects: 2
- Framebuffer uploads: 1

Misc:
- Scanlines: off
- Mdec filter: on
- Screen filtering: on
- Shader effects: 1/3
- Flicker-fix border size: 0
- GF4/XP crash fix: off
- Game fixes: on [00000000]

I tried different settings, it didnt help.
Maybe someone can tell me what can be cause of those slowdowns.
 

·
Banned
Joined
·
35,081 Posts
- 640x480 Fullscreen - NO desktop changing
- Internal X resolution: 1
- Internal Y resolution: 1
- Keep psx aspect ratio: off
- No render-to-texture: 2

- Filtering: 4
- Hi-Res textures: 2
- TexWin pixel shader: on
- VRam size: 512 MBytes

Framerate:
- FPS limitation: on
- Frame skipping: off
- FPS limit: Auto

Compatibility:
- Offscreen drawing: 1
- Framebuffer effects: 2
- Framebuffer uploads: 2

Misc:
- Scanlines: off
- Mdec filter: on
- Screen filtering: on
- Shader effects: off
- Flicker-fix border size: 2
- GF4/XP crash fix: off
- Game fixes: off
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #3 ·
Thanks. I did a quick check.I dont have much time to play this game at the moment, I will check it more tomorror, but it seems it helped. I just wonder, how powerfull pc do you need to fully use the emulator?
 

·
Banned
Joined
·
35,081 Posts
dude, your pc should run this uncapped at atleast 400fps.

actually though... i'll need to do some testing since i know theres a way to get the spells to run perfectly.... anyhow, set the epsxe affinity to core 0 in task manager.
 

·
From Love and Limerence
Joined
·
6,584 Posts
640x480 fullscreen on an LCD? Eww.

This is just a personal recommendation of mine, but with high resolution textures set to 2 (stretched), the filtering level is best set to 2 as well. Well, that rules works good in reverse more so, but still, the game is mostly 2D, and since the hardware acceleration will make the characters look good as it is, I'd concentrate efforts on preventing the 2D from being pixelated.

Also, you could probably probably bump up the internal X and internal Y resolutions to 2 each (the one that can go to three actually looks worse in my testing than if it's at two at a resolution of 640x480). Your PC is plenty fast for this. A Pentium III with an old early GeForce or Radeon would run the emulator fine (granted, it would have to be with basic settings and OpenGL(1) or Direct3D, but it would run), and the documented requirements are lower, so yeah, you're pretty overkill.
 

·
Banned
Joined
·
35,081 Posts
4 looks better to me actually :\
 

·
Discontinued
Joined
·
1,192 Posts
(1)
Run epsxe, don't run game yet

ctrl+alt+del = Task Manager
Check program list for high CPU usage (several epsxe for instance)
Terminate unwanted ones

(2)
Try using OpenGL1 and see if your problems disappear

(3)
System reboot?
 

·
From Love and Limerence
Joined
·
6,584 Posts
4 looks better to me actually :\
I guess it depends on the type of look you're going for.

Filtering of 2 won't filter the 3D, so the world map and battles might not look as good.

Filtering of 4 won't filter 2D, so the backdrops look pixelated, more so for higher resolutions (higher is anything higher than 320x224 in this case) and any lack of smoothing and/or shading effects that may hide it.

I think 5 and 6 filter both, but they do it in a different way that doesn't look so good.

The reason I choose 2 is because to me, having the backdrops not pixelate is number one, and it's closest to the natural look for 2D (while the 3D is still improved through the fact that it's being hardware rendered).
 

·
Discontinued
Joined
·
1,192 Posts
@800x600x32
There's a visual model upgrade from
Internal: 1-1 (x-y) --> 1-2 (x-y).

Didn't see as much going from 1-2 --> 2-2

(Original post)
When you hit F4, what's the uncapped FPS limit you get? (hit 'del' to show the FPS). You may need to switch from 'Auto-detect FPS' --> 'Use FPS: 200'

It might be different numbers at:
- overworld, pre-battle, towns (120?)
vs.
- actual battle, party menus, save/load game (60?)
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #10 ·
I was playing the game with:
Plugin: Pete's OpenGL2 Driver 2.9
Author: Pete Bernert
Card vendor: NVIDIA Corporation
GFX card: GeForce 9600M GT/PCI/SSE2

Resolution/Color:
- 640x480 Fullscreen - NO desktop changing
- Internal X resolution: 2
- Internal Y resolution: 2
- Keep psx aspect ratio: off
- No render-to-texture: on

- Filtering: 2
- Hi-Res textures: 2
- TexWin pixel shader: on
- VRam size: 512 MBytes

Framerate:
- FPS limitation: on
- Frame skipping: off
- FPS limit: Auto

Compatibility:
- Offscreen drawing: 1
- Framebuffer effects: 2
- Framebuffer uploads: 2

Misc:
- Scanlines: off
- Mdec filter: on
- Screen filtering: on
- Shader effects: 1/4
- Flicker-fix border size: 0
- GF4/XP crash fix: off
- Game fixes: on [00000000]

Slowdown arent that visible during battles any more. They still happen.
After hitting F4 fps are raising to 200 on the world map, 120 during battles, it stais 60 in the menu.
 

·
Banned
Joined
·
35,081 Posts
yeah, the menu's are a fullscreen FBE, its hard for all cards to do them, but that 60fps has been pretty consistent since the FX days.
 

·
Banned
Joined
·
35,081 Posts
install nhancer

create profile for epsxe
set
AA, AF as app
OpenGL triplebuffering will not work without vsync, so theres no point in setting it on (learn about functions before suggesting them shalma)
set Prerender to 2 (decreases cpu dependancy and allows the gpu to do more of the work, decreasing the chance of fullscreen controller lag)
 

·
God of Douchebagness™
Joined
·
15,294 Posts
doesnt the frame pre-render setting only work with dx or am i thinking of something else?
 

·
God of Douchebagness™
Joined
·
15,294 Posts
the max amount of pre-rendered frames the CPU is allowed to prepare ahead of time before they are delt with by the GPU. i thought this particular setting in the control panel only works with DX, not OGL.
 

·
Banned
Joined
·
35,081 Posts
it works with both, even when setting from the advanced d3d settings page in the classic control panel


During the rendering of scenes, the driver usually accepts commands for more than a single frame. This way the GPU doesn't stall the CPU until it's absolutely neccessary.

If the GPU accepts the command for too many frames ahead, additional mouse lag can be introduced, though. That means that there is a very slight delay between the moving of the mouse and the actual reaction on the screen.

Using this setting, you can limit the amount of frames the driver accepts ahead of the currently displayed frame. This should be left at the default value (3) to get the best performance.
You can get a faster reaction on your mouse movements in some games by lowering the limit. This might also cause a loss in framerate, though.

It only works when set in a profile for opengl though. Direct3D must be set globally.
 

·
クロスエクス
Joined
·
4,890 Posts
Triple buffer

install nhancer

create profile for epsxe
set
AA, AF as app
OpenGL triplebuffering will not work without vsync, so theres no point in setting it on (learn about functions before suggesting them shalma)
set Prerender to 2 (decreases cpu dependancy and allows the gpu to do more of the work, decreasing the chance of fullscreen controller lag)
I do not know about how does Triple Buffer works, I only know it can be used to counter the downside of enabling vsync to a certain degree if the computer can handle it (or it could make things worst otherwise).... adding a third buffer to draw and avoid idle times until the monitor request the next frame.... blah blah...

Nevertheless, as I've said before, I usually enable it since it felt "smoother".
Well, I just did some simple test with and without Triple Buffer on the same screens. The difference is quite noticeable, which shows is not so pointless to enable it even with vsync disabled. I have no clue of why it behaves this way either, but it does for me at least.

Triple Buffer [ON]
Screeny 1 (63.0)
Screeny 2 (63.4)

Triple Buffer [OFF]
Screeny 1 (34.9)
Screeny 2 (34.6)
 

·
Banned
Joined
·
35,081 Posts
Thats definitely got vsync enabled. Its a bug thats been in every build of nhancer and has only just been found recently... to be fixed in 2.5.0

so yeah... Vsync can only be enabled / disabled globally in 2.4 and prior.
 

·
クロスエクス
Joined
·
4,890 Posts
It doesn't have vsync enabled, other places of the game get FPS higher than my refresh rate.

#EDIT

With Triple Buffer enabled, settings changed are:
Resolution: [email protected]
Internal Resolution: Low,Low
Shader effect disabled.

VSYNC [OFF] (615.3)
VSYNC [ON] (59.6)

Which would mean, VSYNC can be enabled and disabled.
I do not use nHancer, I just did it from the nVIDIA panel.

#EDIT2

AFTER MORE TESTS! Yesh! It had vsync enabled somehow. I was testing with low internal resolution at high screen resolution and the FPS would not go higher than either "refresh rate value" on screens such as the one for tests, or "double refresh rate value" while ingame. Then, I remembered about the "FPS counter" on the Pete's plugin.

I forced VSYNC disabled, general and with a profile for ePSXe. Unless done so, it appears vsync is not disabled when using a resolution equal to desktop resolution. After doing so and retesting, the framerate was around ~48-75 very unstable (very high, ultra; internal resolutions, shaders enabled like in first tests) and it showed no noticeable difference at all between TB enabled or disabled.

So it appears things work as they should, with Triple Buffer helping against the downside of having VSync enabled.
I started to wonder why it would work (searching and searching about TB stuff)... at least I ain't nuts after all. XD

Therefore, I can now confirm without doubts your statement Squall.
"OpenGL triplebuffering will not work without vsync, so theres no point in setting it on"
*gives cookies* =3
 
1 - 20 of 21 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top