Next Generation Emulation banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Everything seems to be working fine with Silent Hill except I keep getting odd resolution switches between different screens in the game. It seems to boot and run at about 60% of the left side of my screen, then the title screen switches to a weird narrow area of the screen, and then the game itself runs in the same 60% screen the title and boot screens run in.

Im running an i7 3820 with a GTX970

and these are my video settings for Petes Open GL3 Renderer (tweaked version)


Plugin: Pete's OpenGL2 Driver 2.9
Author: Pete Bernert
Card vendor: NVIDIA Corporation
GFX card: GeForce GTX 970/PCIe/SSE2

Resolution/Color:
- 1920x1080 Fullscreen - NO desktop changing
- Internal X resolution: 2
- Internal Y resolution: 3
- Keep psx aspect ratio: on
- No render-to-texture: on

- Filtering: 6
- Hi-Res textures: 2
- TexWin pixel shader: on
- VRam size: 512 MBytes

Framerate:
- FPS limitation: off
- Frame skipping: off
- FPS limit: 200.0

Compatibility:
- Offscreen drawing: 1
- Framebuffer effects: 3
- Framebuffer uploads: 1

Misc:
- Scanlines: off
- Mdec filter: on
- Screen filtering: on
- Shader effects: 1/4
- Flicker-fix border size: 0
- GF4/XP crash fix: off
- Game fixes: off [00000000]

Attached are some screenshots of the problem. Any help would be greatly appreciated. Thanks!
screen1.fw.png
Screen2.fw.png
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2 (Edited)
Some updated notes, The problem detailed in the second image (menu screens) seems to be caused by setting the stretching mode to anything other than 0, and the problem of the game itself not stretching fully is related to running the game in "Fullscreen Mode". In window mode, I can get the game running fully stretched at 1920x1080, but the taskbar needs to be set to autohide, and I've still got a tiny bit of the top portion of the window border visible. Not totally sure what I changed, but In fullscreen mode the game will now center itself in a kind of "pseudo-letterboxed" mode. Don't know if there are any ways around either of these issues, but here are my current video settings if anyone else is having these problems. Perhaps they will help. If anyone knows of a way to run the game in true fullscreen mode, or a way to run the game in borderless window mode, help in that area would be much appreciated. Thanks!

EDIT: I used this tool (http://www.nirsoft.net/utils/winexp.html) to get a fullscreen 1080p borderless windowed version of the game on my setup. Click on the epsxe process, go to the "style" tab and uncheck WS_DLGFRAME for a borderless epsxe window ingame.

Hope that helps anyone who has the same problems I did!


Plugin: Pete's OpenGL2 Driver 2.9
Author: Pete Bernert
Card vendor: NVIDIA Corporation
GFX card: GeForce GTX 970/PCIe/SSE2

Resolution/Color:
- 1920x1080 Window mode
- Internal X resolution: 2
- Internal Y resolution: 3
- Keep psx aspect ratio: off
- No render-to-texture: Ï‹

- Filtering: 6
- Hi-Res textures: 2
- TexWin pixel shader: on
- VRam size: 512 MBytes

Framerate:
- FPS limitation: off
- Frame skipping: off
- FPS limit: 200.0

Compatibility:
- Offscreen drawing: 1
- Framebuffer effects: 3
- Framebuffer uploads: 2

Misc:
- Scanlines: off
- Mdec filter: on
- Screen filtering: on
- Shader effects: 1/4
- Flicker-fix border size: 0
- GF4/XP crash fix: off
- Game fixes: on [00002000]
 

·
Registered
Joined
·
1 Posts
Some updated notes, The problem detailed in the second image (menu screens) seems to be caused by setting the stretching mode to anything other than 0, and the problem of the game itself not stretching fully is related to running the game in "Fullscreen Mode". In window mode, I can get the game running fully stretched at 1920x1080, but the taskbar needs to be set to autohide, and I've still got a tiny bit of the top portion of the window border visible. Not totally sure what I changed, but In fullscreen mode the game will now center itself in a kind of "pseudo-letterboxed" mode. Don't know if there are any ways around either of these issues, but here are my current video settings if anyone else is having these problems. Perhaps they will help. If anyone knows of a way to run the game in true fullscreen mode, or a way to run the game in borderless window mode, help in that area would be much appreciated. Thanks!

EDIT: I used this tool (WinExplorer v1.30) to get a fullscreen 1080p borderless windowed version of the game on my setup. Click on the epsxe process, go to the "style" tab and uncheck WS_DLGFRAME for a borderless epsxe window ingame.

Hope that helps anyone who has the same problems I did!


Plugin: Pete's OpenGL2 Driver 2.9
Author: Pete Bernert
Card vendor: NVIDIA Corporation
GFX card: GeForce GTX 970/PCIe/SSE2

Resolution/Color:
  • 1920x1080 Window mode
  • Internal X resolution: 2
  • Internal Y resolution: 3
  • Keep psx aspect ratio: off
  • No render-to-texture: Ï‹
  • Filtering: 6
  • Hi-Res textures: 2
  • TexWin pixel shader: on
  • VRam size: 512 MBytes
Framerate:
  • FPS limitation: off
  • Frame skipping: off
  • FPS limit: 200.0
Compatibility:
  • Offscreen drawing: 1
  • Framebuffer effects: 3
  • Framebuffer uploads: 2
Misc:
  • Scanlines: off
  • Mdec filter: on
  • Screen filtering: on
  • Shader effects: 1/4
  • Flicker-fix border size: 0
  • GF4/XP crash fix: off
  • Game fixes: on [00002000]
This helped me fix that problem thank you!
 
1 - 3 of 3 Posts
Top