Next Generation Emulation banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
After a few days (and numerous doses of codine), I still can't get the streaming CD sound (background music) in Castlevania SOTN to work.

So far, the best I can get is with the newest version of Eternal SPU. The background music plays alright, but it hitches. It plays for about a second, then hitches (stops) for about a half second, and again and again.

With any other SPU (core, pete's, etc) the background music plays without hitching, but it's horrifically distorted and distorted.

I've tried using different cdr plugins, and playing around with the graphic settings. So far nothing helps.

Does anyone know how to set up things so that the music plays correctly? Or do I just have to disable CD sound and play without the music (I wouldn't mind that so much, except that the music in SOTN is some of the best from any psx game I've ever played.

Settings (more or less):

Pete's CDR aspi/ioctl driver 1.7
Enabled CD timing (to avoid mem card checking freeze)

pete's soft driver 1.52

Null2's audio driver 1.3
enable sound
enable cdda sound
enable xa sound
enable xa read
disabled spu irq hack


Any help would be greatly appreciated.

Thanks
Xeath
 

·
Registered
Joined
·
2,091 Posts
And here are the settings I'm using for Eternal SPU. You may want to adjust the buffer since that is really dependant on your sound card.
 
1 - 3 of 3 Posts
Top