Next Generation Emulation banner

1 - 16 of 16 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
tried searching, couldn't find anything.

okay so i'm trying to get front mission 3 to play correctly. i've managed to work through any problems i had by searching the forum and using trial and error but now i'm stuck. the game has a pretty atrocious frame rate on the actual console, but for some reason i can't play it at 60fps with epsxe. by can't i mean won't. it's just too fast. now, i've gotten it to play the way i'm used to by setting the frame limit to about 47fps, but the sound slows down as well. that was never an issue with the console.

is there a way to get the sound to play independently of the video frame rate? i've been messing around with this for a while now. it's 4am and i just want to finish this and go to bed. i hope i'm explaining my situation right.

merry christmas, i guess. thanks in advance.
 

·
Banned
Joined
·
23,263 Posts
The game doesn't work at 60fps! wow, bet that stunned you.

most games from that era use framerates depending on the layers rendered on the screen, Final Fantasy for instance, uses 25 and 30FPS on the map, but 50 and 60 when in battle.

now the reason for the video seeming so fast when the audio isn't, is because it is too fast, most commonly its caused by multithreading. it screws up the fps calculation and causes too much speed, or instable framerates.

Disabling opengl multithreading (or global multithreading) in the display driver, or via task manager (set affinity to 0) prevents the fps calculation from screwing up.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
well your first three sentences make complete sense to me, but you lost me at the end there. i'm not entirely sure about how to disable opengl multithreading. i couldn't find the option using my video card's control panel, nor in the task manager. any help?
 

·
Banned
Joined
·
23,263 Posts
In task manager, right click on the epsxe process and in the Affinity menu, set it to core 0.

to disable it, depending on your gfx card (if nvidia) you can use nhancer to create a profile for epsxe, and disable opengl multithreading in the compatibility tab.

I should actually rewrite my initial response because it is actually somewhat inaccurate.

The fps that shows up on screen when you have it show fps is actually fields per second, and this should always range from 49 - 59.91 fps.
However using an application such as fraps, you will find the Frames per Second range from 25 - 60 depending on what is shown on screen.

because multithreading screws with the FPS calculation the driver tends to render the FPS as a multiple of fps, so you would actually be seeing 120FPS being rendered when it should only be 60.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5 (Edited)
yes i use a nvidia card, and i only have the card's control panel. nothing called nhancer. i can still make profiles for games but none of the options have to do with opengl multithreading or global multithreading. maybe it's called something different. also, using windows xp pro i can't find anything about affinity in the task manager context window for epsxe.exe. all i can do is set its "priority" which ranges from realtime, to low. assuming this is what you're talking about, i've set it to low and will try. i'll edit this post with the result.

thanks for the help, hopefully i'll be able to fix this. i think we're just having communication errors :)

edit: okay so the reason i can't set the affinity for a process (according to the task manager help file) is because that's only available for multi core processors. i'm using a single core processor.

edit again: i downloaded nHancer and created a profile for epsxe. i was able to disable opengl multithreading but nothing has changed. 60fps is still a bit faster than what i'm used to on the console. 50fps plays just how i want it, though. but the music and sound still slows down as if it's attached to the video frame rate. look, i can get the game to play at whatever speed i want. that was never a problem. i want to change the rate that the SOUND plays at. i really don't think my point is getting across correctly.
 

·
Not a Registered User
Joined
·
1,419 Posts
My guess is that back then on console you had a PAL ver of this game and now you have a NTSC ver

PAL i NTSC have the same music even thou its 10FPS difference
And form what i know you cant slow down the game without the music correct me if wrong
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
"back then" being yesterday? i still have the same playstation and the same original front mission 3 disc. i'm looking at it right now and it says ntsc under the playstation logo. what you said would make sense if i was indeed using a pal disc. i just want the music to play 60fps, but the sound effects should be in sync with the video, which should be at around 50fps. maybe i should try picking up a pal version of the game? that's ridiculous though. i should be able to emulate the performance of my console with this program. there has to be a way to get this to work right.

i've been messing with all of the sound options (using Eternal's SPU Plugin 1.41) and the one that seems the most likely to give me what i want is "audio out method". there are three main options under audio out method. they're thread, timer, and SPUsync. SPUsync has three more sub options; simple, wait, and smooth. thread and timer don't change anything for me, neither does the smooth setting of SPYsync. simple and wait, however, DO do something. when i use the in game frame options and change it from autodetect to manual (which is set to 50), the music gets choppy. like it skips, so that it can still play at the tempo of 60fps while the rest of the game is being played at 50fps. this is what's making me think i can do this. i'm so close.. i just want the music to not skip.
 

·
Banned
Joined
·
23,263 Posts
yes i use a nvidia card, and i only have the card's control panel. nothing called nhancer. i can still make profiles for games but none of the options have to do with opengl multithreading or global multithreading. maybe it's called something different. also, using windows xp pro i can't find anything about affinity in the task manager context window for epsxe.exe. all i can do is set its "priority" which ranges from realtime, to low. assuming this is what you're talking about, i've set it to low and will try. i'll edit this post with the result.

thanks for the help, hopefully i'll be able to fix this. i think we're just having communication errors :)

edit: okay so the reason i can't set the affinity for a process (according to the task manager help file) is because that's only available for multi core processors. i'm using a single core processor.

edit again: i downloaded nHancer and created a profile for epsxe. i was able to disable opengl multithreading but nothing has changed. 60fps is still a bit faster than what i'm used to on the console. 50fps plays just how i want it, though. but the music and sound still slows down as if it's attached to the video frame rate. look, i can get the game to play at whatever speed i want. that was never a problem. i want to change the rate that the SOUND plays at. i really don't think my point is getting across correctly.
Exactly what cpu do you have :/
 

·
Registered
Joined
·
8 Posts
Discussion Starter #11
there are no drivers to install for it. it's a single core processor and it's automatically recognized by the OS. the AMD website has nothing for it because it doesn't need drivers.

it seems like you're running out of suggestions. are you sure this problem just can't be fixed? it seems like something so simple.. i don't understand. i've tried several different SPUs at this point and i'm getting nowhere. i've resorted to playing the game on my console now. better graphics isn't worth all of this trouble.
 

·
Not a Registered User
Joined
·
1,419 Posts
Squall-Leonhart he doesn't have a problem with the game he just wants to slow it down while not slowing down the sound like this
Sound=60FPS
GAME=50FPS
so CPU is not an issue here still i think thats not possible prof me wrong if you can
 

·
Banned
Joined
·
23,263 Posts
FoxSevent, I'll prove you wrong with a kick to the throat, now gtfo the thread since you aren't providing any help at all.

gfx Plugin
Petes OGL 1.77 or 2.9
set FPS limit to 60 (not auto)
Disable Frameskipping

sfx Plugin
Eternal SPU 1.4 or 1.5b2
set buffer to 48
Set Audio thread to spuasync = smooth or wait.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #14
look, i don't mean to be rude. but you're not telling me anything new. 60 frames per second is still faster than the game should be. setting it to 50 fps and doing everything else you mentioned in your latest post changed nothing for me. the music still slows down with the framerate. is there something i'm not explaining correctly to you? please, tell me. you can't help me if you don't understand my problem, and i don't think you understand my problem.

also, the thread has a decent amount of views. is there anyone else who would care to chime in? not saying i don't appreciate the help, squall. it's just that more input would be nice.

edit: Squall, would you like me to send you the ISO I made of my game so you can try this yourself? I know you would delete it when you were done with it. Also, since I mentioned I'm playing an ISO, I'll just get this out of the way right now: There's no difference between playing the ISO and playing the actual CD. I get the same problem on both mediums.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #16
Can't. This is from the most current pSX compatibility list:

Name.............Front Mission 3
Game ID.........SLUS_010.11
Version..........1.7-1.13
Works............NO
Comments......Minor graphics problem; random freezes in battles

using epsxe i have not encountered any graphics problems and it hasn't froze on me yet, but i've only been playing for the first few minutes of the game.
 
1 - 16 of 16 Posts
Top