Next Generation Emulation banner

1 - 18 of 18 Posts

·
Registered
Joined
·
462 Posts
Discussion Starter #1
Whenever, I turn on FSAA with my GeForce 3 in ePSXe, my screen gets tiled up like in the image below. Has anyone else with a GeForce 3 tried Chrono Cross or FF9 with FSAA on? If so do you get the same problem? If you don't get the bug what settings are you using?

(Note: this is a GeForce 3 problem only, I do not get this problem with my GeForce 2 Ultra)
 

·
Registered
Joined
·
462 Posts
Discussion Starter #3
The above screenshot was taken at 1024x768 32 bit color with FSAA on in the GeForce 3 display properties, using Pete's OGL plug-in, ePSXe 1.2.0 .

Plugin: Pete's OpenGL Driver 1.1.50
Author: Pete Bernert

Resolution/Color:
- 1024x768 Fullscreen - NO desktop changing

Textures:
- R8G8A8A8
- Filtering: 0 - edge clamping supported
- Caching: 2 - 128 textures usable

Framerate:
- FPS limit: on
- Frame skipping: off
- FPS limit: Auto

Compatibility:
- Offscreen drawing: 3
- Framebuffer texture: 0
- Alpha multipass: on
- Mask bit: on
- Advanced blending: on (hardware)

Misc:
- Scanlines: off
- Line mode: off
- Unfiltered FB: on
- Dithering: off
- Full vram: off
- Game fixes: off [00000000]
 

·
Registered
Joined
·
1,808 Posts
Hmm......I have no idea about this
Without any 2D filter background should not be like that...........
Maybe you should turn dithering on...............
 

·
Registered
Joined
·
462 Posts
Discussion Starter #5
Tried that, tried turning on filtering, extended filtering, dithering, messing around with the resolution.... etc. The only thing that would remove it is turning off FSAA.
 

·
Registered
Joined
·
79 Posts
Nice piece of hardware. :)
I would think that a geForce3 would churn out better graphic, than my ATI rage.
Try messing around with the differnet option to get different results.

Try turining Filtering to : Extended

That should results in VERY nice graphic
 

·
Registered
Joined
·
462 Posts
Discussion Starter #8
hmmm... extended filtering did remove the lines. I tried that before on an older driver release detonator 12.00 and the lines still appeared. Anyways I'm glad Nvidia fixed it for filtered backgrounds anyways. I still prefer unfiltered backgrounds and text, but I guess this will have to do until Nvidia fixes the glitch, anyways thanks for the suggestions everyone.
 

·
Registered
Joined
·
1,612 Posts
> I would expect that a GeForce3 would churn out better graphics then my ATI Rage

-Well emulators can't add more polygons. :p
 

·
Registered
Joined
·
5 Posts
other games

Particleman-

Are you having this GeForce 3 FSAA problem with some non-epsxe games as well (i.e. real PC games)?

This same problem has been hounding me for weeks, since I bought the GeForce 3. I've tried everything to get rid of it. Sadly, since I switched from the Voodoo 5, I'm hooked on FSAA and don't want to turn it off.

Have you found a solution?

[Gang, I realize this isn't directly emulator related, but bare with me, please]
 

·
Registered
Joined
·
1,238 Posts
don t worry, it s not only ur geforce 3.
mY geforce 256 has the same pb w/ or biohazard3 ;\

I guess that playing at 1280x1024 w/o FSAA w/ ur geforce 3 should be fine ^_^

bye
 

·
Registered
Joined
·
50 Posts
I used to have the same problem with FF9 and my GeForce DDR. I just loaded the game up about 4 or 5 days ago with ePSXe 1.4.0 and Pete's OpenGL plugin 1.50 and it looked fine. You said you're using ePSXe 1.2.0... try 1.4.0... and maybe try getting the new version of Pete's plugins. But anyway, here's the settings I use:

Resolution: 1280x1024
Color depth: 16-bit
Texture Quality: R8G8B8A8
Filtering: 4 - Extended w/o Sprites
Caching type: 2 - Dynamic
Use FPS Limit
Use Frame skipping
Auto-detect FPS/Frame skipping
Off-screen drawing: 2 - Standard
Framebuffer textures: 2 - Gfx card buffer
Alpha Multipass
Advanced Blending
Color Dithering
and G4 polygon cache (special fix)

I'm using Detonator 12.90 drivers (from http://www.3dchipset.com), and have the FSAA set to 4x. I'm also using Windows XP (Win2K kernel).
 

·
Registered
Joined
·
48 Posts
Had the exact same problem had to set filtering to 2: Standard to get rid of the black lines. Reduces quality slightly, but it worked for be. BTW i was using the DX6 plug with a GeForce 3. (DX7 dont work, damn..)
 

·
Registered
Joined
·
251 Posts
Originally posted by Rargh
don t worry, it s not only ur geforce 3.
mY geforce 256 has the same pb w/ or biohazard3 ;\

I guess that playing at 1280x1024 w/o FSAA w/ ur geforce 3 should be fine ^_^

bye
press f5 ingame,go to others ,turn off texture correction
that should fix the prob
 

·
Registered
Joined
·
38 Posts
correct me if im wrong but isnt fsaa for making low resolutions look as good as higher ones! at that resolution u shouldnt need it. i always thought it was ment to be used for 640x480 and other low resolutions
 

·
Premium Member
Joined
·
6,338 Posts
Originally posted by chris_82
correct me if im wrong but isnt fsaa for making low resolutions look as good as higher ones! at that resolution u shouldnt need it. i always thought it was ment to be used for 640x480 and other low resolutions
FSAA is designed to get rid of the jagged edges (jaggies) of polygons. Running a game at a higher resolution makes jaggies less apparent but it never fully gets rid of them. Even if you were to run at a high resolution (1024+) FSAA is necessary to get rid of the jaggies, although you can run it at a lower resolution and still get good graphic quality.
 

·
Registered
Joined
·
48 Posts
K, had the exact same problem, but i FIXED it!! So happy. Anyway, heres the solutions, use Petes OpenGL Driver with the following config: (picture follows). Also to make it look better you can get a tweak tool (i use NVMax) and turn on the Bilinear Filtering for the OpenGL (I think its turned off by default) This makes the picutre look MUCH better, also i use 4x4 anti aliesing. I have a GeForce 3 (Elsa). These settings work Great, if you set the caching to Palaterized it looks even better, but some of the black lines come back. Anyway hope this helps.
 
1 - 18 of 18 Posts
Top