Next Generation Emulation banner
1 - 2 of 2 Posts

26 Posts
Discussion Starter · #1 · (Edited)
this is kinda weird, but oh well...

i've tried to play a couple of sports games (ssxtricky, pes2009, gt4) where it lets one save replays of a run/lap. sure. that works brilliant. i can view the replays correctly even if i've been using save/load state. the replay doesn't show that. the replay works brilliant when i watch it in-game on PCSX2, but when i transfer the replay-save to my original PS2 memory card (i've read all the instructions on how to do so etc.), load up the game on my PS2, it loads the game and the option file on my memory card, i load the replay, it loads smoothly, but when i start to view the replay in action, it's corrupted! it doesn't give me any errors or somewhat, but it simply isn't the same replay as the one i watched on PCSX2! it's all messed up! the replay works like it should for the first few seconds of the race/track/lap, but then it starts to do things that i cannot even explain the cause of... like in ssxtricky, when i load the replay on my PS2, i can start watching the replay, but then all of a sudden, the rider takes a whole new direction or somewhat and then fails to jump etc. so yeah, the replay gets completely screwed up. however, the times and scores that i did on PCSX2 are all in place and working like a charm. it's just the replay that doesn't play properly on my PS2.

i've checked the following things to be sure i've done things correctly:
- checked if the savegames + replay are both PAL, and yes they are
- tried to format my PS2 memory card and add the replay + option file, no effect
- i've tried mix and match with NTSC and PAL savegames AND the game itself, and obviously that didn't work
- i've checked if the settings on PCSX2 were correct (region was set to PAL etc.), no effect
- i've even tried 3 different PS2 memory cards (one of them was even a NTSC mem. card)

so yeah, i am pretty much confused on why the replay is not working like it should. all the graphic details and everything else is working like it should, but when i hit "play replay", it works fine for the first few seconds, then it starts to drive off-road, do weird jump, crash into the walls etc. and the weird thing is that whenever i SKIP to the NEXT scene/part of the track/lap/stage, it runs properly for a few more seconds and then it starts going nuts again!

i can only see two causes to this... 1) it got something to do with the PCSX2 fps not matching original PS2's fps..? or 2) the save/load state part. whenever i save a state, drive around, screw up, then load state, drive to a certain spot, save state again, drive on and so on, and then when i finally reach the goal, i then save the replay through the in-game option that lets me save the replay. perhaps it is then when the replay-save gets screwed up..?? but how come that the replay isn't corrupting at all when i watch it on PCSX2..?? i can even shut down the PCSX2, start it again and watch the replay without any probs... but as soon as i convert the replay to the PS2 memory card, the replay is screwed up.

EDIT: come to think of it... perhaps it got something to do with the fact that PCSX2 savegames can only be converted to .psu and .max (max drive) formats... what i did, was that i converted the PCSX2 savegame + replay-save file to .max and then used a tool to convert the .max to .xps (there's a converting tool that lets one convert max drive files to x-port files and vise versa)... perhaps THAT got something to do with it....?? too much converting, maybe?? and yes, the converting program has worked for many many games before, but not for replays...somehow.

EDIT2: also, the first 2-3 jumps and tricks goes very well. timed properly and all, but after that, the driver just goes mental and starts off-roading, jumping like 5 meters before the actual jump, sometimes not even jump at all, screw around, resetting characters position on free will, crash onto walls, take different routes and stuff like that. there's no other speed changes though. the speed is like it should be.

so pretty much stuck with this...

any clues, anyone??

it'se miku!
3,609 Posts
as far i know, GT4 replays doesn't save and load correctly in pcsx2.
may it has been fixed in the latest beta, but i don't know and don't care.

ingame fps should be both the same.
Its more a CPU timing issue.
1 - 2 of 2 Posts