Next Generation Emulation banner
1 - 20 of 21 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 · (Edited)
I'm sorry if this is already answered elseware but I could not find it in my searches (forum and google) after about two hours of searching.

The problem I've been trying to solve for the last four hours or so everything seems to work fine running Epsx 1.7 except save states, I've tried the hotkeys F1 F2 and F3 and I've tried the menu with no results, when I use the hotkeys nothing happens, and when I use the menu the save option resumes the game but if I use F3 it does not load and if I look at the menu there is no save states to load (gray list)

I disabled DEP for epsx and took ownership of the file.

My Computer

* CPU: AMD Athlon 64 X2 4400+
* GPU: HIS Radeon 3870 512MB
* MOBO: ASUS M2A-VM
* RAM: 4GB DDR2
* Windows Vista Ultimate 64

PS. I know many prefer Win XP but I need Vista for technical reasons, and I also own this legally while I don't own an XP license.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 · (Edited)
C:\games\epsx 1.7

EDIT: I just ran it with logging on and it says SaveState Done! and Loadstate Done! when I press the appropriate hotkeys but nothing actually happens (and yes I did move to make sure it was just not really fast) testing with Castlevania SotN by the way, its all I have presently.
 

·
Banned
Joined
·
23,263 Posts
open up the epsxe folder's properties and add the everyone account to the security tab.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
Tried it, did not help, also the ownership thing I mentioned above gives total control to the current user (in this case admin) so I believe I have full access anyway, thanks for helping btw, really enjoy save states.
 

·
Registered
Joined
·
1 Posts
I'm sorry if this is already answered elseware but I could not find it in my searches (forum and google) after about two hours of searching.

The problem I've been trying to solve for the last four hours or so everything seems to work fine running Epsx 1.7 except save states, I've tried the hotkeys F1 F2 and F3 and I've tried the menu with no results, when I use the hotkeys nothing happens, and when I use the menu the save option resumes the game but if I use F3 it does not load and if I look at the menu there is no save states to load (gray list)

I disabled DEP for epsx and took ownership of the file.

My Computer

* CPU: AMD Athlon 64 X2 4400+
* GPU: HIS Radeon 3870 512MB
* MOBO: ASUS M2A-VM
* RAM: 4GB DDR2
* Windows Vista Ultimate 64

PS. I know many prefer Win XP but I need Vista for technical reasons, and I also own this legally while I don't own an XP license.
HEY, I´ve tested 1.7 version and really savestates doesn´t work using f1 or f3 or directily to menu.

I am using 1.6 version, whit that version you can use savestates.
 

·
Banned
Joined
·
23,263 Posts
savestates work fine on 1.7, learn how to use the emulator (and computer) properly.
 

·
God of Douchebagness™
Joined
·
9,826 Posts
does the logger mention any problems when you attempt to create/load a save state? also, do the other hotkeys work? like if you try to toggle the internal FPS limiter with the F4 key does it work or is it just the F1-F3 keys that are not responsive?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #12 ·
no, the logger does not mention anything out of the ordinary, it appears in the log as if it saved and loaded correctly, yes the other hotkeys all seem to work (I also did it using the menu incase the hotkeys were the problem anyway)

On a side note, I tried using 1.6 with the plugins from my 1.7 install and the states work fine with that, so atleast I know its not likely a plugin issue (even configured the same way)
 

·
God of Douchebagness™
Joined
·
9,826 Posts
try making a save state and then afterwards return to the GUI (leave the emulator running) and look in the save state folder in your epsxe directory and see if a state file shows up or not.

btw unless you are already doing so, you might want to try launching epsxe directly from its exe file rather than from a shortcut to it.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #14 ·
interesting....not only did the save state file not show up, the save state folder is MIA, perhaps despite using every method I could think of to give epsxe acess it still can't make new folders.

Final Update, dont know why it can't create the folder, but I created a folder called sstates and save states now work fine, thanks for the help.
 

·
Banned
Joined
·
23,263 Posts
epsxe DOES create the folders.....
 

·
Registered
Joined
·
3 Posts
enconter same promblem with states save and load

when I'm going to bios(you know cd player thing File - Run Bios), I can save and load pushing f1 f2 f3 all seems to be ok I can see files in sstates directory, but when playing a game through an iso image (file - run iso) those buttons doesn't create anything in sstates directory. but I can see in log that "Savestate Done!" "Loadstate Done!" though nothing happens. I'm running under XP ePSX 1.7.0 didn't find current issue in FAQ so I'm begging for help :(
 

·
Registered
Joined
·
603 Posts
try making a save state and then afterwards return to the GUI (leave the emulator running) and look in the save state folder in your epsxe directory and see if a state file shows up or not.

btw unless you are already doing so, you might want to try launching epsxe directly from its exe file rather than from a shortcut to it.
Shortcut works fine. I'm using a shortcut with 1.7.0 and the save states function perfectly with no problems. Tested this in XP, Vista, AND Windows 7. But you can't put the actual ePSXe.exe file on the Start Menu, because it will try to find the plugin folder inside the Start Menu then, and it obviously won't work. So I just created a shortcut inside the folder and used that on the Start Menu.

Windows 7's taskbar function automatically does this though.


@Arkeyn:
That's weird. So it works if you Run the BIOS, but not when you're playing the game? Strange indeed. :S

I don't suppose this matters, but could it be a bad BIOS? (Don't see how they're related to Save States though.....) Just taking a wild guess here right now.
 
1 - 20 of 21 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top