Next Generation Emulation banner

SaGa Frontier 2 Frustration

1632 Views 7 Replies 3 Participants Last post by  hushypushy
Hello Everyone!
I am hoping that someone can please help me - I have looked at everything I can find on Saga Frontier 2 (PAL), here and elswhere, and can't solve my problem. If anyone can, please do! :D
The game begins alright, and goes automatically into a bit of story (no SF2 data on mem card) - guys having a fight, army routed, King calls off the rout to go back to the castle and see his new born son, all very jolly, names him Gustav XIII - and then it freezes black (seen this about 50 times!).

I have tried all these things, in many combinations:
- I tried playing around with a patch - ePSXe Help said I would need one - but I reckon if that were the problem the game would not start at all, which it does.
- Get the same result running off the disc or an ISO.
- Tried starting ePSXe with command line switch -noauto; same result.
- Tried starting ePSXe with command line switch -auto, which has been mentioned as a special SF2 fixing switch, but this is not recognised as valid.
- Tried starting ePSXe with command line switch -nomdec (I reckon an MDEC is about to kick in when it freezes); same result.
- Tried all sorts of different video settings; same result.

I am now at a complete loss as to what to try next. :???:
My versions are all quite up to date - I am using:
ePSXe 1.6.0
Pete's OpenGL2 Driver 2.6
P.E.Op.S. DSound Audio Driver 1.9 [Doubt relevant]
Internal ePSXe W9X CDR [Doubt relevant]

If anyone can help, I would be eternally grateful - maybe :2love: !

Hope so,

Fu Hsi
See less See more
1 - 2 of 8 Posts screen?!

Use PSXeven in this case. Most probable caused by a badly treated CD. :p
*he wears it everywhere...
1 - 2 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.