Next Generation Emulation banner

1 - 13 of 13 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I just downloaded the latest VBA-M and loaded it up with Pokemon Crystal.

The game is running so fast I have no idea what to do. I would really enjoy playing it, but it's just too fast to get anything accomplished. How do I slow it down?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #2
I got it to slow down by setting frame skipping to automatic.

Hopefully if anyone else has this problem this helps.
 

·
Registered
Joined
·
191 Posts
All VBA incarnations have the same problem and there is no solution but setting frameskip into automatic.Although, this is not a complete solution.
VBA will try to adjust emulation speed to 100% but there will be times when it won't be able to do so.

If that's a mayor for you, i recommend using >>BGB<< as a GB/GBC/SGB emulator.
All VBA incarnations are good GB/GBC/SGB emulators but they are not the best.
[IMO]
>>BGB<< is a better GB/GBC/SGB emulator than VBA or VBA-M.
 

·
Registered
Joined
·
1 Posts
I have Throttle to "No Throttle" and Frame Skip to "No Frame Skip" with "Automatic" NOT checked. Games run at the normal 100%.

I find that if I have Automatic frame skipping turned on, the sound becomes choppy even if the game is still running at 100%.
 

·
Hackin 'n Slashin
Joined
·
28,630 Posts
If you want GBC/GB emulation that VBA's forerunner VisualBoy would be a good place to start.
 

·
Just Myself
Joined
·
21 Posts
There is a simple answer. Go to Options->Emulator->Synchronize and make sure that's checked. Also, in the same menu, make sure that Speed Up Toggle is not checked. That will fix your problem completely for every game.
 

·
Registered
Joined
·
2 Posts
There is a simple answer. Go to Options->Emulator->Synchronize and make sure that's checked. Also, in the same menu, make sure that Speed Up Toggle is not checked. That will fix your problem completely for every game.
Mine is running at about 400%-500% and synchronize is checked and speed up toggle is off. It did this last time and all I did was redownload it. But I want to know how to fix it instead of redownloading it every few days.

Edit: Even when I set the throttle to 100% and the Frame Skip to 0 it not only gets really choppy but when I play a game, half the time if I do a certain action the entire thing freezes up. Also at the beginning it takes a few seconds to load the actually game, the screen starts off gray and then the speed goes between 3000%-5000% rapidly.
 

·
Hackin 'n Slashin
Joined
·
28,630 Posts
There's no way audio synching is enabled if it runs that fast.
 

·
Registered
Joined
·
1 Posts
I had the same problem, but I got it fixed. Many ppl say u have to set ur throttle to "No Throttle," but they're wrong. Set it 2 100%, and ur speed should be fine. Make sure "Vsync" is checked (In "Video").
 

·
Registered
Joined
·
1 Posts
I had this problem, I fixed it by going to Options:Audio:Output API:Synch Game to audio. I turned that off then turned it back on and Viola! it was fixed.:D
 

·
Registered
Joined
·
1 Posts
I just downloaded the latest VBA-M and loaded it up with Pokemon Crystal.

The game is running so fast I have no idea what to do. I would really enjoy playing it, but it's just too fast to get anything accomplished. How do I slow it down?
Okay, So I don't know if your sound is playing but if not (Or even if it is) go to [Options -> Advanced] And change the sound device to OpenAL or whichever one works and it should slow down to normal and music should be present
 

·
Registered
Joined
·
3 Posts
Okay, So I don't know if your sound is playing but if not (Or even if it is) go to [Options -> Advanced] And change the sound device to OpenAL or whichever one works and it should slow down to normal and music should be present
in newer versions of VBA-M (like the 2.x versions), OpenAL option is no longer available. I use XAudio2
 
1 - 13 of 13 Posts
Top