Next Generation Emulation banner

1 - 9 of 9 Posts

·
Registered
Joined
·
9,504 Posts
Discussion Starter · #1 ·
Finally some water for this news drought! Rice has updated his video plugin for Nintendo 64 emulators today......here are the version changes
  • External high resolution texture loading. Read HiRezTexture.txt for further information
  • Texture group dumpping
  • Zelda MM point lighting
  • Software vertex clipper problem fix by not using inline for a few important functions.
    Microsoft C++ compiler did a very bad job of optimization before. By converting these inline
    functions to regular functions, the clipper works with much less glitches now.
  • Some fixes on a few color combiners, including DirectX high-end, opengl 1.2/1.3, opengl 1.4,
    Nvidia openg register combiner. You may see various improvement on these combiners if you
    are using them.
  • Various DirectX frame buffer related fixes
  • Using BMGLibPNG to handle PNG files. The include BMGLibPNG.dll file must be placed under
    your emulator folder, not the plugin folder.
» Source: <A HREF="http://www.ngemu.com/forums/showthread.php?p=837528#post837528" TARGET="_blank">hellmasterx</A>

» Download Rice Video 6.1.0 <A HREF="http://www.ngemu.com/download.php?action=plugin&id=37">here</A>
» Emutalk <A HREF="http://www.emutalk.net/showthread.php?t=26229" TARGET="_blank">thread</A>
 

·
Resident Rabble Rouser
Joined
·
174 Posts
I got zelda to work (with some minor issues) with new hi-res textures, but the characters in mario kart are oily black. opengl is much faster than directx, but dr mario still doesn't work in opengl. who's retexturing dr. mario?!? I'd do it, (and I'm bad-assed with the gimp/photoshop) but I've been banned more times from emutalk than anna nicole smith from TV.

*sigh* emutalk ****s!!!!

rhY

Over all, awesome plug rice, gg!!!
 

·
Registered
Joined
·
907 Posts
yeah this release is cool! in fact IMO amazing!!
All people saying that emuscene is dead or almost, bah look at this :D
simply amazing!!
wbr Shin Gouki
 

·
Moo.
Joined
·
455 Posts
It's working somewhat better... Also, my compy uses DirectX 9.0C, and it has 32MB of Video RAM.

This new emulator appears to use more RAM and Processor speed at regular settings when compared to 6.0.0C as well.

The graphics appear and look smoother, in general.

Legend of Zelda : Ocarina of Time now shows water effects...

Ogre Battle 64 Still shows backgrounds (perfectly without frameskip), and displays backgrounds better with Frameskip turned on (though it's not perfect, there are still moments where it'll crap out and you'll get a FUBARed background)

GoldenEye 007 runs even faster than before! Yay! (Without Frameskip, game doesn't work with Frameskip turned on.) (Runs about 40FPS at 933 MHZ, 640 RAM, whereas with 6.0.0C it was running about 30.)
 

·
Emu Author
Joined
·
613 Posts
ok i got a nice question that i hope can be answered. ok i remember soem time back i tested a version of this emu and by a miracle in oo7 i believe i was able to get the blood effects to work(where it shows red in the area you shot them) well now i can not seem to get that to work and forgot how i did it before.

what i was wondering was is it possible to get this to show up or was i just seeing things, and if so plz let me know how:) .

(if you not noticed when i play games i want the full effect of playing :D )
 

·
Moo.
Joined
·
455 Posts
swatgod said:
ok i got a nice question that i hope can be answered. ok i remember soem time back i tested a version of this emu and by a miracle in oo7 i believe i was able to get the blood effects to work(where it shows red in the area you shot them) well now i can not seem to get that to work and forgot how i did it before.

what i was wondering was is it possible to get this to show up or was i just seeing things, and if so plz let me know how:) .

(if you not noticed when i play games i want the full effect of playing :D )
You're not dreaming, I saw them too, but I simply used default settings. I'm not sure if they're gone in 6.1.0. I'll have to test that.

Edit: Hm... strange. The gunshots seem more grainy in 6.1.0... Didn't see any blood in the test I ran though. Sorry. Could be 6.1.0 removed something that was causing it.
 
1 - 9 of 9 Posts
Top