Next Generation Emulation banner
1 - 11 of 11 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
It doesn't matter what game I test it with, what key I bind rewinding to, or how I tweak the rewind settings, whenever I try to use the rewind functionality, instead of actually rewinding like it's supposed to, all it does is jump back to the last point where emulation was paused or the last save state that was loaded.

I have the latest dev build, and my rewind settings are as follows:
Rewind: Enabled
Save Frequency: 0.00 seconds
Buffer Size: 500 frames
Runahead: Disabled
Keybinding: Blackslash
 

·
Not a Registered User
Joined
·
1,558 Posts
That's because you put 0 in save frequency.
Rewind is really more of a auto save state.
Save Frequency: You put here how often you want it to save state, every 2 seconds, every 5 seconds etc.
Buffer Size: 500 frames: Here you how many of the saves you want. 500, 1000 etc.
Hold the rewind key for it to keep going back in a slide show manner.

Fair warning Rewind can eat up RAM and VRAM like crazy if you set it very high, in rewind setting it will tell you how much it will need with how much you set it.
Rectangle Font Parallel Screenshot Darkness
 

·
Not a Registered User
Joined
·
1,558 Posts
I dunno seems working fine to me.
This is save frequency at 1 sec, I could make it more fluid by putting in 0.1 like you did but that destroys my PC you need a beefy setup for that.
"real-time rewinding " in no emulator that's a thing all emulators do the same just make save states every second or half a second or even more often, the difference is that weaker systems like NES/SNES or GBA doing this is far far less demanding so you can make save states in milliseconds.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #6 · (Edited)
Ok, so I tried replicating this by setting the frequency to 1.00 and the buffer size to 300, and I think I figured out what's going on.
As you can see, it works within what I'm assuming are the 300 saves that were recorded during gameplay. Anytime I press rewind after that, it jumps back to the last point within those saved frames that I rewinded to regardless of progress, and then rewinding continues from there, as opposed to overwriting old save states with new ones as gameplay progresses.
I don't think this is how it's supposed to work, because it wouldn't make sense at all if it was.
 

·
Not a Registered User
Joined
·
1,558 Posts
Hmm you could try updating Duckstation to a preview version maybe that could help if you don't already have the preview version.
In general settings change the update channel from latest to preview and press check for updates, you can always go back by picking the latest and click check for updates to revert back.

What specs you got? Rewind does devour RAM and VRAM like crazy so this could be an issue of not enough memory so portion of it gets wiped.
Rewind should always move you back the amount you wrote in save frequency, in this case 1 sec and it should be continues meaning the oldest saved frame should be overwritten by the newest one when running out of frames.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #8 ·
Ok, so I updated to the latest preview build, and tried again with all the same setting configurations.
The problem is more or less exactly the same as it was before, the only difference being that the time between frame rewinds is slower (more akin to your video).

I'm running Windows 10 Home x64 on a Dell XPS 15 7590 laptop with an NVIDIA GeForce GTX 1650 and 64 GB of RAM (46.1 GB available).

I'm running duckstation 0.1-5016-gcb127b64 (master). The rendering mode is set to Vulkan, Adapter is set to the aforementioned 1650, and I have the internal resolution set to 9x with geometry correction enabled for the best visuals.
 

·
Not a Registered User
Joined
·
1,558 Posts
Lucky you I have a similar laptop and your issues is lack of VRAM.
You're asking that poor 1650 with its little 4gb of VRAM to render frames at 4K which by itself eats up a gig then to save those frames?
My 1650 4gb VRAM pool was completely filled in 5 seconds flat.
Try lowering the rendering resolution and then test.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #10 ·
I checked "turn off all enhancements", and now the rewinding works properly.

Although I'm not sure I follow when you say "4gb". I don't know if that's a typo, but I seem to have specified that my available physical RAM was in the double digits of gigabytes.

But aside from that, I'm still a little bit confused. If my system is being overworked by the rewind feature, wouldn't that just cause my system to lag, as opposed to flat-out refusing to even attempt to get the feature working properly?
 

·
Not a Registered User
Joined
·
1,558 Posts
I checked "turn off all enhancements", and now the rewinding works properly.

Although I'm not sure I follow when you say "4gb". I don't know if that's a typo, but I seem to have specified that my available physical RAM was in the double digits of gigabytes.

But aside from that, I'm still a little bit confused. If my system is being overworked by the rewind feature, wouldn't that just cause my system to lag, as opposed to flat-out refusing to even attempt to get the feature working properly?
"Turn off all enhancements" sets the rendering resolution to 1x instead of 9, it also disables other things like PGXP, filters etc.
RAM is not the same as VRAM, you have 64GB of RAM but your graphic card has its own separate video memory VRAM a laptop 1650 has 4gb of VRAM/
The system won't be overworked it will save the states but because those saves at 9x 4k eat up a lot of space it gets filled up to quickly and older saves are overwritten sooner then they should be which breaks the function.
 
1 - 11 of 11 Posts
Top