Next Generation Emulation banner
41 - 60 of 64 Posts

· Premium Member
Joined
·
5,486 Posts
Discussion Starter · #128 ·
thanks, will add them soon,

Are you sure tombraider needs a hookmask? i played this game and did not need one.

also, can you indicate whether teh game has both 32bit and 64bit executables, i highly doubt all those games are 64bit only with 32bit windows still having a pretty decent market share.
 

· Premium Member
Joined
·
5,486 Posts
Discussion Starter · #130 · (Edited)
AC2 was my guess, but if you need FakeVid/FakePid then use 1E instead.

As for not using a mask, if a game doesn't need it you won't need to put anything in the gdb, it'll just work by putting the file in the folder.

i'll put a note in that those last 2 games need the dinput.dll
 

· Premium Member
Joined
·
5,486 Posts
Discussion Starter · #137 ·
And the next wrong hookmask is for hawx and hawx2 .
HookMask=0x0000000E Does not work. (has wrong button mapping for both games)

I tried old version of x360ce (that don't have x360ce.exe) 3.1.4.0 libs with this options :

[Options]
UseInitBeep=1 #use 0 to 1; default 1; beep on init
Log=0 #use 0 to 1; creates a log file in folder 'x360ce logs'
FakeAPI=1 #use API patching

This worked great for hawx (All things are working).
But for hawx2 nothing worked.(I tried all previous versions and all hookmasks with no chance,and if something worked, buttons were mapped wrong)
HawX works perfectly with those hookmasks, both Tapeq and myself have tested them.
What controller do you have?
 

· Premium Member
Joined
·
5,486 Posts
Discussion Starter · #145 ·
And another question, If the game "gears of war" has an unique hooking method, so why it's hookmask is not in the gdb file ?
Is that not compatible with new versions of x360ce ?
lol, we could never get confirmation on the executable!.
 

· Premium Member
Joined
·
5,486 Posts
Discussion Starter · #146 ·
Hi, I'm having trouble playing Turbo Dismount. The button mapping is incorrect.

Controller: Logitech F310 Gamepad
library: x360ce_lib32_r848_VS2010
Hook:
[InputHook]
HookMode=1
HookLL=0
HookCOM=1
HookSA=0
HookWT=0
HookDI=0
HookPIDVID=0
HookName=0

Log:
TIME THREAD TYPE DATA
06:49:47.864 00007888 [Core ] Using game database file:
06:49:47.864 00007888 [Core ] D:\Program Files (x86)\Turbo Dismount v1.5\x360ce.gdb
06:49:47.870 00007888 [Core ] x360ce 3.4.0.848 [TurboDismount.exe - 7232]
06:49:47.870 00007888 [Core ] Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit
06:49:47.870 00007888 [IHook ] InputHook starting with mask 0x00000002
06:49:47.870 00007888 [HookCOM] Hooking COM
06:49:47.870 00007888 [HookCOM] Hooking CoCreateInstance
06:49:47.870 00007888 [HookCOM] Hooking CoUninitialize
06:49:49.813 00007888 [HookCOM] *CoCreateInstance*
06:50:00.376 00007888 [Core ] Terminating x360ce, bye

any help?
No help im afraid, Turbo Dismount uses Unity Engine, which doesn't actually use Xinput properly.
The only aspect of Xinput it uses is Vibration, the rest is all RawInput.
 

· Premium Member
Joined
·
5,486 Posts
Discussion Starter · #164 ·
It's a Genius Maxfire Blaze 3, analogue sticks

I just reviewed results and edited my previous post
no, i was asking if the triggers are Digital.

Call of duty black ops works perfect, but with no aim assist and vibration. (is it related to x360ce i mean vibration?)
Black ops 2 works flawlessly.
This is limitations of the game.


- you can't navigate menus with controller
- sadly, there are no rumble effects at all, also no aim assist
- annoying mouse cursor appears in the middle of the screen during cinematics
 
41 - 60 of 64 Posts
Top