Next Generation Emulation banner
1 - 20 of 173 Posts

·
RPG n00b guru
Joined
·
86 Posts
OGL2 configs for FF8

FMVs that sometimes freeze for a second?

Battle Swirls that cause the FPS to drop like Michael Jackson's career?

Observe:

Plugin: Pete's OpenGL2 Driver 2.6
Author: Pete Bernert
Card vendor: ATI Technologies Inc.
GFX card: RADEON 9800 SE x86/SSE2

Resolution/Color:
- 640x480 Window mode
- Internal X resolution: 1
- Internal Y resolution: 2
- Keep psx aspect ratio: off
- No render-to-texture: off

- Filtering: 4
- Hi-Res textures: 0
- TexWin pixel shader: on
- VRam size: 128 MBytes

Framerate:
- FPS limitation: on
- Frame skipping: off
- FPS limit: 65

Compatibility:
- Offscreen drawing: 1
- Framebuffer effects: 2
- Framebuffer uploads: 0

Misc:
- Scanlines: off
- Mdec filter: on
- Screen filtering: on
- Shader effects: 0/1
- Flicker-fix border size: 0
- GF4/XP crash fix: off
- Game fixes: off [00000000]

--------------------------------------------------------------------------

That's what I've tweaked my settings to, so far. As of yet, the same problems, as stated above, arise. I've had help before, yet that help did not seem to work (probably because it was posted to the wrong forum).

I say let us finish the playstation series of Final Fantasy off in this forum (besides those that would use PEOPS due to being 2d), and come up with a setting that would even work on a card with only four graphic pipelines (the other four being disabled).

The rest, I leave to the members of this forum to decide...
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,982 Posts
wow, at first i was very excited because i never got FF8 to run right, but i tried the settings and same old thing (see screenshots). it's not your config, because i tried every setting on OD/FA/FT and the menu didnt change. so far this game perplexes me.

just a couple of quips, constructive criticism if you will :) was Pete's config OD/FE/FU at 1/2/2 and special games fix not good enough for you? i see you didnt use either of them. also, i like to turn hi-res textures to "smoothing' because if you dont it's easy to get nasty tiling especially in the FF games. also, why is your FPS limit set to 65? it should be the same as the region you live in, for game compatibility sake ;)

other than that....i dont know. the config didnt work for me. hopefully someone with a Radeon can try it out and see if the problem lies in Nvidia.
 

·
RPG n00b guru
Joined
·
86 Posts
Discussion Starter · #3 ·
A few things to clear up

I guess I wasn't clear with my last message, I was still having the problems, but to a lesser degree.

Now, if I peruse 1/2/2 and Pete's special fix, I get an interesting black box, as you can see in one of my screenshots.

Also, in another screenshot, I show my title screen with no problems...

Anyway, I believe my problem is centered around the fact that my 9800SE is pretty much half as good as what a regular one is (half the pipelines are used).

There ARE problems, and there are still problems, even with the config that seemed to work okay that I posted earlier.

The next question is: what now?
 

·
Premium Member
Joined
·
12,032 Posts
I'll try this one with my card guys ;)
 

·
RPG n00b guru
Joined
·
86 Posts
Discussion Starter · #5 ·
Plugin: Pete's OpenGL2 Driver 2.6
Author: Pete Bernert
Card vendor: ATI Technologies Inc.
GFX card: RADEON 9800 SE x86/SSE2

Resolution/Color:
- 640x480 Window mode
- Internal X resolution: 1
- Internal Y resolution: 2
- Keep psx aspect ratio: off
- No render-to-texture: on

- Filtering: 0
- Hi-Res textures: 0
- TexWin pixel shader: on
- VRam size: 128 MBytes

Framerate:
- FPS limitation: on
- Frame skipping: off
- FPS limit: 65

Compatibility:
- Offscreen drawing: 1
- Framebuffer effects: 3
- Framebuffer uploads: 1

Misc:
- Scanlines: off
- Mdec filter: on
- Screen filtering: on
- Shader effects: 0/1
- Flicker-fix border size: 0
- GF4/XP crash fix: off
- Game fixes: off [00000002]


-------------------------------------------------

What a difference "no render to texture" makes.

Anyway, I tried 65 FPS at the behest of another member of the forums who used it (it doesn't cause me any problems at all, though maybe it might have to do with the "character flickering" I get whenever I change screens, that is if my FU aren't in effect).

I basically used what was posted to be Hushypushy's settings for FF7 or something like that. Turns out... that works just fine. The only problem still stems from Pete's fix leaving that little black box, and it still does the same when I'm not redering to textures.

Alas, the Black Wind howls once again for my card, which will never be able to run a game with true optimum settings...
 

·
Premium Member
Joined
·
12,032 Posts
Must be your guys' cards. I tested with mine and everything runs perfect and smooth. Of course cause I own an ATi I can't get the very high x, but it still runs perfect other than that. ;)
 

·
RPG n00b guru
Joined
·
86 Posts
Discussion Starter · #7 ·
Actually, most things are running smooth for me now, so I dunno. The settings I used with "no render to texture" really fixed things for my speed. Ugh... sometimes I wish I bought a Pro instead of an SE.
 

·
Premium Member
Joined
·
12,032 Posts
The 4 extra pipeline would definately help in some cases. ;) Still a good card though :)
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,982 Posts
Novalon said:
Actually, most things are running smooth for me now, so I dunno. The settings I used with "no render to texture" really fixed things for my speed. Ugh... sometimes I wish I bought a Pro instead of an SE.
well you can always softmod the SE up to a normal, right? try to enable those pipelines.

anywho, maybe it's the curse of NVidia. i'll try lower internel res later when i'm not so tired
 

·
Premium Member
Joined
·
12,032 Posts
As for the pipeline, it was reported on some cards that thee were actually four more that weren't active. But the chances are really low, as they were really 9800 pro's that didn't pass some tests for some reason or another ... Wouldn't hurt to see though, don't get your hopes up ;)

Well at least a nvidia card lets you have both very high x and y res :p it's so sad for the "red side" :laugh:
 

·
RPG n00b guru
Joined
·
86 Posts
Discussion Starter · #11 ·
I could try a softmod once I get back to college (and my broadband), as what I have at the moment is rather subpar in the realm of connections.

If worse comes to worse, I could use R-Tool to disable Hierarchal-Z and see if I can get rid of any artifactoring issues...

Or next Christmas, I'll just buy another card and give a friend of mine a deal on a card that he needs to be able to play FFXI with.

By the way guys, thanks alot. If anything comes up, I'll be sure to let you guys know. Maybe I'll actually gain a knowledge to help others when the time comes...

Over and out.
 

·
Premium Member
Joined
·
6,341 Posts
Razor Blade said:
Must be your guys' cards. I tested with mine and everything runs perfect and smooth. Of course cause I own an ATi I can't get the very high x, but it still runs perfect other than that. ;)
Were the battle swirls normal looking? That's my main problem with FF8 and my card. Either the swirls look perfect and there's flickering black boxes in battle (like the ones Novalon got) or the swirl is black with rainbow streaks and the rest of the game is perfect (no flashing black boxes). I'll have to experiment with it a bit more once I get home (I keep forgetting about the ability to change the settings in-game :p).
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,982 Posts
(I keep forgetting about the ability to change the settings in-game ).
everybody does ;)

dude, it would've been near impossible to test out my FF9 configs without the in-game menu...you know how many changes i had to make to everything?

/me bows down to save states and pete's in game menu :bow:
 

·
Premium Member
Joined
·
6,341 Posts
I tried messing around with the OGL2 settings and FF8 without using the on screen menu, it sucked :p. I've never tried using save states to test settings, I should try that sometime :).
 

·
Premium Member
Joined
·
12,032 Posts
>>Were the battle swirls normal looking?

Not really. They weren't slow though. It was just kind of like it started then went black for a second then went into battle :p
 

·
Go-player 15 kyu ^^
Joined
·
185 Posts
hushypushy said:
wow, at first i was very excited because i never got FF8 to run right, but i tried the settings and same old thing (see screenshots). it's not your config, because i tried every setting on OD/FA/FT and the menu didnt change. so far this game perplexes me.

just a couple of quips, constructive criticism if you will :) was Pete's config OD/FE/FU at 1/2/2 and special games fix not good enough for you? i see you didnt use either of them. also, i like to turn hi-res textures to "smoothing' because if you dont it's easy to get nasty tiling especially in the FF games. also, why is your FPS limit set to 65? it should be the same as the region you live in, for game compatibility sake ;)

other than that....i dont know. the config didnt work for me. hopefully someone with a Radeon can try it out and see if the problem lies in Nvidia.

I've never had these problems with either NVidia or ATI.. Are you using OGL 2?
 

·
Go-player 15 kyu ^^
Joined
·
185 Posts
Set OD/FE/FU to 1/3/1 and enable the special game fix. It works like a charm. Perfect speed even in battle swirls. The battle swirl is beautiful. Heh.
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,982 Posts
TheMaister said:
Set OD/FE/FU to 1/3/1 and enable the special game fix. It works like a charm. Perfect speed even in battle swirls. The battle swirl is beautiful. Heh.
holy penis, it worked.

all i've tried is this beginning of the game, but so far it's managing to show everything. i'll try battles later and see what i get.

PS, for any potential FF8 testers--switching settings on the fly DOES NOT WORK. you'll have to restart ePSXe every time :(
 

·
RPG n00b guru
Joined
·
86 Posts
Discussion Starter · #19 ·
Nice thread progress

Glad to see that I've allowed a good OGL2 setting to be discussed and found for the game.

I used to think it sucked, but now I'm giving FF8 a chance, and it turns out to be pretty good, especially when trying not to level up at all.

Oh yeah, here's an odd graphical quirk I found, and it only happens in a few odd places in the game. Just thought you might want to take a look...

(PS: This is with "The Maister's" settings (1/3/1 and special game fix))
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,982 Posts
well i havent gotten far enough to test that, maybe i'll play this game and see (this game kicks ass, i love it :) )
 
1 - 20 of 173 Posts
Top