Next Generation Emulation banner

1 - 11 of 11 Posts

·
Registered
Joined
·
275 Posts
Discussion Starter #1
I first tried this emulator about a week ago, so downloaded it, installed it, copied plugins to it, and fired it up. Everything was great thus far, changed the plugin settings around a bit, noticed that you cant use a gamepad, and closed the options window. It then told me to re-start the emulator, which it did all by itself.. and when I re-ran it, it simply did nothing. The program itself is visible, but if I move my mouse pointer over it, theres only an hourglass that never goes away. 10 seconds later it shows up as "not responding" in the close program window. I let the emulator alone and forgot about it.

Today I got the beta release 3 thing, and got the full install with plugins, because maybe I'm missing some psinex-only plugins. Anyway after installing it again over the old copy, I ran it, chose my plugin settings, closed the emulator, and ran it again hoping for some sign of life. Nope, it did the same thing as before, locking up before I can do anything with it. I'm wonderring if theres something I should be doing or maybe .dll's I'm missing. I have epsxe running fine and adripsx running.. well.. as good as it wants to run. I noticed how psinex has the dynamic recompiler just as AdriPSX does, which appeals to me because of my slower computer (for games that actually work with AdriPSX, its a dream). Anything you guys can find that's wrong?
 

·
Registered
Joined
·
134 Posts
The only time psinex does that is when it cannot boot the bios, example on BIOS like SCPH5000 - SCPH5500.

But i cannot understand why the same thing exists on Revision 3,while the BIOS is emulated by default.

Try removing your BIOS from the directory and try opening it, while no BIOS exists in the BIOS directory. If it works, that means your BIOS image was either incompatible or broken.

Hope this helps. Never heard similar problem before.
 

·
Registered
Joined
·
275 Posts
Discussion Starter #3
I deleted them from the bios directory, and still the same thing happened... I then checked the .ini file and deleted the path to my bios on there too, and still it locked up. I'm going to try re-installing it again and choosing no BIOS.

Ok, after first run I get a small popup error saying "No CDR!" or whatnot, whatever that is. Chose dynamic recompiler, no choice for bios because I have them deleted, (for some reason now i'm getting this thunk connecting failed 32->16, never had that before), seal audio for spu, |Zink|'s image driver for cd-rom, and I left controls alone for now. Clicked "Ok" and it says to restart emulator, which it does on its own. Restart emulator, and it locks up as before. Here's what I have in my .ini file:

[GENERAL]
BIOS=BIOS\SCPH1001.BIN
CD Device=
CPU Mode=True
Direct Boot=True
New User=False

[PLUGINS]
Graphics=PLUGINS\gpuPeteD3D.dll
Sound=PLUGINS\spuSeal.dll
CD-ROM=PLUGINS\cdrDiskImage.dll

(and then all the controller settings)

possibly I need something in my CD Device spot?
 

·
Registered
Joined
·
134 Posts
Everything seems ok.

I now think of something else. Do you know if your AMD is capable of MMX? Because my compilation of PSinex is based on MMX capable pc's and over. At least thats my settings. If not, ask me for a new compilation, a normal one.
 

·
Registered
Joined
·
275 Posts
Discussion Starter #5
MMX = yes. Any other possible reasons or things I should try?
 

·
Registered
Joined
·
12 Posts
try changing your SPU plugin... use Pete's or Null2's... some of the other plugins don't have the newer style dma functions...
 

·
Registered
Joined
·
275 Posts
Discussion Starter #9
OMG.. amazing neomax. That seemed to have fixed it. Using SEAL froze it, using "No Sound" froze it, but using Pete's Dsound 1.1, it gets rid of the hourglass and is runable.. gonna try some games now.. thanks very much. I guess this should go in a FAQ some day, huh?
 

·
Registered
Joined
·
275 Posts
Discussion Starter #11
I guess theres also a few compatibility issues it has with my computer. The only game of mine I could get to run (graphically) well was Vagrant Story. GT2 had car problems. I quickly bought a red used toyota and put it in max speed test, not only was it going at about 25fps, but the car was a polygonal mess and looked brownish. Tales of destiny 2 ran ok, but the MDEC was slow so I shut that off. I dont blame the emulator, I blame the SPU plugins that I was forced to use, since my computer has a very bad history with SPU plugins. I normally am forced to use SEAL or nothing when it comes to sound, and since I couldnt use either.. but its nothing to worry about. EPSXE runs about the same speed with the better SPUs too. Get "No sound" to work and I'm good to go. Here's a screenshot of the only game I got working, along with Pete's options tab at the top to show the FPS.
 
1 - 11 of 11 Posts
Top