Next Generation Emulation banner
1 - 3 of 3 Posts

·
Registered
Joined
·
356 Posts
Discussion Starter · #1 ·
I just got component cables for my PS2 and they are not working right. When I'm in any menu the picture isnt steady. Some times it off screen sometimes just shakey it near impossible to make out whats on screen. When I get in game the picture centers but the color is off, it seem to be really redish and funky looking. The ones I bought are from Gameshark and has a seprate wire just for XBOX. They are real cheapy wires that only costed 15 bucks and I figure that must be the problem but I want to first find out if anyone has had a problem like this before. Thank you in advance.
 

·
band
Joined
·
5,270 Posts
i do not have this problem. im just using the default ones from sony (which are pretty cheesy ~__~ )
 

·
Prepare for Descent...
Joined
·
2,844 Posts
First, connect your PS2 using the regular A/V cables (RCA/Composite). Then in the bios, go to the configuration screen and find where it says Component Output or something. I'm guessing that RGB is selected here. You don't want that to be selected, you need to have Y, Pb, Pr selected (or something similar to that). Now we turn off the PS2, reconnect the component cables and we should get an excellent picture. I hope that help.

Btw, the sony component cables aren't THAT bad. I use them and I get great picture quality out of them. Much better than Composite, that's for sure.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top