Next Generation Emulation banner

1 - 14 of 14 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Ok, my problem is that when I play Star Ocean: The Second Story with the ePSXe SPU core 1.7.0 sound plugin (default) the sound in the game is like it is in Slow motion and in a fight it hardly works at all, and the voices rarely work. And then sometimes outside of battle it'll start making this high pitched noise that won't go away unless you turn off the emulator, mute the sound on the emulator start the game up, save it, turn it off and turn the sound back on then load the game back up. I know that is a mouthful but that isn't even my problem, lol. My main problem is that when I use another sound plugin (any of them, tried about 5) it plays the entire game about 5x normal speed with NO sound...I walk really fast, fight really fast and everything, and I have no idea how to fix it, so I have to stick with the SPU core 1.7.0 until I can figure out how to fix it with another sound Plugin. Any Ideas? Sorry for such a big problem, lol.
 

·
Banned
Joined
·
23,263 Posts
use Eternal SPU, with the SPU IRQ - wait CPU action item ticked.

oh.. and according to shadow lady, try spuasync - wait
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
I've used Eternal SPU...it does what I explained, I don't understand it, hard to explain really, SPU IRQ is on by Default with that one and Star Ocean 2 is one of the games it lists there for it. Like I said, it plays it in Fast Forward, lol. The odd thing about it is that the Menu Screen isn't playing faster than normal...but as soon as I go out of the menu screen, it speeds up again. I still have no sound with it though.
 

·
Banned
Joined
·
23,263 Posts
Post your plugin configurations (screenshots will do) and system information.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Ok, It isn't running fast anymore with those settings you gave me...it just isn't playing ANY sound at all...lol.
 

·
Banned
Joined
·
23,263 Posts
Video plugins as well of course xD

---------
for audo, set Buffer to 40, and reverb to new (new is only in the Eternal SPU 1.5 beta, which is available in the plugins section of ngemu)
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8 (Edited)
Oh sorry, here is the video settings, and just so you know, I tried using FPS limit set to 60 and there is still no sound. And I put reverb on New, no change.
 

·
Banned
Joined
·
23,263 Posts
This is very odd, alot of people have played star ocean on epsxe.

all i can think is to enable all the fixes in the spu plugin, and are you using an intel, or amd dual core processor?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #10
Intel...I've beat this game at least a couple hundred times on the real playstation, lol...I don't understand why it isn't working, seems like it used to work for me a long time ago on here.
 

·
Banned
Joined
·
23,263 Posts
xD
ok, set it back to the internal plugin, and disable the FPS limit in the Gfx plugin, also disable frame skipping.

epsxe 1.7 has an internal frame limiter that works based on SPU timing, and it tends to conflict with the gpu based limiter if both are enabled at the same time.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #12 (Edited)
Ok, I'm going to tell you something that makes me look really stupid...if I start the game up with the Eternal SPU with the settings you gave me and I let the game load up and start it that way, it works just fine with perfect sound. I always LOAD STATE and the sound stops working if you LOAD STATE for some reason, must unsync or something. I always LOAD STATE because when I use a save point in the game, when I turn off my ePSXe it deletes my save...so I have no choice but to use the Save/Load state feature. My memcard folder is empty, I downloaded a memcard manager but that doesn't help my problem any...is there a Memory card I need to download? I couldn't find anything on Ngemu.
 

·
Banned
Joined
·
23,263 Posts
xD, ok we'll start with that memory card issue.

Go into the memory card dialogue, then click browse on each one, type a name then hit open (also functions as save)

Then do this again and hit open(save)

Ok, now you have 2 sets of memory cards, and theres a good reason for this,

When you load the state it will write the currently selected memory cards as blanks, which is where you've been going wrong basically.

So once the state is loaded, hit escape, then select the other 2 files you created, Resume emulation then save to them,
then hit escape, and do File > Quit.
This should update the memory card file and write the save data.
(Note:, If you Save a state now, then load it it will also update the memory card files and also contain the memory card data and no longer have this problem in the future (as long as the state doesn't corrupt)

When you load from the memory card the audio will be fine. with the Eternal Spu plugin.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #14 (Edited)
OMG...thx for all your help...my sound is finally working and I can just load from Memory cards now :D, thx again. Let me know if there is anything you ever need help with, lol. Well, it is 7 AM here and I've yet to go to sleep, now that it is working I might finally be able to sleep :D. I'll chat with you when I wake up maybe.
 
1 - 14 of 14 Posts
Top