Next Generation Emulation banner

1 - 12 of 12 Posts

·
Super Moderator
Joined
·
6,283 Posts
Discussion Starter #1
Well,I just wondered if someone else than me experienced this problem:
in FF7(french pal version)the sound of the mdecs is not in sync with the image,
for exemple:the intro movie and the ending movie.
I believe it may be related to the fact that it's a pal version but I'd like to know if someone knows how to correct this,or if it is a problem in ePSXe are the authors aware of this and do they plan todo something about it?
 

·
Registered
Joined
·
9,506 Posts
I had the same problem with syphon filter. I had set my own FPS limit (Petes OGL). Setting it to autodetect and switching off Unfiltured framerate updates corrected this. Might be the same problem
 

·
Super Moderator
Joined
·
6,283 Posts
Discussion Starter #3
Thanks,but it didn't work.
I think it comesfrom the fact that the music on these mdecs is not coded with the video or something like it.
It can't come from a slowdown since I always get 50 fps and a friend who has an atlhon 1ghz has the same problem.
I've also tried every SPU but I get the same result.
So it must be the emu.
I hope it will be fixed one day.
 

·
Registered
Joined
·
298 Posts
try useing null's latest plugin with these settings (sound is perfect for me in all final fantasy games)

attributes = 44100Hz, 16bit
buffer length = 40
block = 6
interval = 6ms

misc.
use reverb = disabled
mute xa/vag stream = disabled
reverse l/r = disabled
enable vag stream = enabled
force vag 48kHz = disabled
linear interpolation = enabled
enable tone-cache = enabled




:cool:
 

·
Super Moderator
Joined
·
6,283 Posts
Discussion Starter #5
It still doesn't work.
Thanks anyway
 

·
Registered
Joined
·
21 Posts
hmmm...

Maybe you have old bios
Maybe you have programs running in the background
Maybe your cd is slow, try running from ISO

Maybe you just have bad luck :D
 

·
Super Moderator
Joined
·
6,283 Posts
Discussion Starter #7
I tried to play via an iso, I've tried all my bios(7),my cd drive isn't slow(52x),no programs running in the background,but I don't think it's about luck.
When I say "not in sync" I mean that the music comes later than when it should be heard, ex:when the FF7 logo is diplayed in the intro at this right moment the music becomes louder,for me the music only comes 5-10 secs later but I can still hear the footsteps or cars at the right moment because they're coded with the video but the music isn't(try to watch them with PSMPLAY and you'll understand what I mean).
But,I still think it comes from the fact it's a pal version and that the emu is not coded correctly for pal games.
I've tried VGS and the music is heard when it must be heard but it looks really awful with it so I guess I'll just have to wait for this problem to be fixed.
WOW,now that's a LLLLLLLLLOOOOOOONNNNNNNGGGGGGG post:)
 

·
Registered
Joined
·
17 Posts
You might need to force epsxe into PAL mode (in epsxe, Options->Country->PAL, in epsxecutor, quick configure the game, go to the options tab, and set the country to PAL). Assuming that doesn't fix it (you probably already have it set to PAL), it's probably an emulation bug; you might try forcing it to NTSC timing to see if it makes it better (or worse?).

I don't have the PAL version of FF7 (or, for that matter, any other game ;) so I can't test this, but at one point I was running the US version of ff7 at PAL timing because I thought the game was running too slowly otherwise (not slow as in framerate, slow as in game speed, particularly noticable with the music dragging out). That seemed to speed it up to where it belonged, but the openning movie was out of sync with the sound. At this point, I think Pete's and Lewpy's plugins both allow for manually setting the frame limit cap, so I've been meaning to test that one of these days.
 

·
Super Moderator
Joined
·
6,283 Posts
Discussion Starter #9
Yes I can get the ingame music at the right speed but not in the mdecs and if Itry to limit the fps using pete's plugin islows down the music(and the game of course)but it's still out of sync in mdecs.
Too bad I can't get it to work properly:(
 

·
Registered
Joined
·
17 Posts
Well, I sat down with the US version of ff7, reinstalled epsxe 1.01 so I could start a new game, and played with different settings and plugins tonight and managed to accomplish absolutely nothing. The timing is very consistent from test to test, just wrong. Bleh.

I'd have to guess it's a timing problem in the spu code in epsxe itself (either that or a problem in the code of every spu plugin, which I suppose is possible but not terribly likely). I figured it was a problem with the PAL/NTSC timing, but it doesn't seem to be; when autodetect is on, the game time is accurate but the music is too slow. If I set the fps limit in Pete's up to about 66, the music speeds up to about normal, but the clock runs fast. And regardless of what I do, the music just isn't syncing up to the movie.

Ah well, maybe they'll have this one nailed down in the next version.
 

·
Registered
Joined
·
21 Posts
I run ff7 PAL in epsxe 1.0.1 and experience no problems. (took some time to find good setting, but it works great)

A thing which can solve many issues is to format the hardrive and reinstall windows. Formatting have solved problems MANY times for me. But when it doesn't solve the problem it's pretty bad :(
 

·
Super Moderator
Joined
·
6,283 Posts
Discussion Starter #12
Pizza_maker have you ever played it on the PSX or VGS?
If not try it and tell me if the music in the intro mdec is heard at the same moment as in ePSXe,if it does could you post your settings?
About formatting my hardrive,I formatted it last week so I don't think it will change anything.
 
1 - 12 of 12 Posts
Top