Next Generation Emulation banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
I recently felt like playing Pokemon Red for nostalgia and tried it on a new emulator I never tried before. I quickly abandoned it because the save file seemed to have saved incorrectly and I had lost a few hours of grinding, with only a save file from my previous session left. I shook it off as a fault of an emulator I had never used before then.
Still unsatisfied, I then installed Visual Boy Advance yesterday (I used it years ago and remembered it being the most reliable and stable emulator I used in the distant past) and began a completely new run. However, the same thing happened... Only this time, almost an entire afternoon's worth of progress was lost to this dumb.. whatever it is, glitch. The only save files left are from the session before the last one, and there seems to be no way of restoring them or the file containing them to previous versions, or system restoring to yesterday...

I'm playing on a Windows 10 laptop. The rom I used was also the from the same website as the one I used previously, but I really doubt it's the rom's fault..

Is this a common problem on Windows 10? Something to do with temp files or.. what..? I have never once encountered this problem playing on my old laptop a long time ago...

Edit: decided to just start over from that most recent file.. nevermind, i guess! gonna back up my saves in another file from now on.
 
1 - 1 of 1 Posts
Top