Next Generation Emulation banner
1 - 17 of 17 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Hey everyone!! Im new to emulation and to in this forum, but I hope someone will help me with my problem. I trying to play FF7 on epsxe 1.70.
I was searching web and couldn't find solution to my problem.

Plugin: Pete's OpenGL2 Driver 2.9
Author: Pete Bernert
Card vendor: NVIDIA Corporation
GFX card: GeForce 9600M GT/PCI/SSE2

Resolution/Color:
- 1280x800 Fullscreen - Use Window size in Fullscreen mode
- NO desktop changing
- Internal X resolution: 2
- Internal Y resolution: 3
- Keep psx aspect ratio:
- No render-to-texture: on

- Filtering: 5
- Hi-Res textures: 2
- TexWin pixel shader: on
- VRam size: 512 MBytes

Framerate:
- FPS limitation: on
- Frame skipping: off
- FPS limit: Auto

Compatibility:
- Offscreen drawing: 2
- Framebuffer effects: 2
- Framebuffer uploads: 2

Misc:
- Scanlines: off
- Mdec filter: on
- Screen filtering: on
- Shader effects: 1/4
- Flicker-fix border size: 0
- GF4/XP crash fix: off
- Game fixes: on [00000002]

You can see my graphic card is geforce 9600m gt. It is on notebook and Im using vista.
The problem is that all the 2D background are terrible pixelated and the movies look bad, it seems like Im using low resolution, but Im not(1280x800).I was trying changing sme of the graphic options, but it didnt help.
And the last thing - sorry for my English, my native language is Polish .
 

·
From Love and Limerence
Joined
·
6,584 Posts
Your english isn't bad at all. Had you not mentioned that, I would never had noticed.

The problem is likely the last thing you're expecting. It's because you're using a high resolution. The game is natively 320x224. When you run it at anything higher than that, as all things natively small and made larger, it either pixelates or blurs and/or filters to make it larger. 3D looks better the higher resolution, but pre-drawn 2D backdrops look worse. You're running it roughly three and a half times the original size, hence, it looks really pixelated.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #3 ·
Thanks for answer. What you are saying about the resolution make sence, but the lovest resolution I can choose is 640x480 and 2D still look bad in it. I read many epsxe configuration i the web and people usually choose much higher resolution. Shouldnt texture filtering and Hi-res texture options take care of pixelated backgrounds?
 

·
Registered
Joined
·
7,407 Posts
Can you post a screenshot so we can know whether it's an actual problem or just a misinterpretation? Your filtering settings are set to what they should be to filter both 2D and MDECs.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #5 ·

·
Registered
Joined
·
7,407 Posts
That's the best it's going to get. Lord Zedeck's post explains why - nothing you can do about it.
 

·
Registered
Joined
·
7,407 Posts
Yep, exactly the same.
 

·
Discontinued
Joined
·
1,192 Posts
Download the OpenGL2 shader pack from:
emugameshader - Google Code

Under Pete's OpenGL2 fullscreen filters:
1. Click 'Shader effects', set to 5
2. Click '...' to right of Shader Effects
3. Point to the shader from the unpacked file above
(I extracted to epsxe\shaders)
(I selected directory epsxe\shaders\4xScale shaders\4xGLSoft)
4. Set 'Shader level' to 3 or 4
5. You might need 'Flicker-fix border' to 1 (some games like FF9 on 9600M GT)


Plugin: Pete's OpenGL2 Driver 2.9
Author: Pete Bernert
Card vendor: NVIDIA Corporation
GFX card: GeForce 9600M GT/PCI/SSE2

Resolution/Color:
- 1024x768 Fullscreen - NO desktop changing
- Internal X resolution: 2
- Internal Y resolution: 2
- Keep psx aspect ratio: off
- No render-to-texture: '… (2 - use framebuffer object)

- Filtering: 4
- Hi-Res textures: 2
- TexWin pixel shader: on
- VRam size: 512 MBytes

Framerate:
- FPS limitation: off
- Frame skipping: off
- FPS limit: 200.0

Compatibility:
- Offscreen drawing: 2
- Framebuffer effects: 3
- Framebuffer uploads: 1

Misc:
- Scanlines: off
- Mdec filter: on
- Screen filtering: on
- Shader effects: 5/4
- Flicker-fix border size: 1
- GF4/XP crash fix: off
- Game fixes: off [00000000]
 

·
God of Douchebagness™
Joined
·
15,294 Posts

·
Registered
Joined
·
14 Posts
Ok, so I used Window mode with 320x240 and the movies in the game were still blurred. Also when the opening movie is ending it goes straight to game. It is hard to me to explain it, it is like the last frame of the movie is becoming the background to the game. Even in this resolution you can see difference betwen the movie and the pixelated back ground. While on the psx this background looks like the movie.

edit- Sorry for double post I couldn't edit button.
I think I just want to much:) Background dosent look that bad. I guess I should just start playing the game already:) Anyway thatks for help.
 

·
From Love and Limerence
Joined
·
6,584 Posts
Thanks for answer. What you are saying about the resolution make sence, but the lovest resolution I can choose is 640x480 and 2D still look bad in it. I read many epsxe configuration i the web and people usually choose much higher resolution. Shouldnt texture filtering and Hi-res texture options take care of pixelated backgrounds?
640x480 is still twice (a little over vertically actually) the normal resolution. Those don't seem too pixelated. They seem more blurred than anything. Take filtering off and you'll see real pixelation.

I think you're simply overestimating how good this should look. These old games at such low resolutions (like 320x224) and masked by the anything but sharp interlaced televisions were a totally different animal than the digital high definition content of today.

Play 320x224 windowed (full screen won't work and will still look pixelated for reasons that could probably make a topic itself) if you want a true 1:1 image with no pixelation or blur. It's the only way. That's how it truly looks, and even then, it won't be ultra crisp and sharp as you've noticed yourself.

I do have a guide (which needs updating) for getting an almost natural 2D look while still retaining the 3D look if you're interested, but you honestly do need both willingness to have some blur (not for those who want super sharp and crisp) and a CRT for it to look right (since LCDs look bad outside their native resolution). Since you appear to have a laptop, which means you have an LCD, and since I'm guessing you're just overestimating how sharp and crisp these should be and don't like the current blurriness, I'd definitely say the guide probably isn't for you. It does deal with overcoming pixelation though.
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top