Next Generation Emulation banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2,162 Posts
Discussion Starter #1
The New openGL iCD is fast but causes a bug in the plugin with regards to frambuffer. the graphics are in strips as shown below
This is with Full vram enabled. The Plug in worked fine before the install of the new drivers.
 

·
Premium Member
Joined
·
874 Posts
maybe Pete have to cuztomise His OpenGL plugin to match the new OpenGL iCD
(ver1.3) codes - maybe -
Pete doesn't think so... the new Dets are working without problems on his system...

one thing you should take care after each driver update: go and check all D3D/OGL settings in the nVidia display properties... usually the values get changed by the installation process. The usual tip to get speed and a not flickering display is to set the ogl buffer mode to block transfer.

About the messed up screen: dunno which option could cause that... prolly the texture coords get screwed somehow. Maybe the nVidia texel alignment... mmm... only nVidia knows.

Btw, what card (TNT1/2 or GF1/2/3) are you using?
 

·
Registered
Joined
·
2,162 Posts
Discussion Starter #4
ooops sorry bout that...Geforce 2 GTS, and I did make sure to check the settings....Really strange....I'll experiment and reinstall the 12.40's and test....and let you know...
 

·
Registered
Joined
·
1,247 Posts
I just spent all of last night switching back and forth between 14.70 and the 21.xx (can't recall the exact number suddenly) as well as several clean driver installs and I discovered that for my elsa geforce2 gts they do cause several artifacts to show up if I have 4x4 anti-aliasing enabled. Nothing shows up in any of the other anti-aliasing modes. I don't know if this is related to your problem, I primarily experimented with final fantasy 8.
 

·
Registered
Joined
·
2,162 Posts
Discussion Starter #6
*UPDATE*

Seems to be related to Grfx card buffer. Emulated vram works great (Just slow), when setting it to grfx buffer reads it's really, really fast(60FPS) but the messed up graphics show up.

maybe nvidia changed the way the Geforce2 memory reads and writes are done in the new drivers?
 

·
Registered
Joined
·
1,247 Posts
Blah, can't believe I forgot to experiment with the graphics card buffer. I should've guessed that would have something to do with it immediately. If nvidia changed their reading and writing to something non-standard then their backwards compatibility would be rather screwed I dare say.
 

·
Premium Member
Joined
·
874 Posts
Well, no problems on my GF3+det4 with 'gfx card' framebuffer textures... but I have to admit that I am using a beta 1.53 plugin right now, and I've changed that func to get rid off the occasional heavy shaking with some games using framebuffer textures (Chrono Cross, Alundra2, Megaman Legends 2, Jade Cocoon, etc)

Just wondering: is that glitch also in D3D, or just OGL?
 

·
Registered
Joined
·
2,162 Posts
Discussion Starter #9 (Edited)
You actually posted while I was discovering the problem...seems if you have opengl set to always use 32bit textures and are using a 16 bit screen mode in the plugin it happens...after I switched it to 16 bit textures everything is fine...


*UPDATE*
It's not just the above, ALL 32bit plugin modes cause it regardless of texture format. it has to be some kind of interaction with the new opengl driver. NO openGL games are having any problems.
This is really, really strange, especially if you are not having problems...
 

·
Registered
Joined
·
1,247 Posts
Here's a pic of the glitch I'm experiencing.

I experimented with 16 bit and 32 bit with 16 bit and 32 bit textures for both still occured, only way to get it to not occur was to turn anti-aliasing off. Didn't occur in d3d mode but that is because anti-aliasing would never turn on for me in d3d, whether I set it through the control panel or through nvmax. Messing around with the framebuffer textures did nothing. So far, unimpressed with these new drivers. Though my other games run fine mind you. Can we try the beta 1.53s too? ^,^ Time to switch back to the 14.70s once again.

Oh and by the way, the scene looks just fine when it is fading in, once the fade is done the graphics corruption pops up.
 
1 - 10 of 10 Posts
Top