Next Generation Emulation banner

1 - 16 of 16 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Okay, I want to make everything extremely clear, so before I begin, let's get a couple things straight. I OWN THIS GAME. I payed cash-money-dollars for it, I didn't download it off of anything. The game works completely fine on a PSX (or PS2).

However, when I run the game with ePSXe, either from the CD or from an ISO I created from the CD, it freezes. Specifically, it freezes right after the movie scene with a car going up a ramp, right before going to Dryfield. (The second mission.)

This one has been asked before a hundred times, I know, but try as I might, I haven't actually seen anyone give a SOLUTION to the problem. So what remedies have I tried? I've tried all of this:

-Forcing PAL/NTSC
-Remaking my ISO from my original CD
-The f4/f6/f7 trick, whatever. I pressed all the f-buttons, before, during, after the freeze happened.
-Of course, savestating over and over and over again to make sure it wasn't a fluke
-Turning off sound
-Every combination of Pete's plugins and Eternal's sound plugin and... well, a lot of plugins.
-Loading the ISO with Daemon Tools (a virtual CD manager) and loading with Pete's CD plugin
-Switching emulators *gasp* away from ePSXe.

I guarantee that my system specs really have nothing to do with the problem, but if someone says they really need them, I'll be glad to post them. In the mean time, I'd really appreciate anyone's help; my brain has been melting at the idea of playing PE2 again.

Oh, and PLEASE, for the love of whatever god you believe in, don't just tell me that my CD is scratched. That's the most half-a$$ed answer you could possibly give me. My CD isn't scratched, because it works fine in a regular PS2.

Thanks again.
 

·
Premium Member
Joined
·
6,341 Posts
Does ePSXe display an error message in the console? Have you tried passing the point without using savestates?
 

·
Premium Member
Joined
·
21,977 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #4 (Edited)
Answers:

No, I haven't been banned before, I just started posting on emuforums for the first time today. However, I've been searching through emuforums for months to find various answers to weird questions. Which brings me to my point: I tried the search function. Oh did I ever. As a matter of fact, I went above and beyond the search function. I went to the archives and searched manually through 20 pages of posts, looking for anything with the word "parasite" in the subject line. Not fun. So believe me, I've looked for an answer.

<edit>Oh, and I forgot to mention. I did run into that post when I was searching for help, and I went to the PPF section, but the only options were "SPA PAL", "GER PAL", "FRA PAL", and "ITA PAL." Spanish, German, French and Italian. Now I don't fully understand the whole patching thing, but I'm pretty sure my PE2 is english. And I misunderstanding something? Correct me if I'm stupid.</edit>
<edit2>Okay, so rather than being lazy, I went ahead and educated myself about patches. I realized that this game is probably european, since they spell armor "armour", and I found a euro PPF and did all the necessary stuff. Game patched okay, according to the log, but still couldn't get passed the car/ramp cinema.</edit2>

And to the other guy, no, there's no error message in the console. It's almost like it's expecting to do something, like it's still loading... but it's not. Unless it takes more than 8 hours to load Mission 2 when I'm running 200 frames/sec. Actually, ePSXe acts like it's under heavy stress; for example, after the cinema ends and the game freezes on a black screen, if I try to display/hide the green menu with the del key, nothing happens. However, I CAN just load state back to before it froze, and everything is fine. Again, it's just acting like it's trying really hard to load... obviously that's not the case though.

<edit>Oh, and playing all the way through until the glitch without using save states does no good either, as I've discovered... :/ </edit>
 

·
Premium Member
Joined
·
21,977 Posts
usually i would suggest PSXeven, PCSX, or a different version of ePSXe (i dont know which you are using but sometimes a switch makes a difference) but it seems like you are a thorough dude, so i won't even bother with the n00b question, "are you SURE you also tested PSXeven and a different ePSXe and PCSX THOROUGHLY".

i dont have PE2 ( i do have PE1...) so i can't test it for you. hopefully someone else does and would attempt to pass that point if you post up your memcard.
 

·
Premium Member
Joined
·
3,093 Posts
I'm gonna try to get my friend's pe2 copy and see if i can pass that point, but it's an european pal version (spa pal, to be precise), so it might work differently. Anyway, have you tried making your own patch? PEOPs cd-r plugin lets you do it. Download it from pete's site. There are instructions about subchannel file (that's it, the patch) creation either on the radme or the version file, i don't remember exactly in wich one. In short, go to peops config, select 'use sbi/m3s sub file', click on the create button, select 'create directly from the cd', and make it. Note that you MUST create it from the original cd, i once tried extracting from my FFIX ISO and didn't work (and it was extracted with alcohol 120%, subchannel info ripped too); however, from the cd worked flawlessly. Once done (it takes about 15-20 minutes), select it and try again. I don't know if it will work, but it's worth a try.
 

·
Premium Member
Joined
·
21,977 Posts
yeah but isn't the "making your own patch" thing with Peops designed to get around copy protection, kind of like making a subchannel file for some games? i've never had a game that needed it so i've never tried. it seems like the PAL PE2 patch is a sort of "hack" for the game to fix it, do you know what i mean?

on a sad side note, i realized that one of my friends in this neighborhood owns an NTSC PE2...but he leaves today for Florida and i won't be able to catch him beforehand :(
 

·
Registered
Joined
·
3 Posts
Discussion Starter #8
Well...

...at least I can finally be happy knowing that even the mod's couldn't help me, so my problem wasn't noobish. (Well, I'm sure someone will contradict me on that one soon enough)

I did try using ePSXe 1.5.2 earlier, but it wasn't even able to load the graphics properly, even with the -pe2 switch and a couple different video plugins. I also used my friend's copy of Bleem! but little good was done there either.

However, I haven't tried PSXeven, simply because I'm losing faith in trying. I'll have to play the game AGAIN up until the glitch point just to see if it works... I've played the game up until the glitch 4 different times now testing theories, and I think I've almost completely destroyed any gameplay value the first mission of the game has.

But I'm getting really good at hunting NMC's.

I'll go ahead and try PSXeven, just because I'm determined to know that I've tried everything. I'll let everyone know if this works. In the mean time, if anyone has any better ideas, ohpleaseohpeaseohplease post them.
 

·
Premium Member
Joined
·
3,093 Posts
You can use your memcard with psxeven, just try with it ;)
 

·
Is this thing on?
Joined
·
2,121 Posts
If you don mind, can you try posting your memcard?
I currently have PE2 with me, but in NTSC U/C format. You can check yours in the front, back, and even sides of the PE2 casing.

Anyways, Is there any methods that enables you to skip MDECs scenes? This would then greatly reduce problems when allowing ePSXe to access the disc which has problems...
 

·
Registered
Joined
·
378 Posts
There are several saves up to Aya's motel room. Haven't gone out the back yet. If you need me to go farther I can.

ePSXe 1.6.0
Petes OpenGL 2
Eternal
 

·
Is this thing on?
Joined
·
2,121 Posts
I apologize...just came back online today.
I will play the game once I have the time...

Thanks n_w95482, I will try using that for my games which have problems with mdecs.

EDIT: I can't seem to d/l the .zip file...
 

·
Registered
Joined
·
378 Posts
fireblaster_lyz said:
I apologize...just came back online today.
I will play the game once I have the time...

Thanks n_w95482, I will try using that for my games which have problems with mdecs.

EDIT: I can't seem to d/l the .zip file...
I just downloaded it from work, though I can't play it here....

I'll post it in RAR later if necessary. I was hoping that zephyr could use it to get past the problem area, and then run into some other problem so that a mod could identify the problem easier. I'm well into the second disc right now, so I can't really help, since I don't have his particular issue.

This might seem dumb, but have you tried skipping the cutscene? PE2 lets you do that with START.
 

·
Registered
Joined
·
3 Posts
I play a German version, so the savegame dont work. i tried to change the game id in the memory manager and that this savegame to pal but it did not work. please help me, what could i do?
 
1 - 16 of 16 Posts
Top