Next Generation Emulation banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hey all,

I'm new to all the emulation stuff (aside from playing Chrono Trigger on an SNES emulator, but that didn't take much setting up). I decided to try to get thorugh Xenogears, which I enjoyed getting halfway though a couple years back but didn't finish; my PS2 is being used extensively by roomates and friends playing DDR, so I figured I'd try emulating it :)

So, I've got ePSXe on my computer and set up, and I made Xenogears Isos with Alcohol. No problem getting it to actually run, but I'm getting weird speed issues. I'm using Pete's OGL2 2.6 and the default sound plugin. In FMVs, everything works nomally. For everything else, the sound and video always stay synched up, but they run at the wrong speeds - especially in scenes with gears. I've only gotten through the opening and into Fei's house so far, but the fight scene, both overlooking the village and in combat view, both ran very slow, and Fei's House wasn't too bad, but felt sluggish. However, the limitation isn't the computer; I uncapped the FPS, and both went simply blazing along :)

Any tips on how to tune the speed to get the right feel to the game?

Computer Specs:
Athlon 64 Mobile 3400+
1Gb DDR400 Ram
Radeon 9600 Mobility Pro Turbo 128mb
 

·
Premium Member
Joined
·
21,977 Posts
try using Eternal for sound. you might want to try PSXeven to see if that works too.
 

·
Premium Member
Joined
·
3,093 Posts
Also, post your current configs for the plugins, or else i don't know how can we tweak them :p
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Note that I've randomly tried a bunch of settings. This is what it's currently at. I've got it running properly when you're playing as Fei and walking around on the map, but the 3D cutscenes drop it down to 40-45fps.

Pete's OGL2 Setting:
Fullscreen
Window Size 640x480
Internal* resulution: 0
Texture Filtering: 0
Hi-Res Textures: 0
Gfx Card vran: 0 (autodetect) <-- I also tried this at 128
Show FPS: Yes
Use FPS Limit: Yes
Autodetect FPS: Yes
Use Frame Skipping: No
Off-Screen: 1
Framebuffer Effects: 2
Framebuffer Upload: 1
Screen Filters/Shaders: None
Scanlines: No
MDEC: Yes
Disable Screensaver: Yes
GF4/WinXP: No
Special Game Fixes: None

Sound: Eternal SPU 1.41
The first three sound options (all but the IRQ hack) are on, all the Eternal options are on default


I know these are really low-quality settings, but I'm just trying to figure out how to run it without the massive performance problems - you'd think a top of the line, 6 month old laptop would be able to run a PSX game and with some killer graphics settings without choking:)
 

·
Premium Member
Joined
·
21,977 Posts
im not even going to read that, there's a paste button in Pete's plugins, just use that ;)

anyway, defrag your drive. that could be causing the problem.
 

·
Premium Member
Joined
·
26,303 Posts
>Framebuffer Effects: 2
>Framebuffer Upload: 1

Try setting these to 3/2
Could you also as Hushy suggest use the copy to clipboard function. You missed nemerous options.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Kane-Sama said:
Could you also as Hushy suggest use the copy to clipboard function. You missed nemerous options.
Oops, sorry, missed that it was there.

Playing around with it this morning, I tried PSXeven, and it's working far better - it stays right at 59-60fps almost all the time, and rarely drops down to 55, even with the graphics options turned up, so I guess that solves the problem. Thanks for trying to help me, even though I didn't help you out with it much.
 
1 - 7 of 7 Posts
Top