Next Generation Emulation banner

OpenGL and AH3650 video card

3871 Views 37 Replies 7 Participants Last post by  Squall-Leonhart
A couple of days ago I bought the Asus AH3650 Silent AGP video card. This is the most recent AGP Radeon type card I could get hold of.

The problem is that even if DirectX works fine, I can't use OpenGL applications. OGL query tools identify the video renderer as 'GDI generic' and card's vendor as "Microsoft Corporation" which is very bad. To experiment I installed Windows XP (SP2) on a new partition a couple of times, downloaded some older Asus drivers, tried to install the most recent AMD drivers - nothing worked so far. OpenGL games don't work.

But depending on the driver supplier, the results differ. AMD drivers usually make OGL apps crash either producing exceptions or "Context creation errors" (don't know what that means though).

I have a Pentium IV 2.66 GHz processor, 2 GB RAM, my primary OS is Windows XP (SP3).

If you have any idea what I can do in this situation, please don't keep it a secret.
1 - 13 of 38 Posts
Overinstall the drivers, others have had issues with the Catalyst ICD not registering.


asus card...

uninstall the Asus enhanced display driver, and all asus versions of the drivers then download the 9.7 kit from
Can you post some screenshots of Realtek VR's opengl extension viewer.

I unistalled the Asus drivers completely using Driver Sweeper utility in VGA mode. I deleted everything manually that the Sweeper couldn't handle. Then I rebooted and installed this package: Catalyst AGP Hotfix - Radeon HD 3000 and Radeon HD 2000 Series AGP products

The system works normally, but OpenGL applications crash producing errors stating that "the other memory is probably corrupt" and then "Context creation error".


Edit: forgot to mention that the same drivers work perfectly under Ubuntu.

Ok, search your system for ATKOGL32.dll

if you find it, remove it from the hdd,
you will also need to remove ATKOGL from the registry

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\OpenGLDrivers
yes, its a component of the Asus enhanced driver and isn't removed by driversweeper.
no it can't. :rolleyes: ATKO is not a autostarted app or service.

Learn > Comprehend > Post.
the system icd is definitely not being started

did you atleast check that registry key i mentioned? try deleting the opengl key itself then reinstalling the drivers.
Check in add-remove programs for any asus software and remove them.
hmm.. im unsure for now.
Actually, the "Learn > Comprehend > Post" thing you have said is against you not me. Autoruns does also show some drivers because sometimes Windows treat them as "services" and it can open the right registry for each of them. I have used this program for more than a year.

Have a better behaviour and don't try to troll.
No display driver, or opengl for that matter is installed as a user mode service.
System level services are never displayed by applications like that.
Evaldas, if you like, i can help you fix this using Teamviewer, theres some idea's i have, that would take more time writing then it would to just look at the issue myself.
I did email you!!
Gigabyte and sapphire are equal in terms of quality, just go with the cheaper.

AGP GART driver.
i should've known.
1 - 13 of 38 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.