Next Generation Emulation banner
1 - 13 of 13 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I just bought myself a Geforce 6600GX over my previous Radeon 9100 and the emulation framerate seems to have improved a little but it's still not perfect. I am posting this thread because I want to find out whether or not anyone else is encountering the same glitches as me (and that they are standard glitches you would find on any pc) or whether or not there is something wrong with my settings.
First of all I tested both plugins with cloud's omnislash technique which I consider to be one of the most graphic demanding sequences in the game. Both in opengl 1.7 and 2.5 this sequence remains at a steady 58-59 fps but as soon as I turn the framebuffer effects to 3 (Full) then the frame rate drops temporarily in and out of the 30s range and I get slowdown - it really doesn't seem to matter whatever other setting are enabled it's the framebuffer that is causing this evil. However I have found that if I switch framebuffer effects to anything but option 3, the system hangs (with choppy music) right before entering a battle sequence and the swirl effect doesn't display at all. The simple answer would be to use opengl 1.7 which incidentally also displays the game at a better resolution than 2.5 for reasons discussed by Stevedroid in another thread. However...(sigh) with 1.7 I get an annoying glitch in right after the experience screen where the screen flashes before exiting to the main game.
Finally (the SPU settings are fine) the audio skips a tiny bit every 6~10 seconds or so. Anyone else encountered these issues? I'd be most grateful for any responses.
 

·
Premium Member
Joined
·
6,284 Posts
SPU issues, I'd bet on you having SPU Irq hack enabled in the sound options, well, turn it off, as for OpenGL 2.5 (it's 2.7 now, btw) being lower res than 1.76, use very high X and very high Y in OpenGL2, will make it look just as "hi-res" as 1.76, with better compatibiliy (your gfx card supports it, since only nvidia cards supports very high X, or is it Y ? dunno about the recent x1000 ATi cards though)
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 · (Edited)
No, neither of the SPU IRQ boxes are checked.

EDIT: I upgraded from 2.6 to 2.7 of pete's OGL2 plugin. I have found that in some areas such as during the bombing mission at the beginning of the game, the game doesn't stall at the battle swirl with the framebuffer set to 2 rather than 3 but in other areas such as on the world map it does. Any ideas?
 

·
Premium Member
Joined
·
6,341 Posts
In case you want to keep using Pete's OpenGL plugin (OGL2 would be a better choice), try setting framebuffer textures to 0 and framebuffer access to 4. Hopefully the pausing with the battle swirl will disappear with those settings. What processor do you have?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 · (Edited)
Thank you everyone for your helpful efforts and comments!

In response to the first question: no I am not running from the CD I am running from an iso that I created from my legally owned copy of FFVII international.

I have a P4 2.6Ghz HT processor running with 1GB ram on SSSPSX (I have tried other emulators and have found the issues to be the same if not worse on them).

I am now using the OGL2 2.7 plugin all the time since I can't stand that annoying screen flicker that appears after the experience screen! :cuss2:

I will try the settings that you mentioned later on tonight. Also, just thought I would ask if anyone gets perfect sound on FF7 (I mean no skips at all, not even tiny skips). As I mentioned in my first post, I keep encountering these confounded skips every 6~8 seconds and these seem to get more frequent/worse if there is a lot of action going on in the scene or if it is graphically intense.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #8 · (Edited)
I am not getting any sound pauses before going into battle it's a habitual thing that happens every 6~8 seconds no matter what situation I'm in. Is the audio on everyone else's computers completely smooth with absolutely no skipping?

EDIT: I am using Eternal SPU plugin v1.41. Async on smooth Iori's reverb 32 buffer.

Also I isolated the stuttering before entering battle problem and it had to do with the X resolution which I had set to very high. I thought that since my new card was not ATI but Nvidia it would be able to handle the setting but apparently not. I had tried it before and it HAD worked but that must have been when entering battles outside the world map area (strange huh?).

The sound problems I was experiencing with some instruments not playing that occured right after I installed my ATI card on this computer is now also fine (since I formatted my hard-drive) :hdbash:
I guess that using multiple video cards can really mess with your settings and stuff.

But the oddest thing of all is that I get better FPS with the same settings on my ATI radeon 9100 card which is over 3 years old than my brand spanking new geforce 6600GT...Anyone else had this?
 

·
Registered
Joined
·
654 Posts
Say...you wouldn't happen to have the frame rate set to 60, would you? Your description leads me to think you're playing a PAL version of FF7, in which case your frame limit should be 50. This might help explain your sound hitch.


Dan
 

·
Premium Member
Joined
·
6,341 Posts
Oh duh, I just remembered, I had similar problems when I had the async mode set to Smooth. Every 5-8 seconds, the sound would skip a little bit and the framerate would quickly drop to somewhere in the 40's. Setting it to Simple fixed the problem.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top