Next Generation Emulation banner

1 - 20 of 30 Posts

·
Registered
Joined
·
5,442 Posts
Discussion Starter #1
Great job Nickk.It works on my 810 chipset decently.But still going by initial response I find it similar to older Nikk d3d (which created a lot of confusion).
Ok first can you tell me if there is any way to get around those black backgrounds problems?
Secondly F8 says picture done but doesnt come up(isnt saved under snap,where is it?)
I may post some shots in coming time if I get through those two problems.

Once again good job and I will wait for further versions for sure.
 

·
Registered
Joined
·
1,756 Posts
Originally posted by prafull
Great job Nickk.It works on my 810 chipset decently.But still going by initial response I find it similar to older Nikk d3d (which created a lot of confusion).
Oh really? It must be coming along nicely then :) And note NIK's name has one "K" while my name as an additional "c" and "k" :) (or just 2 "k"s that's how Bobbi spells it.)

Ok first can you tell me if there is any way to get around those black backgrounds problems?
What do you mean exactly? I know that there's a few problems where MDECs don't show up correctly. The weird thing is though if I multi texture the screen texture onto itself they usually appear? :confused: I'll look into this.

Secondly F8 says picture done but doesnt come up(isnt saved under snap,where is it?)
Uh, hey, actually I forgot to put that feature in. :emb: For now, when the window's focused, just press alt+PrintScreen and it will copy the screen image onto the clipboard. (That's how I take all of my screen shots :)

I may post some shots in coming time if I get through those two problems.

Once again good job and I will wait for further versions for sure.
Yeah! Eventually NextGL and Next3D will have synced updates since they are so similar in structure :)

Thank you!
 

·
Registered
Joined
·
5,442 Posts
Discussion Starter #3
I meant the type of backgrounds shown in below snap.It appears in almost every games and many ingame texts too are surrounded by black boxes.Its surely a texture problem.Another initial observation is smoke effects are not perfect.Ok lets talk about some of my favourite games(those were available on my hard disk right now).

dino crisis 2- black boxes,In cut scenes characters become sort of transparent.
RE-2- decent performance,background problem much less.
Brian Lara Cricket-really impressive,menus that were missing in almost every other plugin except pete's soft show up(thats great for me),some backgrounds are black,some ingame fonts are messed up.(mdecs not showing)
MGS-few glitches need some work I guess.(mdecs not showing)
World Eleven4-works fine except black boxes(mdecs not showing)
Carmageddon-Almost perfect
Alone in Dark-black boxes,cut scenes messy(mdecs not showing)

Its really very good keeping in mind thats the first release.Speed is really good and I am very much optimistic about this plugin.

Note... I just found out a similar problem discussed in

http://www.ngemu.com/forums/showthread.php?s=&threadid=6528

May be its of some help.
I have latest drivers for my 810 chipset available on intel site and dont have such black boxes problems in any other plugins.
 

·
Registered
Joined
·
1,756 Posts
I think this might have something to do with your drivers. I'm going to check out what D3D operations the 810 supports so that I can fix your problem in a future version.
 

·
Premium Member
Joined
·
8,586 Posts
Originally posted by Asfaloth
prafull, I just had the exact same problem... try turning FSAA off, that did it for me.
I don't think he has a video card that has FSAA.. Its an onboard integrated video card meaning its cheap and probably doesn't do FSAA.. Or does it?
 

·
Registered
Joined
·
5,442 Posts
Discussion Starter #8
Nickk,
My computer doesnt support 32 bit colours.
Neway Thanks a lot for trying to help me.Until now I saw about 5-6 people using 810 chipset on our NGEMU site and many people here in India are using this chipset.
One of my friends have newer (and probably better) vesion 810E of this chipset so I will try the plugin on his computer and then post about it.

Another thing I noticed and may be of some help to you is in Segu's d3d 1.3 plugin.There is a option "Draw mdec and direct image",if this option is disabled then it also shows similar black background problems (but much more weird).

I am hoping (and praying) that this problem can be and will be solved.


Fivefeet8 and asfaloth most probably it doesnt have fsaa.Neway how to turn it off?
 

·
Registered
Joined
·
1,812 Posts
Right, I forgot he has an 810. Those most definitely don't have FSAA :p So that's not the problem. Since the black boxes only occur with NickK's GPU, I guess the best solution is to switch GPUs, eh?

But keep up the good work, NickK! ;)
 

·
Registered
Joined
·
1,756 Posts
NeoJag, if you're using windowed mode make sure the color depth is set to the desktop's color depth. (This will be corrected in the future.)
 

·
king Kong Never Dies!
Joined
·
2,105 Posts
I NEVER seen the problems prafull talked about BEFORE i installed v21.83 and changed my color depth to 32 bit.AFTER i changed it back to v21.85 and 16 bit color, the problem solved.I am not sure it is either the driver or color depth problem anyway, but If the problem has something to do with the fsaa, then this is really weird...


p/s i always turn on my 4xfsaa.
 

·
Registered
Joined
·
3,258 Posts
Originally posted by NickK
NeoJag, if you're using windowed mode make sure the color depth is set to the desktop's color depth. (This will be corrected in the future.)
hum, thkx m8, it worked ;)
 

·
Premium Member
Joined
·
8,586 Posts
Originally posted by Nightmare
I NEVER seen the problems prafull talked about BEFORE i installed v21.83 and changed my color depth to 32 bit.AFTER i changed it back to v21.85 and 16 bit color, the problem solved.I am not sure it is either the driver or color depth problem anyway, but If the problem has something to do with the fsaa, then this is really weird...


p/s i always turn on my 4xfsaa.
AS said in a previous reply to this thread, Prafull's computer doesn't have FSAA.. He doesn't have a geforce2.. Its an integrated video card meaning its probably cheap and doesn't do FSAA.. Its most likely a hardware or driver problem pertaining to his video card.. And maybe an incompatibility to Nikks current d3d pluggin..
 

·
Registered
Joined
·
1,756 Posts
Hey prafull, could you download and run this program that I made? It will test the alpha comparing functions that your video card supports in Direct3D. If you do, please post the results. It might help me to fix your problem.
 

·
Registered
Joined
·
5,442 Posts
Discussion Starter #17
Originally posted by NickK
Hey prafull, could you download and run this program that I made? It will test the alpha comparing functions that your video card supports in Direct3D. If you do, please post the results. It might help me to fix your problem.
Umm how this is supposed to run? I mean I can run it in any directory or need to be in some particular place?
Neway running it gives a text file with this

"D3D8Test v1.0
-------------

Alpha compare capabilities
--------------------------
"
Nothing else comes up.
 

·
Registered
Joined
·
1,756 Posts
Well, I guess I need to think of a better idea on how to fix your problem now. The fact that it says nothing after the last line is because your video card supports all types of alpha comparason tests. :)
 

·
Registered
Joined
·
5,442 Posts
Discussion Starter #20
Hi Nickk,
Two new developments that I would like to discuss here.I am attaching two images as well (it will help I guess).Firstly I think the "hardware" option below "brightness level"used to work earlier but now even on selecting that option and saving the settings it automatically deselects.As a result of this I am getting really dark and dim image.
Secondly and more importantly I tried almost all the options and combinations in order to remove those black boxes and I found out that when I select "VSYNC" I get blinking images(with some other glitches) and those black boxes seems to be removed for some part of the second(It blinks many times within a second itself).Textures continue to be drawn and disappear.I think the images will give a proper scenario of the situation.
 
1 - 20 of 30 Posts
Top